PDA

View Full Version : Myanmar Font Installation and Common Problems



mgngapyin
November 9th, 2012, 08:03 PM
I will edit this post little by little, and make it as one-stop guide for common font issues in Myanmar. I hope we don't need to answer the same question again and again on FB groups, blogs, Myanmar forums, etc.

I. How many kinds of Myanmmar fonts are there?

Four as far as I know
1. Unicode
2. Ayar - Unicode, but encoding is slightly modified
3. Zawgyi - Non-Unicode
4. ASCII - Winn Innwa

II. How to installl Unicode fonts?

If you're using Ubuntu 12.10 (Quantal), you don't need to install Unicode fonts. It's already included in Ubuntu. You can find it in the package Fonts-sil-padauk.

If you're using Ubuntu 12.04 (Precise) or later versions, you can still install Fonts-sil-padauk from the Ubuntu Software center, Terminal or Synaptic Package Manager.

Other Unicode Fonts ???
You can find other unicode fonts in


http://www.myanmarlanguage.org/unicode/myanmar-fonts-which-follow-unicode-rulesEthnic Unicode Fonts
Tharlon supports some ethnic languages
There are other unicode fonts too. I'll add later.

III. How to install Zawgyi and other Truetype fonts (.ttf)?

Download Zawgyi 2008 from google code


http://code.google.com/p/zawgyi-keyboard/downloads/detail?name=ZawgyiOne2008.ttfDouble-click to open it. It'll open the Font Viewer.
Click Install.


### Should I install Zawgyi 2009?

No. Zawgyi 2009 is incomplete font. Though you can install it in Ubuntu, font may be displayed differently. Windows 8 even detects it as a corrupted font. And most people use Zawgyi 2008.


### What happended if I click Install in Font Viewer?

In 12.10 (Quantal), the font is installed tp ~/.local/share/fonts directory.

In 12.04 (Precise), the font is installed to ~/.fonts directory.


### Where is ~/.local/share/fonts?

Dot files/folders ( . ) are hidden in the HOME folder.
Open Home folder. Click Menu View Show Hidden Files.
Open .local share fonts
There, you'll see ZawgyiOne2008.ttf

In Precise (12.04),
Open HOME folder
Open .fonts folder
There, you'll see ZawgyiOne2008.ttf

IV. How to install multiple fonts?

Copy and paste the fonts to ~/.local/share/fonts OR .fonts directory.
If you can't find the folders, you'll need to create it yourself.

How to create a new folder ?
Right click >> Create New Folder

V. Problems, Problems that everyone thinks

Though there is Unicode font preinstalled and most of the unicode fonts are supported in many Ubuntu Applications, many people still want to use Zawgyi for personal reasons.

Common Problems in Quantal (12.10)

Though I installed Zawgyi, fonts are incorrectly displayed in Title bar of Firefox.

http://i.imgur.com/ECmY4.png




Or even worse, Facebook friends' names, page names or group names appear like this.

http://i.imgur.com/7QuCb.png

So, what's wrong here?

Nothing.

It's not the Ubuntu problem. It's the configuration problem.

Let's start with the Facebook problem first.

Ubuntu 12.10 has Unicode (Padauk font) preinstalled.
When you install Zawgyi, Zawgyi overides the Padauk font because it has more encoding points.

But ...., Zawgyi is incomplete.

If you analyse it more, you'll see that the place where Zawgyi doesn't appear are using Bold fonts.

Padauk is replacing these places instead of Zawgyi.
Why? Simple, because it is better.

OK. How to solve it?

Remove Padauk ??? --- A very bad idea. Why remove when it becomes default?

The solution -- Change Font Settings in Firefox

In Firefox, click on Menu Edit Preferences
A new window will appear.
Click Content
Click Advanced in Fonts & Color
You'll see Fonts for Western & a list of settings.

Click Western in Fonts for
Choose Other Languages
You'll see ( Proportional, Serif, San-serif, MonoSpace & their fonts)
Change the Serif font to Zawgyi One.
Click OK.
Close the Firefox Preference Windows.

Now, you can see Facebook Names in Zawgyi properly.

Problems in Chrome and Chromium ??

In Chrome/Chromium, Zawgyi replaces Padauk completely, so you don't need to change anything if you did like most people did.
If something is not right,

Type chrome://chrome/settings/fonts in the URL bar
Change the Sans-serif font to Zawgyi-One or the font you used.

Title Bar Fonts .... To be continued

mgngapyin
November 9th, 2012, 10:23 PM
How to Change Title Bar Fonts

This post is written in Zawgyi. If you can't view Myanmar text, read the above post.

Firefox မွာ font ျပင္သြားျပီးရင္ အခု Windows Title Bar က font ကို ျပင္ပါမယ္။
Title Bar Font ကို ျပင္ဖို႕အတြက္ Gnome Tweak Tool or Ubuntu Tweak ေဆာ့ဝဲလိုပါတယ္။

How to Install & Use Gnome Tweak Tool
1. Internet ခ်ိတ္ထားဖို႕လိုပါမယ္
2. ဘယ္ဘက္အေပၚနားက Ubuntu Icon (Dash) ေလးကို ႏွိပ္ျပီး Dash ကို ဖြင့္လိုက္ပါ။
3. Software Center လို႕ရိုက္ထဲ့ပါ။ ေပၚလာတဲ့ Ubuntu Software Center ကို ႏွိပ္ပါ။
4. Software Center Search Box မွာ gnome tweak tool လို႕ ရိုက္ရွာပါ။
5. Tweak Tool ဆိုျပီး ေပၚလာပါမယ္။ Select လုပ္ျပီး Install ကို ႏွိပ္ပါ။
6. Password ေတာင္းရင္ ရိုက္ထဲ့ပါ။ ခဏေစာင့္ပါ။
7. Install လုပ္ျပီးသြားရင္ အစိမ္းေရာင္ ျမွားေလးေပၚလာပါမယ္။ ဘယ္ဘက္ Launcher မွာ Icon တစ္ခုတိုးလာပါမယ္။ Icon ကို click လုပ္ပါ။
8. Fonts ကို ေရြးပါ။
9. Windows Title Font - Ubuntu Bold ကို ႏွိပ္ပါ။
10. Zawgyi-One ကို ေရြးပါ။
11. တျခား font သံုးမယ္ဆို Zawgyi-One အစား တျခား font ကို ေရြးေပးပါ။

How to Install & Use Ubuntu Tweak
1. Download Ubuntu Tweak from http://ubuntu-tweak.com/.
2. Terminal ကို ဖြင့္ပါ။ (Dash >> Terminal လို႕ရိုက္ထဲ့ပါ)
3.

sudo apt-get update
sudo apt-get install gdebi လို႕ရိုက္ပါ။
4. Open Downloads Folder
5. Right click >> Ubuntu Tweak_0.8.2....deb
6. Open with GDebi Package Installer ကို ႏွိပ္ပါ။
7. Install Package ဆိုတာကို ႏွိပ္ပါ။
8. Password ရိုက္ပါ။ ခဏေစာင့္ပါ။
9. After installation, Dash >> Ubuntu Tweak
10. Tweaks ကို ႏွိပ္ပါ။ Fonts ကို ႏွိပ္ပါ။
11. Windows Title Bar font မွာ Zawgyi One ကို ေရြးေပးပါ။
12. တျခား font သံုးမယ္ဆို တျခား font ကို ေရြးပါ။

mgngapyin
November 10th, 2012, 12:52 AM
Ubuntu Myanmar Version & Zawgyi Font Issues

You may not know it, but you can now use Ubuntu in Myanmar starting from 12.10 (Quantal). You can choose Myanmar during the installation or add Burmese in Region & Language later.

Ok. I'm using Ubuntu Myanmar Version. I installed Zawgyi and everything messed up like this. I can't read anything. Alien Words.

http://i.imgur.com/lBWy5.png

Why?
Because Ubuntu is translated into Myanmar using Unicode. Unicode is internationallly recognised and widely used. (not in Myanmar though :()

Why not Zawgyi?
Zawgyi is not maintained anymore. License not clear. Internationally not recognized - No one will support it. That's sure. Some issues deep.

OK. My Ubuntu Myanmar Version is messed up now. How to solve it?
Remove Zawgyi font.

How? I can't read anything.
That's not true. If you read it carefully, you still can.
Click on the Folder icon in Launcher.
Go to Menu
Click V မြင်ကွင်း
Click H ဝှက်ထားသောဖိုင်များပြပါ Ctrl+H
Open ~/.local/share/fonts folder
Delete ZawgyiOne2008.ttf
Wait for a few seconds, and everthing will be back to normal.

No, No. I can't go anywhere because I can't read.
Ok. close everything & go to Desktop.
Press keyboard shortcuts ( Ctrl + Alt + T)
Terminal will open. Copy this code (Ctrl+C)

rm ~/.local/share/fonts/ZawgyiOne2008.ttfPaste into Terminal (Ctrl+Shift+V)
Wait for a few seconds, and everything will be back to normal.

OK. I want to use Ubuntu Myanmar Version. How to prevent Zawgyi from changing the font?
You can change it with the font.conf file.
First, delete Zawgyi Font and make it as original.

Then create a new empty document in ~/.config/fontconfig/ folder
Name it as conf.d (note: there is a dot " . " in file name)
If you can't view it, press Ctrl + H to show hidden files.
Or you can go to menu >> V မြင်ကွင်း >> H ဝှက်ထားသောဖိုင်များပြပါ
Edit the conf.d like this (just copy and paste)



<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>

<!-- Use Unicode as default-->
<match target="pattern" name="lang" >
<test name="lang" qual="any" >
<string>my</string>
</test>
<edit name="family" mode="assign">
<string>Padauk Book</string>
</edit>

</match>
</fontconfig>
Save it (Ctrl + S) or သိမ်းဆည်း

Open Terminal & type

fc-cache -f -vto make sure let Ubuntu knows about the change & make sure everything works fine.

type

fc-match "my"If you see Padauk Book, it is fine.

Now Open Zawgyi One with Font Viewer and install it.
Wait for some minutes. Nothing changes, right?
It is because we've prevented Zawgyi One from chaning the font.

to confirm it again, Open Terminal & type

fc-match "my"Padauk-book is still the default.

Padauk Font is too small. You can change the font size in font.conf OR Use Tharlon font, which is bigger.

How To Make Tharlon as default?
Open ~/.config/fontconfig/conf.d file & replace Padauk Book with Tharlon.
Save it. Wait for a few seconds. You'll see that it looks bigger.

http://i.imgur.com/CqiHR.png

Need to view Facebook, Webpages in Zawgyi?
Use Firefox Zawgyi to Unicode Converter Add-ons - https://addons.mozilla.org/en-US/firefox/addon/myanmar-converter/
Use Tagu Extension for Chrome - https://chrome.google.com/webstore/detail/tagu/ddjpcdpfemhkibhpmgcdbfajdhgpegdk

Need to switch back to Zawgyi temporarily
Open font.conf and replace with Zawgyi-One
Save and wait for a few seconds

Need an easier way to switch Unicode (Tharlon) & Zawgyi back and forth
Use my-fs-cli from Ubuntu Myanmar Loco Team

Prolems not solved?
Zawgyi removed. font.conf not created, but Zawgyi remains
most likely cause
1. You installed the Zawgyi to System level (not the local folder / Home folder)
2. Where are system level fonts?
/usr/share/fonts/
If you installed Zawgyi from Ubuntu-mm launchpad, the fonts are there

/usr/share/fonts/mm/ZawgyiOne2008.ttf
/usr/share/fonts/mm/Zawgyi-Tai.ttfIf you installed mm-kb.deb keyboard (offline version), the fonts are there

/usr/share/fonts/mm/ZawgyiOne2008.ttfto remove these, you'll need sudo access or simply use the font.conf

Change the font in font.conf, but nothing changes
most likely
1. The font you changed is not installed.
2. Try refreshing the font-cache

fc-cache -f -v3. Still not solved. Log out and log in again.

mgngapyin
November 11th, 2012, 09:24 PM
Chrome/Chromium & Myanmar Font Issues

I'll be using a lot of pictures. If you've very slow connection, please kindly bear with me.

In the past, Chromium can't display Myanmar text properly.

Zawgyi Problems - Words become mixed if they are typed without a word break.

http://i.imgur.com/2j2yJl.png


Unicode Problems - Worse. Can't display at all with most unicode fonts.

http://i.imgur.com/W16rql.png


Padauk can display some text, but still wrong.

http://i.imgur.com/YtzaRl.png



How to Solve it?

Until recently there is no solution.

But "Now", Thanks to the great work by Chromium developers,

chrome/chromium texts are displaying properly.(see bug here - https://bugs.webkit.org/show_bug.cgi?id=90362 ) Special Thanks to Kenichi Ishibashi. :KS


You can test the Chrome beta version if you want.

https://www.google.com/landing/chrome/beta/

Enter chrome://chrome/settings/fonts in the URL bar
Change the San-Serif font to "Zawgyi" or "Padauk" or "Myanmar3" or "Tharlon" or whatever Myanmar fonts you like. Most of them are working.

In the new version,

Zawgyi is correctly displayed. No mixing of words anymore.

http://i.imgur.com/l28v2l.png


Unicode is displayed properly too.

Padauk

http://i.imgur.com/84IBql.png

Myanmar 3

http://i.imgur.com/Xc5O6l.png


By the way, in myanmar3 font, " U " is wrong, right?
It is because it is incorrectly typed. " U " has its own unicode point. Someone typed 3 unicode points by mistake ... Oo + Lone Kyi Tin San Kat + : ... Though they looks like the same, they're not.

That's why I wish everyone use Unicode. Better search index, sorting, spell-check, ....

Unfortunately, there are very few Chromium developers for Ubuntu. So If you want to test Chromium new version, you'll need to build it yourself or just use Chrome Beta.

If you're a developer, please help in Chromium Ubuntu development.

gipsyhnh
November 23rd, 2012, 10:46 AM
Nice Jobs

mgngapyin
December 8th, 2012, 11:33 PM
I have found that changing fontconfig with the "lang" pattern results in ugly English text with some unicode fonts, so I'm trying to correct this with a new fontconfig file.



<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<alias>
<family>sans-serif</family>
<prefer>
<family>Droid Sans</family>
<family>Padauk</family>
</prefer>
</alias>
</fontconfig>
What it does is chaning the sans-serif font with fonts in <prefer> tags. Droid Sans will be used first. If there is no Myanmar characters in Droid Sans, it will use Padauk. The English text looks better this way. Since most of the GUI fonts are sans-serif, it should be fine this way.

The drawback is you need to change font settings for browsers.

For Firefox, type
about:config in the address bar, search for
font.name.sans-serif.x-unicode and change the string to Zawgyi-One to use Zawgyi and default for unicode.

For Chrome/Chrome, go to
chrome://settings/fonts & set the Sans-serif font to Zawgyi or Unicode.

yjsu
December 21st, 2012, 04:29 AM
why can't I see myanmar font in terminal well,I can see myanmar font in gedit like this:
http://ubuntuforums.org/attachment.php?attachmentid=228944&stc=1&d=1356060444
but it display in terminal like this:
http://ubuntuforums.org/attachment.php?attachmentid=228945&stc=1&d=1356060444
why and how to solve it?

Nwe Nwe
December 21st, 2012, 06:32 AM
[QUOTE=mgngapyin;12345828]I will edit this post little by little, and make it as one-stop guide for common font issues in Myanmar. I hope we don't need to answer the same question again and again on FB groups, blogs, Myanmar forums, etc.

I. How many kinds of Myanmmar fonts are there?

Four as far as I know
1. Unicode
2. Ayar - Unicode, but encoding is slightly modified
3. Zawgyi - Non-Unicode
4. ASCII - Winn Innwa

II. How to installl Unicode fonts?

If you're using Ubuntu 12.10 (Quantal), you don't need to install Unicode fonts. It's already included in Ubuntu. You can find it in the package Fonts-sil-padauk.

If you're using Ubuntu 12.04 (Precise) or later versions, you can still install Fonts-sil-padauk from the Ubuntu Software center, Terminal or Synaptic Package Manager.

Other Unicode Fonts ???
You can find other unicode fonts in


http://www.myanmarlanguage.org/unicode/myanmar-fonts-which-follow-unicode-rulesEthnic Unicode Fonts
Tharlon supports some ethnic languages
There are other unicode fonts too. I'll add later.

III. How to install Zawgyi and other Truetype fonts (.ttf)?

Download Zawgyi 2008 from google code


http://code.google.com/p/zawgyi-keyboard/downloads/detail?name=ZawgyiOne2008.ttfDouble-click to open it. It'll open the Font Viewer.
Click Install.


### Should I install Zawgyi 2009?

No. Zawgyi 2009 is incomplete font. Though you can install it in Ubuntu, font may be displayed differently. Windows 8 even detects it as a corrupted font. And most people use Zawgyi 2008.


### What happended if I click Install in Font Viewer?

In 12.10 (Quantal), the font is installed tp ~/.local/share/fonts directory.

I use Ubuntu 12.10 (Quantal), after installation, i can see Myanmar font but they are not true. So, I install zawgyi.ttf and it has under ~/.local/share/fonts. Now, I can see clearly , but I can't type it, I can't see zawgyi in keybord layout. Can you kindly share how to change keyborad layout. Thanks in advance.

mgngapyin
December 21st, 2012, 10:53 AM
why can't I see myanmar font in terminal well,I can see myanmar font in gedit like this:
http://ubuntuforums.org/attachment.php?attachmentid=228944&stc=1&d=1356060444
but it display in terminal like this:
http://ubuntuforums.org/attachment.php?attachmentid=228945&stc=1&d=1356060444
why and how to solve it?

Unfortunately, I don't know how to solve this, yjsu. I've tested mlterm, rxvt-unicode terminal emulators, but no success at all. I think Myanmar unicode is not yet supported in Gnome-terminal. Or we might need a better unicode font for console. Since most people refuse to adopt using unicode, everything lags behind. I think you should ask this question at http://myanmaritpro.com or http://mysteryzillion.org or Myanmar Unicode Facebook page, where the Myanmar unicode initiators visit often.

mgngapyin
December 21st, 2012, 11:01 AM
Now, I can see clearly , but I can't type it, I can't see zawgyi in keybord layout. Can you kindly share how to change keyborad layout. Thanks in advance.

Hi Nwe Nwe,

You can follow the steps mentioned in https://www.facebook.com/groups/ubuntu4mm/doc/442170362469082/

Download the mm-kb.deb file
Copy it to Desktop
Open Terminal
type


cd Desktop
sudo dpkg -i mm-kb.deb

Open Dash >> Ibus
Click "input methods"
tick "customize active input methods"
select an input method >> burmese >> zawgyi


Shortcut is Ctrl+Space. (You can customize it)
Pressing Left_Shift will also change Zawgyi to English, but don't use the Left_Shift. English texts will spread, and a little bit ugly.

You can view the steps on Youtube. http://youtu.be/0yttttL7jFo

mshan
December 31st, 2012, 04:21 PM
ubuntu 12.10 အတြက္ ေဇာ္ဂ်ီ ကီးဘုတ္ ႐ွိပါသလား၊ ဝင္းဒုိး မွာ သုံးရတဲ႔ လက္ကြက္ပုံစံနဲ႔ တူတာကို လုိခ်င္တာပါ၊ system setting --- keyboard layout ကုိ သြားၿပီး Burmese ကီးဘုတ္ကုိ ေ႐ြးၿပီး ျမန္မာလုိ ႐ုိက္လုိ႔ ရတာ သိပါတယ္၊ ဒါေပမဲ႔ အဲဒါက Zawgyi One font မဟုတ္ပါဘူး၊ Libre ထဲမွာ စာ႐ုိက္ဖုိ႔ Zawgyi One ကုိ ေ႐ြးထားေပမဲ႔ ကီးဘုတ္ ကုိ us ကေန my ကုိ ေ႐ြးၿပီး ႐ုိက္လုိက္တဲ႔ အခါ ေ႐ြးထားတဲ႔ Zawgyi One font မဟုတ္ေတာ႔ဘဲ တျခားဟာ ေျပာင္းသြားပါတယ္၊ အဲသည္လုိ မျဖစ္ေအာင္၊ MSWord ထဲမွာ ေဇာ္ဂ်ီ နဲ႔ ႐ုိက္ရသလုိ ႐ုိက္လုိ႔ရမယ္႔ နည္းလမ္းမ်ိဳး မ႐ွိဘူးလား ခင္ဗ်ာ...

mgngapyin
January 1st, 2013, 09:11 AM
ubuntu 12.10 အတြက္ ေဇာ္ဂ်ီ ကီးဘုတ္ ႐ွိပါသလား၊ ဝင္းဒုိး မွာ သုံးရတဲ႔ လက္ကြက္ပုံစံနဲ႔ တူတာကို လုိခ်င္တာပါ၊

http://ubuntuforums.org/showpost.php?p=12415248&postcount=10

မွာ ၾကည့္ပါ။ လက္ကြက္က ေတာ္ေတာ္ေလးကို တူပါတယ္။ (စာလံုးေပါင္းထားတဲ့ စာလံုးေတြ - ဥပမာ - W, Q တို႕မွာ ယပင့္ ( ် ) ( ွ ) တစ္ခုထဲ ျဖစ္ေနတာေလာက္ပဲ ကြဲတယ္ ထင္တာပဲ။ အဲဒါေတြကလဲ ၂ ခါ ရိုက္လို႕ ရေတာ့ အဆင္ေျပမွာပါ။


system setting --- keyboard layout ကုိ သြားၿပီး Burmese ကီးဘုတ္ကုိ ေ႐ြးၿပီး ျမန္မာလုိ ႐ုိက္လုိ႔ ရတာ သိပါတယ္၊ ဒါေပမဲ႔ အဲဒါက Zawgyi One font မဟုတ္ပါဘူး၊

Unicode - Myanmar 3 keyboard ပါ။ Layout ကို ဒီေနရာမွာ (http://commons.wikimedia.org/wiki/File:Myanmar3_Kayboard_Layout.jpg) ၾကည့္ပါ။


Libre ထဲမွာ စာ႐ုိက္ဖုိ႔ Zawgyi One ကုိ ေ႐ြးထားေပမဲ႔ ကီးဘုတ္ ကုိ us ကေန my ကုိ ေ႐ြးၿပီး ႐ုိက္လုိက္တဲ႔ အခါ ေ႐ြးထားတဲ႔ Zawgyi One font မဟုတ္ေတာ႔ဘဲ တျခားဟာ ေျပာင္းသြားပါတယ္၊ အဲသည္လုိ မျဖစ္ေအာင္၊ MSWord ထဲမွာ ေဇာ္ဂ်ီ နဲ႔ ႐ုိက္ရသလုိ ႐ုိက္လုိ႔ရမယ္႔ နည္းလမ္းမ်ိဳး မ႐ွိဘူးလား ခင္ဗ်ာ...

CTL font ေျပာင္းေပးရင္ ရပါတယ္။ Log In ဝင္ျပီး ၾကည့္ပါ။ ပံုျမင္ရပါမယ္။

Menu bar က Tools >> Options
Language Settings ကို double click လုပ္ပါ။
Languages ကို ႏွိပ္ပါ။
ညာဖက္က Default Languages for documents >> CTL မွာ [none] ကို ေရြးပါ။

[Enhanced language support မွာ Enable for complex text layout (CTL) ကို အမွန္ျခစ္ထားရပါမယ္။ တကယ္လို႕ CTL ေရြးလို႕ မရရင္ အေပၚက Locale Settings မွာ Burmese ကို ေရြးေပးဖို႕ လိုေကာင္းလိုပါမယ္။]

CTL မွာ [none] ကို ေရြးျပီးရင္ ဘယ္ဖက္က LibreOffice Writer ကို double-click လုပ္ပါ။
Basic Fonts (CTL) ကို ႏွိပ္ျပီး ညာဖက္မွာ Zawgyi-One ကို လိုသလို ေရြးေပးရံုပါ။

အဆင့္ေတြမွာ OK ႏွိပ္ဖို႕ မေမ့ပါနဲ႕။ မဟုတ္ရင္ Save လုပ္မွာ မဟုတ္ပါဘူး။
အားလံုးျပီးရင္ စိတ္ခ်ရင္ေအာင္ LibreOffice ကို တခ်က္ပိတ္ျပီး ျပန္ဖြင့္ပါ။
ျမန္မာလို ရိုက္လိုက္ရင္ Zawgyi-One, English ဆို တျခား font ျဖစ္ေနတာ ေတြ႕ပါမယ္။
English font ကိုပါ ျပင္ခ်င္ျပင္လို႕ ရပါတယ္။ ဒါေပမဲ့ မလိုအပ္ပါဘူး။
CTL font ေျပာင္းတာနဲ႕ ရပါတယ္။ နဂို CTL က Hindi လားမသိဘူး။ ဒါေၾကာင့္ ကီးဘုတ္ေျပာင္းရင္ ေႏွးသလိုျဖစ္တာ၊ စာလံုး မွန္မွန္ မျမင္တာ ျဖစ္တာပါ။

Unicode သံုးရင္ေတာ့ CTL language မွာ Burmese လို႕ ေရြးတာနဲ႕ Padauk ကို autodetect လုပ္ပါတယ္။

MHK99
April 27th, 2013, 03:17 AM
I have a number of issues with Zawgyi/Padauk fonts. I have installed the two as advised in mm-deb pkg. And also taken the above steps. I still can not get the correct words. I will write zagyi below.

ေဇာ်၈ျီ Could you please help me get it right (for both zawgyi and Padauk).

Thank you.

MHK99
May 14th, 2013, 03:52 AM
ကြည့်တာမပြည့်စုံလို့ပါ။အခုမှသေသေချာချာ ဘတ်ပြီးပြန်ရိုက်တော့မှန်သွားပါပြီ