PDA

View Full Version : [kubuntu] automatically unlock keyring



rybnik
September 20th, 2012, 05:45 AM
I run Lucid Lynx, and I use both Gnome and KDE--mostly KDE. I recently switched from GDM to KDM, and immediately after I did so, the keyring no longer automatically unlocked. How do I get the keyring to automatically unlock again?

I have already checked that autologin is disabled and my login password is the same as the keyring password.

sharathkumar
September 20th, 2012, 02:17 PM
It's been discussed in an earlier post: http://ubuntuforums.org/showthread.php?t=1616370

hope that helps

rybnik
September 21st, 2012, 01:39 AM
It's been discussed in an earlier post: http://ubuntuforums.org/showthread.php?t=1616370

hope that helps

Thank you!

spaceshipguy
September 21st, 2012, 11:51 AM
Didn't work for me.
I have only Passwords: Login, and it is set as default, but I am still bothered by this dialogue.
Every version of Ubuntu I've ever run has started to do this after a while. I've just gotten used to it.

cmcanulty
September 21st, 2012, 08:41 PM
my machine started this a few days ago and none of the fixes stops it, very irritating

rybnik
September 21st, 2012, 10:17 PM
The above two posters say it doesn't work. Make sure you actually DELETE the keyring password (by setting it to a null field), not just switch some setting.

cmcanulty
September 22nd, 2012, 12:32 AM
I did that and also deleted the files in,gnome2/keyrings folder still persists

rybnik
September 22nd, 2012, 02:02 AM
I did that and also deleted the files in,gnome2/keyrings folder still persists

You have kdm, right? If you're willing to switch to gdm, that might fix it.

But if that doesn't work, I don't know what to tell you.

cmcanulty
September 22nd, 2012, 12:28 PM
I am using ldm

rybnik
September 22nd, 2012, 07:00 PM
I don't know enough to be able to be of help, but I haven't marked this thread [solved], so hopefully someone else can offer help.

rybnik
August 5th, 2013, 05:59 PM
This might shed some light on this:

I used to use Ubuntu 10.04 with KDE installed on top. When I logged into Gnome2 (which is what Ubuntu used by default back then), the keyring unlocked automatically. It didn't when I logged into KDE.

Now I use Kubuntu 12.04 with LXDE and XFCE installed on top. When I log into KDE, the keyring unlocks automatically. When I log into LXDE or XFCE, it doesn't!

So it seems that a keyring is unlocked automatically only for the first desktop environment that you've installed. I don't know anything about changing that, though.