PDA

View Full Version : [gnome] ooffice.sh: how to modify startup environment



wgw
August 26th, 2012, 11:31 PM
Under ooffice I can normally get accented characters ( etc.), but after an update I lost them. I get them back if I start ooffice from bash with
env XMODIFIERS='' ooffice -writer %U.

I thought I could modify the ooffice.sh file in /etc/bash_completion.d and add:
XMODIFIERS=
export XMODIFIERS

but that doesn't work. (Why??)

What is the best way to make sure XMODIFIERS="" when I run ooffice? I already have that environment setting in my bash.rc. Should I put it somewhere else? I believe I am using ibus, with us international layout.

I'm still under 10.04 for the moment, but may upgrade soon, when I'm feeling courageous and patient. So this question may be resolved with an upgrade.