PDA

View Full Version : [SOLVED] 12.04 Hylafax+Avantfax - No faxes getting sent as emails or showing in Avantfax inbox



jumping_snake
August 21st, 2012, 11:42 PM
I have a feeling I'm missing something simple here, but here goes:

In the past, I've built Hylafax w/ AvantFax servers (6.0.3 & 3.3.3 respectively) on 10.04 with no issues. The server is able to send emails out with PDFs attached and the faxes show up in the AvantFax's website inbox. Following the same steps on 12.04 (versions 6.0.5 & 3.3.3), I can get everything working except for emailing out the faxes and I don't get faxes showing up in the AvantFax inbox.

Differences in the old/new system other than the OS and versions:
1) Dell OMSA and nrpe installed - I use this to keep track of the hardware of the server.
2) udev rules - I set udev rules to keep the usb modems in the same spot so I don't have to check them after a reboot/power outage.


The /etc/aliases are set to be the same and the 10.04 continues to run correctly, as well as the /etc/postfix/main.cf being exactly the same (other than the hostname).


I should mention that I noticed this in the mail logs on each server:

10.04 that works correctly:


Aug 21 15:28:00 <hostname> postfix/pickup[27674]: 37C2AC1F76: uid=10 from=<root@localhost>
Aug 21 15:28:00 <hostname> postfix/cleanup[28730]: 37C2AC1F76: message-id=<m94meo.xau0hh@localhost>
Aug 21 15:28:00 <hostname> postfix/qmgr[1051]: 37C2AC1F76: from=<root@localhost>, size=61110, nrcpt=1 (queue active)
Aug 21 15:28:01 <hostname> postfix/smtp[28732]: 37C2AC1F76: to=<<correct user>@<company domain>>, relay=<relay server>[<relay server IP>]:25, delay=1, delays=0.2/0.01/0.29/0.53, dsn=2.6.0, status=sent (250 2.6.0 <m94meo.xau0hh@localhost> Queued mail for delivery)
Aug 21 15:28:01 <hostname> postfix/qmgr[1051]: 37C2AC1F76: removed


12.04 where it doesn't work:


Aug 21 15:07:04 <hostname> postfix/pickup[6961]: 2A3F06A102E: uid=10 from=<FaxMaster>
Aug 21 15:07:04 <hostname> postfix/cleanup[7454]: 2A3F06A102E: message-id=<20120821200704.2A3F06A102E@IN-IND-FAX-1>
Aug 21 15:07:04 <hostname> postfix/qmgr[2081]: 2A3F06A102E: from=<FaxMaster@<relay server>>, size=932, nrcpt=1 (queue active)
Aug 21 15:07:04 <hostname> postfix/local[7457]: 2A3F06A102E: to=<FaxMaster@<relay server>>, orig_to=<FaxMaster>, relay=local, delay=0.25, delays=0.19/0/0/0.06, dsn=2.0.0, status=sent (delivered to mailbox)
Aug 21 15:07:04 <hostname> postfix/qmgr[2081]: 2A3F06A102E: removed


I'm confused why FaxMaster is the FROMADDR instead of root@localhost and why it doesn't try to use SMTP and uses "local" instead.

Any thoughts, ideas are appreciated as I'm still looking and trying to stay sane :)

jumping_snake
August 22nd, 2012, 01:34 AM
Ah, I knew it would be easy :)

Apparently in my stress to get this system up under pressure, I forgot to set it's FQDN...

Please read this very handy and straight forward explanation and by post #10 you'll see a break down of exactly what I posted above from the server that's failing to send emails:

http://ubuntuforums.org/showthread.php?t=711512

I'll report back once I have the FQDN in place...

jumping_snake
August 22nd, 2012, 06:07 PM
Ah, ha!! The postfix was part of the problem, but I forgot that AvantFax 3.3.3 doesn't overwrite /var/spool/hylafax/bin/faxrcvd, it instead puts it's faxfcvd.php file there and leaves the Hylafax version of the file as well. After renaming the original to a different name, I renamed faxfcvd.php (AvantFax's copy) to faxrcvd and viola I'm back in business.

gillecaluim
August 25th, 2012, 12:51 AM
hello, you've managed to accomplish just what I want....
I just purchased an usr 56k serial faxmodem to attach to my 12.04.1 server but am having trouble finding a step by step guides for getting hylafax/avantfax system up and running.
If you know of an actual working guide, could you share it with those of us in need ):P
If there isn't such a guide......maybe you could be a :KS and write one up. Thanks for any assistance you can give:p

jumping_snake
August 26th, 2012, 06:52 PM
Ask and you shall receive :)

http://ubuntuforums.org/showthread.php?t=2048425