PDA

View Full Version : [lubuntu] Can't use xfce



25tom
August 21st, 2012, 09:36 AM
Hi,
I am trying to use xfce (not xubuntu-desktop) on Lubuntu Oneiric.
When I try to log in, I select the xfce desktop and then log in. This simply returns me to the login screen.
How can I fix this?
Also, I am, while not an absolute beginner, still fairly new to the various *buntus; no uber-difficult explanations please :)

zombifier25
August 21st, 2012, 10:01 AM
Can you log in as other desktop environment?

Either ways, press Ctrl + Alt + F1 to get into a tty, login and type this command:

sudo chown yourusername:yourusername ~/.Xauthority
don't forget ro replace yourusername of course.

25tom
August 21st, 2012, 10:07 AM
No, I tried Openbox Session and that gave the same response.
I presume that the code you gave changes permissions for me to use other desktops?

25tom
August 21st, 2012, 10:23 AM
Have managed to do the

sudo chown yourusername:yourusername ~/.Xauthority
but I still can't log in to Xfce...

25tom
August 21st, 2012, 02:27 PM
Some more info about the problem:
I can login to "Lubuntu" and "Openbox", but not "Openbox Session" or "Xfce session".

black veils
August 21st, 2012, 02:35 PM
did you actually manually install the xfce desktop, or was it just an option in the menu already? if so, what package did you select?

25tom
August 21st, 2012, 03:41 PM
did you actually manually install the xfce desktop, or was it just an option in the menu already? if so, what package did you select?

I used the metapackage 'xfce4', from Synaptic Package manager. Once I had installed it the option 'Xfce Session' appeared in the desktop choosing menu at the login screen. I selected that from the menu and then the login failed as described before.

cmcanulty
August 21st, 2012, 10:22 PM
it is certainly work trying reinstalling xfce

25tom
August 22nd, 2012, 08:24 PM
it is certainly work trying reinstalling xfce

That didn't work... still just reloads login screen.

25tom
September 3rd, 2012, 01:05 PM
I think the technical term I need to use is "bump".

black veils
September 3rd, 2012, 01:10 PM
my solution would be to install ubuntu from minimal or alternate image, and install xfce desktop from there. i cant remember the difference between minimal and alternate, all i know is minimal gives you groups of packages to choose from, xfce isnt one of them, so you can install lubuntu desktop, then when you get into your system
sudo apt-get install xfce4

http://www.youtube.com/watch?v=JLAQ2uQgTAY&playnext=1&list=PL365F9BF47955BA5F&feature=results_main

25tom
September 3rd, 2012, 09:01 PM
Is there a solution that doesn't involve a new install of Ubuntu?

s1baker
September 4th, 2012, 04:57 AM
have you tried the xfce forums for any info they may have?

http://forum.xfce.org/index.php

Lemuriano
September 4th, 2012, 05:28 AM
Perhaps you should try to install another display manager like GDM.

Regards.

25tom
September 8th, 2012, 07:24 PM
Perhaps you should try to install another display manager like GDM.

Regards.

How do I go about doing that?

Lemuriano
September 8th, 2012, 07:41 PM
I suggest gdm but you could use others like xdm ect. This happen to me with other distro while using lxde and it solve the problem. You can have only one display manager so the system will ask you to change the one you have for gdm. Hope this help.


sudo apt-get install gdmRegards.

You can also install the display manager from synaptic package manager if you chose to.

25tom
October 24th, 2012, 07:23 PM
Thanks :)