PDA

View Full Version : [SOLVED] Ubuntu mac slowing down with thunderbolt display (solution)



thesillymoose
July 29th, 2012, 01:22 PM
Hi,

I am running Ubuntu 12.04 on a macbook air 4,2 (mid 2011). When I cold boot with the Thunderbolt display, I found the GUI slows down dramatically. I'm not sure what the root cause is but running top from the command line showed a kworker process eating up my CPU.

Fortunately there is a fix for this, as helpfully documented by souriguha here (http://souriguha.wordpress.com/2011/03/08/how-to-solve-problem-with-thinkpadkslowd-kworker-on-linux-kernel-2-35-2-36/).

For 12.04 Ubuntu users, open up the terminal and become root by typing:

sudo su
To fix the issue for the current session only type:

#echo N> /sys/module/drm_kms_helper/parameters/poll

And to change the setting for all future sessions type:

#echo "options drm_kms_helper poll=N">/etc/modprobe.d/local.conf

Thanks again to souriguha for sharing the solution online.

Mb0742
July 30th, 2012, 12:52 PM
And to change the setting for all future sessions type:
Code:
#echo "options drm_kms_helper poll=N">/etc/modprobe.d/local.conf

>> is the correct redirect. Safety first :)

thesillymoose
August 24th, 2012, 12:33 PM
Redirect updated following helpful addition by Mb0742:


Hi,

I am running Ubuntu 12.04 on a macbook air 4,2 (mid 2011). When I cold boot with the Thunderbolt display, I found the GUI slows down dramatically. I'm not sure what the root cause is but running top from the command line showed a kworker process eating up my CPU.

Fortunately there is a fix for this, as helpfully documented by souriguha here (http://souriguha.wordpress.com/2011/03/08/how-to-solve-problem-with-thinkpadkslowd-kworker-on-linux-kernel-2-35-2-36/).

For 12.04 Ubuntu users, open up the terminal and become root by typing:

sudo su
To fix the issue for the current session only type:

#echo N>> /sys/module/drm_kms_helper/parameters/poll

And to change the setting for all future sessions type:

#echo "options drm_kms_helper poll=N">>/etc/modprobe.d/local.conf

Thanks again to souriguha for sharing the solution online.

domhans
April 15th, 2013, 10:31 AM
I have a similar problem but this solution does not work for me. When I attach my thunderbolt displayt to my 13" intel macbook retina the system needs several minutes to boot and the mouse is extreamly delayed. Everything else seems to work great and I did not notice any unusual high cpu usage. I'm running Kubuntu 13.04 beta2. X.org log file seems to be ok.

Any suggestions?
Thanks
Dom

kc600
April 26th, 2013, 09:07 AM
This answer was very helpful.

Unfortunately it stopped working on Ubuntu 13.04 Raring.

$ sudo echo N> /sys/module/drm_kms_helper/parameters/poll
bash: /sys/module/drm_kms_helper/parameters/poll: Permission denied

And modifying local.conf is possible but makes no difference after reboot.

(Lenovo Thinkpad S430)

mattm79
April 29th, 2013, 11:10 PM
This answer was very helpful.

Unfortunately it stopped working on Ubuntu 13.04 Raring.

$ sudo echo N> /sys/module/drm_kms_helper/parameters/poll
bash: /sys/module/drm_kms_helper/parameters/poll: Permission denied

And modifying local.conf is possible but makes no difference after reboot.

(Lenovo Thinkpad S430)

Hi,

You can try the below, it works on 12.04 (which had similar problem to what you described)

just add the echo N line to /etc/rc.local and restart, that'll make sure the parameter gets changed by root on restart, if you have nothing else there it should look similar to this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo N> /sys/module/drm_kms_helper/parameters/poll
exit 0

regards,

matt