PDA

View Full Version : [ubuntu] software center "not responding"



casondonkersgoed
July 6th, 2012, 08:33 AM
Every time I try to open the software center (clicking and using terminal) the window for it opens and after about 10 seconds it either fades to grey, or displays the loading wheel and then freezes and fades to grey. I have tried putting "software-center
" into the terminal and it displays this "2012-07-06 01:06:07,941 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-07-06 01:06:07,947 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-07-06 01:06:08,476 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-07-06 01:06:08,682 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None." please help, I will provide any additional information if needed.

krustenBrot
July 6th, 2012, 10:47 AM
Have you tried simply reinstalling it?
First remove it with typing
sudo apt-get purge software-center into a terminal. It is apt-get purge because you want to remove the config files as well - maybe there went something wrong. To keep the config files in future you can use sudo apt-get remove (appname).

After that reinstall it typing the following:

sudo apt-get install software-center

I had various crashes and problems with the software center. Since I reinstalled it it works fine. Maybe it helps here too..

krustenBrot
July 6th, 2012, 10:52 AM
I tried running the software-center from terminal as well - and your output seems to be just fine. I got the same here and everything is working as it should.

And welcome to the forums by the way. ;)

casondonkersgoed
July 6th, 2012, 12:37 PM
I uninstalled it and re-installed it using those commands and it still has the same problem. I can't figure out what the problem is because the terminal just stops without completely loading the software center. I have a feeling it might be something conflicting with it that I may need to uninstall.

not found
July 6th, 2012, 03:37 PM
Shot in the dark... in terminal run:


sudo apt-get update && sudo apt-get upgrade

Check for any errors etc. Maybe there is an issue with the sources and package cache that is causing the issue.


404

NikTh
July 6th, 2012, 06:01 PM
Also you can try to update the catalog..

sudo update-software-center

jmfal
July 6th, 2012, 06:18 PM
Or you can try this


sudo apt-get install synaptic

and not use the software center anymore..