PDA

View Full Version : Offline Software Analysis, libtermcap.so.2: cannot open



Soonick
June 29th, 2012, 04:05 PM
Hello everybody!
I am trying to install the OSA data analysis program (Offline Software Analysis, from the Integral Science Data Center: http://www.isdc.unige.ch/integral/analysis#Software).

However, when I try the test command (make test), the terminal returns the following error:



>>>>> Run the analysis script ...


/home/nedu/soft/osa_sw-9.0
/home/nedu/soft/osa_sw-9.0//bin/og_create: error while loading shared libraries: libtermcap.so.2: cannot open shared object file: No such file or directory
cd: 178: can't cd to /home/nedu/soft/osa_sw-9.0/run/obs/osatest
/home/nedu/soft/osa_sw-9.0//bin/ibis_science_analysis: error while loading shared libraries: libtermcap.so.2: cannot open shared object file: No such file or directory


>>>>> The analysis script terminated with return code: 127


***** Error: expected return code: 0
-> Abort the test run at this point



Do you know what it could be?
Thanks in advance!

drmrgd
June 29th, 2012, 04:19 PM
It looks like you're missing a library. Try installing the libncurses5-dev package (I think libtermcap.so.2 is in there):


sudo apt-get install libncurses5-dev

Then try recompiling the OSA package.

Soonick
June 29th, 2012, 04:30 PM
Thanks!

However, when I try to install the library, the terminal says that it is already updated to the most recent version...
So, the problem has to be different...

drmrgd
June 29th, 2012, 05:55 PM
Thanks!

However, when I try to install the library, the terminal says that it is already updated to the most recent version...
So, the problem has to be different...

Hmmm...I may have the wrong package, then. I wan't quite sure the library was in the package I suggested (although I really thought it was). On my system, I don't see that library even though I have libncurses5 and libncurses5-dev installed.

I did a quick package search, and found some hits:

http://packages.ubuntu.com/search?searchon=contents&keywords=libtermcap&mode=filename&suite=precise&arch=any

I'm not sure about your architecture and your setup. Also, none of them specifically say libtermcap.so.2 (and I do have libtermcap.so on my system already). So this might be a bit of a witch hunt, but I'm thinking it might get you close.

Soonick
June 29th, 2012, 10:14 PM
Thanks again.
I have Ubuntu 10.04 on a 64bit machine.
There are many packages in the link that you posted, but I can not distinguish between them...

Bachstelze
July 1st, 2012, 08:50 PM
There is no libtermcap.so.2 in Ubuntu, you will need to compile the software from source.

Soonick
July 2nd, 2012, 09:19 AM
Hi Bach, thank you.
Are you sure that I can not install the program from the binary?
I am a new, but I can try to compile the software following the official guide.
What is the main problem that I will encounter doing that?

Bye!

ramreddy502
April 22nd, 2013, 06:44 AM
hi
i am trying to generate models for speech database using HMM, for this i am using festvox tools and speech tools.
with these tools i have completed labelling for the speech files.

now i am trying to generate F0 for speech file, but it is showing an error like "loading shared libraries:libtermcap.so.2 can not open shared object file:no such file or directory"

but libtermcap.so.2 is present in usr/lib.

please can anyone help me

thanks in advance