PDA

View Full Version : [SOLVED] 11.10 Eeepc 901 Updates caused multiple hardware issues



hoppyluke
June 19th, 2012, 12:28 AM
I have an Eee PC 901 which has 11.10 installed. I ran Update Manager to install pending updates and it got stuck saying "waiting" in the progress dialog. I cancelled the updates and tried sudo apt-get update which gave me an error about something being locked (can't remember exactly what - maybe package lists?). I figure Update Manager still hadn't cancelled fully yet so I restarted to try and get it to release the locks.

Since the restart I have the following issues (none of which were there before):

The keyboard layout has reverted from UK back to US. I have changed it back under system settings but now each time I reboot the keyboard is still in US layout until I have logged in - i.e. I have to type my password as if I had a US keyboard. Once I am logged in, it goes back to the correct UK layout.
My touchpad (the only pointing device I have available) does not respond at all.
Wireless is not working. ifconfig no longer shows wlan0, the keyboard shortcut (Fn + F2) to enable wireless has no effect. lshw shows "*-network UNCLAIMED" for my wireless card (Ralink RT2860).
None of the keyboard function key shortcuts work (adjust brightness, volume etc).


I only have a wireless connection available so I can't access the net from my netbook at all. I have no idea where to begin - help!

hoppyluke
June 19th, 2012, 02:33 AM
I was able to resolve my issue by running:


sudo dpkg --configure -a

then rebooting. Following the reboot, Update Manager complained about untrusted software sources. Running apt-get update from the command line seemed to put a stop to that.