PDA

View Full Version : [ubuntu] 12.04 - Suspend/wakeup problem



jolan
June 15th, 2012, 08:48 AM
Hi.

I need help with the settings in /proc/acpi/wakeup file. When I tell my laptop to suspend, it flawlessly goes to sleep but immediately wakes up. I found out in forums, that it is caused by USB-s waking it up. I also found out, that I can fix the problem by editin the /proc/acpi/wakeup file (which also fixed my problem).

It's just that the settings of /proc/acpi/wakeup change every time I go to suspend. So I have to change the settings "every time" before I want to suspend the laptop.

By default, my /proc/acpi/wakeup looks like this:

cat /proc/acpi/wakeup
Device S-state Status Sysfs node
SMB0 S4 *disabled pci:0000:00:03.2
PBB0 S4 *disabled pci:0000:00:09.0
HDAC S4 *disabled pci:0000:00:08.0
XVR0 S4 *disabled pci:0000:00:0c.0
XVR1 S4 *disabled
P0P5 S4 *disabled
P0P6 S4 *disabled pci:0000:00:15.0
GLAN S4 *enabled pci:0000:03:00.0
P0P7 S4 *disabled pci:0000:00:16.0
P0P8 S4 *disabled
P0P9 S4 *disabled
USB0 S3 *enabled pci:0000:00:04.0
USB2 S3 *enabled pci:0000:00:04.1
US15 S3 *enabled pci:0000:00:06.0
US12 S3 *enabled pci:0000:00:06.1
PWRB S4 *enabled
SLPB S4 *enabled


In order to get the laptop to suspend, I change the USB settings:

USB0 S3 *disabled pci:0000:00:04.0
USB2 S3 *disabled pci:0000:00:04.1
US15 S3 *disabled pci:0000:00:06.0
US12 S3 *disabled pci:0000:00:06.1


But after waking it up from suspend, the contents of the file are again either:
USB0 S3 *disabled pci:0000:00:04.0
USB2 S3 *enabled pci:0000:00:04.1
US15 S3 *disabled pci:0000:00:06.0
US12 S3 *enabled pci:0000:00:06.1
or:
USB0 S3 *enabled pci:0000:00:04.0
USB2 S3 *enabled pci:0000:00:04.1
US15 S3 *enabled pci:0000:00:06.0
US12 S3 *enabled pci:0000:00:06.1
:mad:

Is there any way, to make the settings stay the same?