PDA

View Full Version : [ubuntu] Gnome won't let me use my mouse pad



PizzaLover101
June 10th, 2012, 03:56 PM
I usually use a mouse when I am at home, but some times I use my mousepad, for simple things. However, whenever I use gnome now, my mouse pad stops working, but my mouse works. When I use
xinput list
This is what I get

Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Dell Dell USB Optical Mouse id=10 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ Sleep Button id=9 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
↳ HP WMI hotkeys
I have a Compaq Presario CQ61 laptop, Ubuntu 12.04

Edit: I should probably note that it works fine in the login menu, and I am booting Ubuntu 12.04 of an external HD right now with no problems

PizzaLover101
June 13th, 2012, 01:41 AM
After digging around, I found this
http://askubuntu.com/questions/66907/touchpad-not-working-on-msi-u130-after-login-in

Look for the second one down, I'll quote it here

Installing the synaptics utility and changig settings didn't work for me. I found something that fixed it in a [comment in a Bug report][1]:

Install dconf-tools (dconf-tools in synaptic package manager or dconf Editor in the Ubuntu Software Center)

Launch it, it's called "dconf Editor" (It's in the "System" group if you use filters)

Find the setting "touchpad-enabled" in "/org/gnome/settings-daemon/peripherals/touchpad/" (See the pic below) and enable it.

Quit the editor and you're done.

Note, this did not require a restart or logout/in for me, the touchpad started working straight away.

My laptop is an MSI i7 running 64 bit Ubuntu 11.10, upgraded from a clean install of ll.04