PDA

View Full Version : [ubuntu] [UL50VT] screen with artifacts after nvidia splash on startup



wobin88
June 9th, 2012, 11:14 AM
I updated to Ubuntu 12.04 yesterday and it caused me a lot of headache with the graphics.

My laptop is a ASUS UL50VT with a Optimus GFX GeForce G210M / Intel Mobile 4.

To get the Nvidia card to work in 11.10 I had to change SATA options in BIOS from enhanced to compatability (see: http://www.linlap.com/wiki/asus+ul50vt).

If I boot with compatability mode enabled in 12.04 I see the Ubuntu loading screen, then a nvidia splash and after that I just end up with seeing different graphics artifacts. Sometimes it's just a few green dots spread across a black screen, sometimes its the nvidia logo discolored. Same issue appears in recovery boot of ubuntu.

If I change to enhanced mode now unity actually boots and i get into the GUI mode, then I get other issues:

If I run with a xorg.conf generated by nvidia-xconfig different applications crashes on startup, nvidia settings panel dont recognize that I run a nvidia card and I cant change from 800x600.

If I run without a xorg.conf things seem to work okay, but I cant change from 1024x768 resolution.

I have tried to remove (with purge) the nvidia-current package and reinstall it again.

Also tried the nomodeset boot option: http://ubuntuforums.org/showthread.php?t=1613132

Anyone got an idea what I should try next? My goal is to get the nvidia card running as intended, I don't really care about switching to keep up the battery life.

Thanks,
Robin