PDA

View Full Version : [ubuntu] Perl-suid package



Yammyguy
April 29th, 2012, 09:06 PM
Hello all,

Trying to install OpenWebMail on my server (ubuntu 12.04 Precise) - I have all the Perl pre requisites installed EXCEPT for perl-suid!!! running apt-get install perl-suid returns

"E: Package 'perl-suid' has no installation candidate"

I've manually downloaded all versions of the package - the latest being:

perl-suid_5.10.1-17ubuntu4_i386.debwhen I try to manually run using dpkg -i I get an error stating the versions of perl installed are too new and there are dependency problems as package libper15.10 is not installed.

Any help with this would be greatly appreciated!

Thank you in advance!
Chris.

Yammyguy
April 30th, 2012, 08:13 PM
Bump...

Anyone???

ian dobson
April 30th, 2012, 08:25 PM
Hi,

Maybe try using cpan (perl package manager) to install the package:-

cpan
install Unix::SetUser

Note: This is untested.

Regards
Ian Dobson

Yammyguy
April 30th, 2012, 10:23 PM
Hi,

Maybe try using cpan (perl package manager) to install the package:-

cpan
install Unix::SetUser

Note: This is untested.

Regards
Ian Dobson

Thanks for the suggestion, but no dice. I've run through cpan and wen I try installing OWM - still getting the error missing perl-suid package...

I don't understand why perl-suid isn't working. it should be an installable package, no?

ian dobson
May 1st, 2012, 08:00 AM
Hi,

Looking abit further it looks as if perl-suid has been removed from perl http://perldoc.perl.org/perl5120delta.html#Deprecations

Maybe just wait abit until OpenWebMail gets fixed to not require it.

Regards
Ian Dobson