PDA

View Full Version : LTS 12.04 - what PHP policy in this release?



BUGUNTU
April 14th, 2012, 07:08 PM
Hi,

after the incredible fail with the buggy php version in the 10.04 LTS release I would like to ask: what is the PHP policy for this next LTS release? Will PHP be supported or will I have to feed a LTS server install with doubtful PPAs that are left alone and vulnerable after some months?

BTW there are still PHP 5.3 PPAs on launchpad that must be vulnerable - there where no updates for several 5.3 PPAs after some major security fixes have been issued - I think you should close accounts of people that are not willing or able to update their PPAs after an important security fix, but this is another story.

This is definitely not the situation you want to get into with an LTS release - having to choose between sticking with an ancient, buggy PHP version, choosing some vulnarable packages from Mr. Unknown or building everything yourself (well, you could go to other distros then) - the whole situation was totally inacceptable. We changed all ubuntu servers back to debian, luckily a long time ago.

However, we are still interested in how Ubuntu is growing, so my question about the PHP policy with the upcoming LTS release! Is there some perspective for LAMP hosters using ubuntu 12.04 LTS?

THANKS!

Jonathan L
April 14th, 2012, 07:50 PM
Hi Bug


my question about the PHP policy with the upcoming LTS release

Perhaps you could describe what you would like to see?

Kind regards,
Jonathan.

CharlesA
April 14th, 2012, 08:09 PM
I've been running a LAMP stack on 10.04 with no problems. As a general rule, if a security vulnerability exists in a package, it is patched and there shouldn't be any need for PPAs. The version of PHP I'm running on my 10.04.4 box is:


phpinfo()
PHP Version => 5.3.2-1ubuntu4.14


The latest version is 5.4 per php.net

What version of php did you have problems with?

EDIT: I never had to use a PPA for php5.

Doug S
April 14th, 2012, 10:28 PM
My 12.04 (Beta) test computers (up to date as of a few minutes ago) show: PHP Version 5.3.10-1ubuntu3
The same as shown on the packages web pages (http://packages.ubuntu.com/precise/php/).

Vegan
April 15th, 2012, 03:18 PM
Unless you are having problems, the version included with 12.04 works fine