PDA

View Full Version : 12.04 - Background and Plymouth Questions



amhainen
April 8th, 2012, 11:15 PM
I don't like Purple...I guess I'll keep my fingers crossed for 14.04 and maybe it won't have a purple background.

Can someone share how to:



Change the LightDM background in 12.04. I just want solid black; whether I just can enter a color code or make a black .png, don't care how it needs to happen. I tried Ubuntu Tweak, but no luck. I also tried simple-lightdm-manager, but that repo didn't work for me.
Change the Purple Ubuntu loading screen (the one in between Grub and the LightDM login screen) to black. I've done this before and it's in some config file related to Plymouth.

Thanks for the help. I've spent an hour Googling and found no useful threads. Also, I realize that 12.04 is in its beta state and not fully supported.

amhainen
April 9th, 2012, 12:26 AM
Okay, I figured out item 2:


sudo emacs /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.script

Set the following:


Window.SetBackgroundTopColor (0.00, 0.00, 0.00); # Nice colour on top of the screen fading to
Window.SetBackgroundBottomColor (0.00, 0.00, 0.00); # an equally nice colour on the bottom

I just used '0.00' for all RGB values for black. Now I have a cool splash screen. (Question: I stumbled across something that says you can disable the splash for grub. Does this give verbose output for the boot process and get rid of the Ubuntu screen altogether?)

Now if someone can help me figure out LightDM, I can get on to playing with more fun things like Cinnamon...

Elfy
April 9th, 2012, 06:18 AM
Thread moved to Ubuntu +1 (Precise Pangolin).

2F4U
April 9th, 2012, 06:47 AM
(Question: I stumbled across something that says you can disable the splash for grub. Does this give verbose output for the boot process and get rid of the Ubuntu screen altogether?)


If you remove quiet splash from the kernel parameters you will see the kernel boot messages printed on screen. You can edit /etc/default/grub and remove the parameters. After that, you need to run

sudo update-grub

so that the changes are made permanent.

2F4U
April 9th, 2012, 06:53 AM
Now if someone can help me figure out LightDM, I can get on to playing with more fun things like Cinnamon...

You should be able to change the lightdm background by following these small tutorials:
http://www.webupd8.org/2011/09/how-to-change-lightdm-login-screen.html
http://www.tuxgarage.com/2011/10/customizing-appearance-of-lightdm.html

ranch hand
April 9th, 2012, 11:05 AM
I do not use Ubuntu but the config files are always there. For your background in lightdm you need
/etc/lightdm/lightdm-gtk-greater.conf

It is nicely commented and the path to an image is, on my Debian Wheezy install, at line 11. There are other things there too that you may find interesting.

Removing both quiet and splash from your grub menu entry (edit /etc/default/grub) will get rid of the Plymouth splash and give you a verbose boot.

You will probably find that leaving "quiet" in there generates more information scrolling on your screen than you can take in. I would leave it there.

amhainen
April 9th, 2012, 12:34 PM
I do not use Ubuntu but the config files are always there. For your background in lightdm you need
/etc/lightdm/lightdm-gtk-greater.conf

It is nicely commented and the path to an image is, on my Debian Wheezy install, at line 11. There are other things there too that you may find interesting.

Removing both quiet and splash from your grub menu entry (edit /etc/default/grub) will get rid of the Plymouth splash and give you a verbose boot.

You will probably find that leaving "quiet" in there generates more information scrolling on your screen than you can take in. I would leave it there.

First, thanks all. To 2F4U, I followed those how-to sites but I didn't have find the file they referenced.

Ranch Hand, I followed what you suggested but still no luck.



I tried both a path to the /etc/lightdm/backgrounddefault.png (which I CHMODed to 775 just in case...) along with the #000000 color code. Nothing changed, even after a reboot.

zika
April 9th, 2012, 12:51 PM
Try uncommenting GRUB_TERMINAL=console in /etc/default/grub and (after that) apply update-grub...
That way I do not get Plymouth purple...
Choice of „quiet“ or not is Yours... I do not use „splash“ either...

ranch hand
April 9th, 2012, 08:18 PM
Sorry, works slick under Debian.

Have no idea what is on your screen shot. Using that combination of background and font colors is going to make your eyes older than mine in a hurry.

BigCityCat
April 9th, 2012, 10:34 PM
You should be able to change the lightdm background by following these small tutorials:
http://www.webupd8.org/2011/09/how-to-change-lightdm-login-screen.html
http://www.tuxgarage.com/2011/10/customizing-appearance-of-lightdm.html

This file does not exist in precise. At least not on my 64bit system.

etc/lightdm/nada

amhainen
April 10th, 2012, 03:52 AM
This file does not exist in precise. At least not on my 64bit system.

etc/lightdm/nada

So does anyone know a solution for x64?

el_itur
April 10th, 2012, 05:16 AM
I've found that /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml has some configuration schema but changes seems not to apply.

amhainen
April 10th, 2012, 11:07 PM
So I changed my file, but can anyone tell the path to the default login background? This way I can just make my own image and mv it to the same location.

Thanks!

amhainen
April 12th, 2012, 12:41 AM
Okay, here's a really weird one: I used grub-customizer to set Grub to a black background. Also, I had the Plymouth Splash set to black (0.00, 0.00, 0.00) as previously mentioned. Both were set.

Compiz crashed today and I had to hold the power button (no Alt+F2, no Ctrl+Alt+Del/F1, nothing). When I rebooted, grub had a purple background and Plymouth had a purple background. I figured no problem, I can just readjust my settings.

The problem now is that grub is stuck with a purple background and the Plymouth Splash is purple during start up and black during shutdown.

Any ideas?_

Thx.

amhainen
April 22nd, 2012, 06:07 PM
I stumbled across how to change the LightDM greeter background:

http://askubuntu.com/questions/121373/etc-lightdm-unity-greeter-conf-file-missing

You need to copy the file to /usr/share/backgrounds/name.png]. Explained as such:


In Ubuntu 12.04, your lightDM background is automatically set to your background image in session as long as your background image is in the /usr/share/backgrounds/ folder. If your background image is not in that folder, you can copy it there via
sudo cp /location/of/image/here.png /usr/share/backgrounds/, then add it to your background images in the Appearance Settings and set it as your background image. Now when you log out, you should see your background image as your lightDM background!