PDA

View Full Version : .desktop file is now "untrusted launcher"



bobman321123
April 7th, 2012, 04:53 PM
How do I set a desktop file to be trusted?
Thanks.

JRV
April 7th, 2012, 04:59 PM
Make it executable, through the properties menu or



chmod +x /PATH/TO/MYFILE.desktop

exploder
April 7th, 2012, 05:10 PM
I just watched a video the other day about a .desktop file being used through an e-mail to wipe a Ubuntu system. I am glad they made this change!

bobman321123
April 7th, 2012, 08:18 PM
Precise pangolin seems to not be allowing me to mark the .desktop files as executable.

mc4man
April 7th, 2012, 08:55 PM
Where is this .desktop that you want to mark trusted?
There is only 2 reasons to do so - so the icon set for the .desktop is displayed & or you want to d. left click on to execute

By & large in a unity* session I see no reason to mark locally stored .desktops as trusted, I just add to launcher or a quicklist

(if I was to mark a local one probably would use u+x or 744

Just to note - this behavior is nothing new in 12.04, change was made quite some time ago, forget which ubuntu release

bobman321123
April 8th, 2012, 12:01 AM
the .desktop is on my desktop.
And I found out later that even if I were to go directly to the executable and try to execute, it won't let me because it has no default program to execute executables or something crazy like that.....

mc4man
April 8th, 2012, 12:49 AM
If inclined - open a gedit window, DnD your .desktop in to gedit window
Copy & paste the contents in a reply here in a code or quote box

At this point your 2 threads basically seem to be about the same, as of yet, unknown issue

bobman321123
April 8th, 2012, 05:10 PM
If inclined - open a gedit window, DnD your .desktop in to gedit window
Copy & paste the contents in a reply here in a code or quote box

At this point your 2 threads basically seem to be about the same, as of yet, unknown issue



#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Type=Application
Name=Desura
GenericName=Game Manager
Comment=Download and play the best games
Exec=/home/josh/Desktop/desura/desura %U
TryExec=/home/josh/Desktop/desura/bin/desura
Path=/home/josh/Desktop/desura
MimeType=x-scheme-handler/desura;
Icon=/home/josh/Desktop/desura/data/desura.png
Terminal=false
Categories=Game;
StartupNotify=false

mc4man
April 8th, 2012, 05:42 PM
Works fine here - the installer creates a launcher on the Desktop, offers to add to launcher & sets all the needed permissions

Did you move the desura folder after installing?
If not to test the binary try this in a terminal

/home/josh/Desktop/desura/desura

Noting that desura runs off of a launch script, not the binary itself

see screen

bobman321123
April 9th, 2012, 12:01 AM
It's not just desura, I seem to lack the ability to mark as trusted.
All 9 .desktop files on my desktop aren't working.

jpeddicord
April 9th, 2012, 03:17 AM
It's not just desura, I seem to lack the ability to mark as trusted.
All 9 .desktop files on my desktop aren't working.

It's on the right-click menu > Properties; Permissions tab. Make sure "Allow executing file as program" is checked. When it's unchecked, you'll see the .desktop filename and a text file icon, as well as that error when trying to launch it. When it is checked, you'll see the actual icon (Desura) and it should launch.

Image attached.

mc4man
April 9th, 2012, 03:23 AM
It's not just desura, I seem to lack the ability to mark as trusted.
All 9 .desktop files on my desktop aren't working.
While your in the proprieties also ck. who owns these files

JRV
April 9th, 2012, 12:33 PM
It's not just desura, I seem to lack the ability to mark as trusted.
All 9 .desktop files on my desktop aren't working.

Your .desktop files belong in /home/USER_NAME/.local/share/applications.
You access them through the dash, then you can pin them to the launcher bar.

bobman321123
April 10th, 2012, 12:02 AM
I've tried marking it as executable, it just doesn't work.