PDA

View Full Version : [ubuntu] fstab cifs volume not automounted



RMSe17
April 3rd, 2012, 02:45 PM
Hi, I added a line to mount a cifs volume to the fstab. When the computer restarts, the volume does not get automounted. If I actually log into the machine, and run "sudo mount -a", the volume gets mounted correctly.

How do I make fstab automatically mount the cifs volume?

Thanks,
RMSe17

Ubuntu 10.04.04 LTS

Morbius1
April 3rd, 2012, 03:24 PM
There could be a couple of things getting in the way.

* Did you add the mount option: _netdev ( don't forget the "_" at the beginning ) to your fstab statement. It's supposed to prohibit the execution of that line until the network is up on your local machine. It doesn't seem to work reliably anymore but it's worth a shot.

* Are you specifying a netbios name or an ip address in fstab. If it's netbios name then it may just not be ready to do that at the time it's executed.