PDA

View Full Version : [SOLVED] Play dvd



dwhite
March 13th, 2012, 06:37 PM
I've checked for the past several days how to get dvds to play in lubuntu 11.10 and i've reached an impass. i have installed the following:


lubuntu-restricted-extras
medibuntu-keyring
apport-hooks-medibuntu
libdvdcss2
libdvdread4


but i can't get MPlayer work

I had linux mint installed on the same system last week and played dvds without any trouble so i know it's not my hardware.

any suggestions would be appreciated, thanks

Artificial Intelligence
March 13th, 2012, 07:26 PM
Mplayer properly requires that you install windows 32/64 codecs.

Install non-free-codecs

andrew.46
March 13th, 2012, 08:21 PM
Can you play your dvd from the commandline using the following syntax:


mplayer dvd://1

and post the command and full terminal output here? This should give some hints as to what is going on...

edit corrected syntax :(.

doctorzeus
March 13th, 2012, 10:20 PM
Personally I'm not a fan of mplayer, I by far prefer vlc on all operating systems (it comes pre-bundled with every single video codec and is fairly lightweight):

http://www.videolan.org/vlc/download-ubuntu.html

Rodney9
March 13th, 2012, 10:30 PM
For How-To's, Information and Screen-Casts on Lubuntu go to the
Lubuntu One Stop Thread -

Lubuntu One Stop Thread (http://ubuntuforums.org/showthread.php?t=1844755)

Rodney

dwhite
March 15th, 2012, 12:10 AM
thanks for the suggestions, i have downloaded vlc using synaptic pkg manager (following directions on vlc website suggested by doctorzeus as that seemed very promising (when i had linux mint installed that was the player that had worked))

it is not working in this case, i can open the disk and it loads the title into the playlist but when i try to play it title gets bold for a second or so the disk starts to spin up and then abruptly stops.

if there are any diagnostic test i can run i would gladly run it, thanks in advance for any help

i've attached a screen shot from vlc showing the codec details if that helps

andrew.46
March 15th, 2012, 01:40 AM
if there are any diagnostic test i can run i would gladly run it, thanks in advance for any help

Well, there was this suggestion:

http://ubuntuforums.org/showpost.php?p=11762354&postcount=3

:).

dwhite
March 15th, 2012, 01:54 AM
Well, there was this suggestion:

http://ubuntuforums.org/showpost.php?p=11762354&postcount=3

:).

hi, yes sorry about that, i keep getting the following (see screenshot) error, thought it was me making an error so i was a little hesitant to post, thanks.:)

ahh here is the info you were looking for..had to put into two separate screenshots hope they are legible.

andrew.46
March 15th, 2012, 02:23 AM
Oops my fault, I have supplied bad syntax! Correct is:


mplayer dvd://1

My apologies :)

dwhite
March 15th, 2012, 02:28 AM
Oops my fault, I have supplied bad syntax! Correct is:


mplayer dvd://1My apologies :)


thanks, i edited my previous post with the screenshots, didn't want to bump my post if i didn't have to. :D

waynefoutz
March 15th, 2012, 03:13 AM
put this in the terminal, then reboot.


sudo /usr/share/doc/libdvdread4/install-css.sh

any player will work after that from the GUI,like it's supposed to, I promise you.

dwhite
March 15th, 2012, 03:21 AM
put this in the terminal, then reboot.


sudo /usr/share/doc/libdvdread4/install-css.shany player will work after that from the GUI,like it's supposed to, I promise you.

does this command install libdvdread4? if so i think it is already installed, see attached synaptic screenshot

waynefoutz
March 15th, 2012, 03:45 AM
does this command install libdvdread4? if so i think it is already installed, see attached synaptic screenshot

there's more to it than that. libdvdread4 will let you play home burnt dvds, that's about it. The above command will enable restricted formats, meaning commercial dvds.

see:

https://help.ubuntu.com/community/RestrictedFormats

You need to reboot after for it to take effect.

dwhite
March 15th, 2012, 04:14 AM
there's more to it than that. libdvdread4 will let you play home burnt dvds, that's about it. The above command will enable restricted formats, meaning commercial dvds.

see:

https://help.ubuntu.com/community/RestrictedFormats

You need to reboot after for it to take effect.


Thanks for all the help, i ran the command, rebooted and still won't play dvd, i also tried with vlc player and no luck there either, i think i have a serious problem here.

thanks again, i have to get to sleep so i won't be trying anything else tonight, thinking i just might reinstall ubuntu, i wonder if i can run the LXDE desktop in ubuntu i like it very much and one of the main reasons i'd like to stay with lubuntu

ciao,

doug

waynefoutz
March 15th, 2012, 04:47 AM
Thanks for all the help, i ran the command, rebooted and still won't play dvd, i also tried with vlc player and no luck there either, i think i have a serious problem here.

thanks again, i have to get to sleep so i won't be trying anything else tonight, thinking i just might reinstall ubuntu, i wonder if i can run the LXDE desktop in ubuntu i like it very much and one of the main reasons i'd like to stay with lubuntu

ciao,

doug


Yeah, you can do that. Also, if you had success with Linux Mint, they just released a new LXDE version a few days ago.

dwhite
March 15th, 2012, 04:55 AM
Yeah, you can do that. Also, if you had success with Linux Mint, they just released a new LXDE version a few days ago.


Thanks, i'll definitely check that out.

thanks again

dwhite
March 17th, 2012, 02:22 AM
well still trying to get this to work (need to play dvd's on this system for work) switched out lubuntu for xubuntu to see if that helped, installed all the packages needed too play restricted format dvd's, tried mplayer, vlc, and parole and no luck.

finally downloaded and ran
regionset, and set to region 1 (north america) now dvd's start to play but choppy and pixelated, so i'm hopeful.


thanks again,


after reboot
regionset command seems to have solved the problem