PDA

View Full Version : [ubuntu] Noting but desktop and mouse cursor 11.10



theducksfan2010
March 9th, 2012, 12:26 AM
I checked the box in Nvidia to use multiple monitors for desktop and when it rebooted all I have left is the Ubuntu 11.10 default desktop and a mouse cursor. Anyone have any ideas?

Jon Monreal
March 9th, 2012, 04:57 AM
Before trying to fix the problem so you can use both monitors, you can try to at least restore your desktop to its prior state.

Try pressing alt+f2 simultaneously, typing in "nvidia-settings" (minus the quotes, and pressing enter to try to bring up the Nvidia settings manager. If this doesn't work, we can try something else.

theducksfan2010
March 9th, 2012, 07:33 AM
no combination of any keys would do anything, so I did a fresh install (painful). Do you have any suggestion on how i can "Safely" run dual monitors in Ubuntu? I have grown attached to both and prefer to avoid Windows for that.

Jon Monreal
March 9th, 2012, 03:02 PM
Was the above result before or after you logged in?

theducksfan2010
March 9th, 2012, 10:54 PM
That was after logging in.

kikotiger
March 9th, 2012, 11:04 PM
What is the Nvidia version? On 290.10 you have to select Separate X screen under X Server Display Configuration and save the configuration, you might have to do it manually. I would suggest not to apply the settings and reboot. If you run into the same problem, run Ubuntu in safe mode and select failsafe graphics (or something like that.)

theducksfan2010
March 13th, 2012, 11:44 PM
What is the Nvidia version? On 290.10 you have to select Separate X screen under X Server Display Configuration and save the configuration, you might have to do it manually. I would suggest not to apply the settings and reboot. If you run into the same problem, run Ubuntu in safe mode and select failsafe graphics (or something like that.)

According to NVIDIA X Server Settings I am running Driver version 280.13. Should I update to 290.10. If so where is this found?

kikotiger
March 15th, 2012, 04:26 AM
You should be fine with that version. How does your monitor configuration file looks like?


cat /etc/X11/xorg.conf

theducksfan2010
March 15th, 2012, 05:26 AM
You should be fine with that version. How does your monitor configuration file looks like?


cat /etc/X11/xorg.conf


this is what I get when i type what you posted:


office@office-GN584AA-ABA-m9060n:~$ cat /etc/X11/xorg.conf

Section "Device"
Identifier "Default Device"
Option "NoLogo" "True"
EndSection

office@office-GN584AA-ABA-m9060n:~$

Soulcage
March 15th, 2012, 05:32 AM
Have you tried sudo nvidia-xconfig?
Theres definately supposed to be more in xorg.conf.
You can also add this ppa https://launchpad.net/~ubuntu-x-swat/+archive/x-updates it will take you to 295.20

theducksfan2010
March 15th, 2012, 05:57 AM
Have you tried sudo nvidia-xconfig?
Theres definately supposed to be more in xorg.conf.
You can also add this ppa https://launchpad.net/~ubuntu-x-swat/+archive/x-updates it will take you to 295.20

office@office-GN584AA-ABA-m9060n:~$ sudo nvidia-xconfig
[sudo] password for office:

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Default Device" must have a Driver line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

office@office-GN584AA-ABA-m9060n:~$ sudo cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 280.13 (buildmeister@swio-display-x86-rhel47-03.nvidia.com) Wed Jul 27 17:15:58 PDT 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

theducksfan2010
March 19th, 2012, 05:36 AM
Bump

kikotiger
March 20th, 2012, 05:12 AM
Try setting your monitors this way. On a terminal type this


sudo nvidia-settings

Under S Server Display Configuration, click on your second monitor and select Separate X screen and apply the settings (click on the Enable Xinerama if you want to extend your desktop to your second monitor, otherwise you will have two different desktops). Then click on Save to X Configuration File, then Save. Logout and log back in to see if it works.

theducksfan2010
March 24th, 2012, 10:46 PM
Try setting your monitors this way. On a terminal type this


sudo nvidia-settings

Under S Server Display Configuration, click on your second monitor and select Separate X screen and apply the settings (click on the Enable Xinerama if you want to extend your desktop to your second monitor, otherwise you will have two different desktops). Then click on Save to X Configuration File, then Save. Logout and log back in to see if it works.

clicking on separate settings and applying required a reboot for all to take effect and upon reboot is what caused this problem. I am wary of doing so again for fear of loosing the system one more time.

But I really do need both monitors, and that fact has kept me running Windows 7 on said machine most of the time, staying away from Ubuntu (being limited to just the one monitor.)

BicyclerBoy
March 25th, 2012, 01:29 AM
You do not need a /etc/X11/xorg.conf file with current Xorg/X drivers.

I'm not sure separate X screens works with unity desktop in 11.10..& do not use Xinerama on separate X screens..
If You do, you have no openGL/GLX.

I also doubt any windows user would be satisfied with it..twinview mode is much closer to windows nvidia nview..

The OP might want to install an additional alternative desktop package:
gnome-session-fallback
Then when you login (or logout) & select the username, you can select diff desktop sessions: unity3d, 2d, gnome-classic(fallback) etc..

theducksfan2010
March 25th, 2012, 06:12 PM
You do not need a /etc/X11/xorg.conf file with current Xorg/X drivers.

I'm not sure separate X screens works with unity desktop in 11.10..& do not use Xinerama on separate X screens..
If You do, you have no openGL/GLX.

I also doubt any windows user would be satisfied with it..twinview mode is much closer to windows nvidia nview..

The OP might want to install an additional alternative desktop package:
gnome-session-fallback
Then when you login (or logout) & select the username, you can select diff desktop sessions: unity3d, 2d, gnome-classic(fallback) etc..



Sounds like you have a good grasp on this. All I need is to be able to use both monitors for separate displays. How should I configure this? Every time I try to get both running, I mess up the whole OS and make it unusable (lucky fo me it has reverted back a few times instead of keeping the incompatible settings).