PDA

View Full Version : [ubuntu] 10.04 printer "Not Connected" epson stylus SX215



samthethe
February 25th, 2012, 03:21 PM
Been troubleshooting for 3 hours this, until eventually I stubbornly booted a windows box and printed what I needed. I hate windows, but for once it actually did something I can't get my ubuntu box to do - and moreover it's a pretty simple task!!

OK two problems:

(1) I have to start the cups service by running "service cups start", it doesn't start automatically. I know how to make it start on boot, but it should start on boot out of the box - so this is a bug I suppose.

(2) When I try to print something it says "may not be connected" or "not connected?". Firstly there is no such thing as "may not", this is a bug, it either is or isn't and there should be an easy way to tell; send some data and get a response. If no response then either:
(i) it's off
(ii) some part of the connection is faulty/missing

(3) The troubleshooter tells you to start cups from system>administrator>service - but this does not exist!!

I love linux and I like the ubuntu version, but not being to print out of the box is probably why non-technical people avoid it. I can get ubuntu to play a sound, and send me an email when the weather is good for a north easterly cycle ride, but I can't get it to print!!!??!!??!!:confused:

EDIT: To be fair, not being to print really isn't the problem here as it may be poor epson linux support - the problem is the silly message "May not" - it's about as useful as a windows error message.

pbhj
July 2nd, 2012, 03:26 PM
I had a not connected issue - details of fixing "may not be connected" problem on Epson CX535WD (http://alicious.com/epson-install-kubuntu/).

Basically the KDE printer config had kept an IP address that the printer no longer had - altered it, set the printer to fixed IP address and things have been working right since.

HTH