PDA

View Full Version : [ubuntu] Sharing issue



Sagimore
February 23rd, 2012, 08:01 PM
Hello,

Having a problem with network. My Ubunto machine can see my windows 7, Home, windows 7 pro.

But my Windows machines cant see the Ubunto shares. I set up SAMBA, also updated and installed some add-ons I read I needed- Glade phython-glade...Windows machines only see each other.

Any ideas? I'm on 11.10

Thanks

Morbius1
February 23rd, 2012, 09:05 PM
* Make sure the server samba daemons are running on your Linux box:

sudo service smbd status
sudo service nmbd statusIf they aren't running start them:

sudo service smbd start
sudo service nmbd start* See if the Samba client on your box can see the Samba server on your box:

smbtreeIt should list your Linux box and any shares you created. If it does not or gives you errors post the entire output here so people can see them.

* Run the following command:

hostnameAnd count the number of characters. If it's 15 or less then you're good to go. If it's 16 characters or more then you need to fix it. You can do that in a samba config file that you will need to edit as root:

gksu gedit /etc/samba/smb.confIn the [global] section - right under the workgroup line - add the following line:

netbios name = something"something" has to be 15 character or less in length. This is the name that you lan will see when they browse the network

Then restart the samba services:

sudo service smbd restart
sudo service nmbd restartNote: every time you restart samba the network has a fit so wait a few minutes, run smbtree again to see if you can see the server without errors, and then try to connect to it from Win7.

Sagimore
February 23rd, 2012, 11:55 PM
Thanks will try tonight.

Sagimore
February 24th, 2012, 03:47 AM
It was 16 characters, and im good to go now. Thank You, very helpful