PDA

View Full Version : [SOLVED] Disable MIDI volume control in qsynth/qjackctl



treacl
January 20th, 2012, 05:19 AM
Thanks to Sylos (http://ubuntuforums.org/showthread.php?t=1911462), I am now using a harpsichord soundfont with qsynth, controlled by an Axiom 61 USB/MIDI keyboard via jack.

The keyboard has volume control, such that the harder (or faster?) you press the keys the louder the volume. Problem is, that's not the way harpsichords work. So the question is: Is there a way of disabling that in qsynth or qjackctl (or on the keyboard)?

Many thanks,
treacl

jejeman
January 20th, 2012, 10:30 AM
Thats called Velocity. So, you need to find the way to disable velocity. Some instruments have option to determine velocity data influence to sound. Sorry, I can say anything speciffic, but this is the way to go.

treacl
January 20th, 2012, 05:29 PM
Thanks, jejeman. By "instrument," do you mean the physical keyboard or the instrument soundfont? I.e., is this strictly a hardware function, or can it also be controlled/disabled in the software?

treacl
January 20th, 2012, 10:11 PM
Don't know whether there is a way to control this in jack or qsynth, but thanks to jejeman's suggestion I did figure out how to disable it on the M-Audio Axiom 61 keyboard:



Press the "EDIT" button just below the LCD.
Press the "Curve" key.
Use the patch "^" and "v" keys to select F3 on the LCD.
Press the "Store" key.
Press the "EDIT" key again to exit.

Full details in the manual, available here (http://www.m-audio.com/index.php?do=support&tab=manuals).

Thanks again, jejeman.

jejeman
January 21st, 2012, 12:06 AM
It can be done on both, hardware, as you already find out, and software side.
For example in Zyn AddSubFx here is the slider fo that