PDA

View Full Version : [SOLVED] 11.10 - Intel 3945ABG (rev 02) - Fuji-Siemens AmiloPRO v3505



Fazir
December 27th, 2011, 11:21 PM
Hello.

I've had a problem running wifi with any Linux distro on this notebook since I remember. I'm pretty sure it's possible, as I managed to run it on Fedora 7 once. Wifi was working right after install but went down after the first reboot. Now I'm trying with Ubuntu - here it's not working at all.

The wifi card is working properly on Windows.

Here are the console dumps:

1 ) Machine Brand and Model (PC/Laptop) & System info:
Fujitsu-Siemens AmiloPRO v3505
Ubuntu 11.10 (32-bit)
Kernel 3.0.0-12-generic i686

2 ) Wireless Brand, Model and Wireless Chipset:
Intel 3945ABG (rev 02)

3 ) Check interface:

$ iwconfig wlan0
wlan0 IEEE 802.11abg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

4 ) Check for modules:

$ lsmod | grep iwl3945
iwl3945 73329 0
iwl_legacy 71499 1 iwl3945
mac80211 272785 2 iwl3945,iwl_legacy
cfg80211 172392 3 iwl3945,iwl_legacy,mac80211

5 ) Kernel boot messages

$ dmesg | grep 3945
[ 7.395825] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 7.395830] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 7.395923] iwl3945 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 7.395940] iwl3945 0000:04:00.0: setting latency timer to 64
[ 7.436385] iwl3945 0000:04:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 7.436391] iwl3945 0000:04:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 7.436546] iwl3945 0000:04:00.0: irq 44 for MSI/MSI-X
[ 8.469160] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 88.764550] iwl3945 0000:04:00.0: PCI INT A disabled
[ 93.427489] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 93.427499] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 93.427622] iwl3945 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 93.427650] iwl3945 0000:04:00.0: setting latency timer to 64
[ 93.468752] iwl3945 0000:04:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 93.468763] iwl3945 0000:04:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 93.468942] iwl3945 0000:04:00.0: irq 44 for MSI/MSI-X
[ 93.469843] ieee80211 phy1: Selected rate control algorithm 'iwl-3945-rs'
[ 93.595011] iwl3945 0000:04:00.0: loaded firmware version 15.32.2.9
[ 93.595289] iwl3945 0000:04:00.0: Radio disabled by HW RF Kill switch
[ 93.731056] iwl3945 0000:04:00.0: Radio disabled by HW RF Kill switch
[ 93.731420] iwl3945 0000:04:00.0: Radio disabled by HW RF Kill switch
[ 660.225038] iwl3945 0000:04:00.0: PCI INT A disabled
[ 1315.175095] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:s
[ 1315.175104] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 1315.175218] iwl3945 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 1315.175246] iwl3945 0000:04:00.0: setting latency timer to 64
[ 1315.216285] iwl3945 0000:04:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 1315.216295] iwl3945 0000:04:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 1315.216473] iwl3945 0000:04:00.0: irq 44 for MSI/MSI-X
[ 1315.217772] ieee80211 phy2: Selected rate control algorithm 'iwl-3945-rs'
[ 1315.839330] iwl3945 0000:04:00.0: loaded firmware version 15.32.2.9
[ 1315.839615] iwl3945 0000:04:00.0: Radio disabled by HW RF Kill switch
[ 1316.129506] iwl3945 0000:04:00.0: Radio disabled by HW RF Kill switch
[ 1316.129741] iwl3945 0000:04:00.0: Radio disabled by HW RF Kill switch

6 ) Network configuration

$ *-network DISABLED
description: Wireless interface
product: PRO/Wireless 3945ABG [Golan] Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: wlan0
version: 02
serial: 00:13:02:dc:c9:8b
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwl3945 driverversion=3.0.0-12-generic firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
resources: irq:44 memory:d4000000-d4000fff

7 ) Scan for networks:

$ iwlist scan
wlan0 Failed to read scan data : Network is down

NetworkManager says "device not ready".
I have tried pushing wifi button on the keyboard, but it hasn't changed anything.

I will appreciate any help.


Edit: one more dump

$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

praseodym
December 27th, 2011, 11:36 PM
Hi,



wlan0 IEEE 802.11abg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on
Your card is "off". Try this module for Fujitsu Siemens Amilo:


sudo modprobe -v fsam7400 radio=1
sudo iwconfig wlan0 power off

Fazir
December 27th, 2011, 11:51 PM
Praseodym, thank you for your answer. Unfortunately my system doesn't contain this module:


FATAL: Module fsam7400 not found.Is it the one I should install: http://linux.zwobbl.de/pub/fsam7400-0.5.1.tgz ?
It has upload date 17-Sep-2005.

Edit:
I can't install it. It's compiling insanely long as for 11kB file - there is probably some problem but nothing is displayed.

praseodym
December 28th, 2011, 12:43 AM
Stop it with

CTRL+C

This one is too old. Try this one named fsam7440:

http://wiki.ubuntuusers.de/rfkill#Modul-fsam7400-im-Kernel

Downloadlink for 10.10 and higher

Fazir
December 28th, 2011, 01:02 AM
This page says that fsam7400 is in kernel (in fact it used to be).
The download link for 10.10+ is for fsam7440.

I have tried it - compiled, insmoded (with arg radio=1). No error, but seems like nothing changed. The second command gives error:


$ sudo iwconfig wlan0 power off
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlan0 ; Operation not supported.

Fazir
December 28th, 2011, 01:10 AM
I got it!
Googled around and found the solution:
https://secure.kitserve.org.uk/content/xorg-and-wireless-ubuntu-and-debian-fujitsu-siemens-amilo-pro-v2000d

sudo modprobe wistron_btns

It makes the wifi-button operational.


THANK YOU PRASEODYM :))
I can use Linux on my notebook thanks to you!

paraflu
December 29th, 2011, 11:19 PM
i got it!
Googled around and found the solution:
https://secure.kitserve.org.uk/content/xorg-and-wireless-ubuntu-and-debian-fujitsu-siemens-amilo-pro-v2000d

sudo modprobe wistron_btns

it makes the wifi-button operational.


Thank you praseodym :))
i can use linux on my notebook thanks to you!



grazieeeeee :ks