PDA

View Full Version : update manager crashes - possible mythtv problem



Ubu_Fester
December 13th, 2011, 09:11 PM
For the last few months, every time update manager runs (either script or through the UI), it ends with an error pointing to a mythtv problem and that the package update did not complete.

Error says:

mythtv-common script returned error exit status 128

I originally suspected a permissions issue, since I was setting samba up to read a mythtv directory. I have tried to check permissions with the mythtv group user, but don't see any problems.

I have spent hours looking for old posts and solutions. What types of checks can I make to diagnose?

Running ubuntu 10.10 and mythtv 23.1

nickrout
December 13th, 2011, 09:43 PM
sudo apt-get install mythtv-common ?

Ubu_Fester
December 14th, 2011, 02:20 AM
Thanks for your assistance. Here's the first few lines of messages after "sudo apt-get install mythtv-common"


Setting up mythtv-common (0.23.1+fixes26437-0ubuntu1) ...
dpkg: error processing mythtv-common (--configure):
subprocess installed post-installation script returned error exit status 128
dpkg: dependency problems prevent configuration of mythtv-transcode-utils:
mythtv-transcode-utils depends on mythtv-common; however:
Package mythtv-common is not configured yet.
dpkg: error processing mythtv-transcode-utils (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mythtv-backend:
mythtv-backend depends on mythtv-common; however:
Package mythtv-common is not configured yet.

nickrout
December 14th, 2011, 02:49 AM
Thanks for your assistance. Here's the first few lines of messages after "sudo apt-get install mythtv-common"


Setting up mythtv-common (0.23.1+fixes26437-0ubuntu1) ...
dpkg: error processing mythtv-common (--configure):
subprocess installed post-installation script returned error exit status 128
dpkg: dependency problems prevent configuration of mythtv-transcode-utils:
mythtv-transcode-utils depends on mythtv-common; however:
Package mythtv-common is not configured yet.
dpkg: error processing mythtv-transcode-utils (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of mythtv-backend:
mythtv-backend depends on mythtv-common; however:
Package mythtv-common is not configured yet.


ummmm try


sudo dpkg-reconfigure mythtv-common

Ubu_Fester
December 14th, 2011, 05:00 AM
Results are:


/usr/sbin/dpkg-reconfigure: mythtv-common is broken or not fully installed


BTW, this has been like this for awhile. Mythtv works fine, I'm just not getting ANY updates installed -- which is now affecting other Ubuntu updates....

nickrout
December 14th, 2011, 08:57 AM
you are beyond my apt-fu. You could try
dpkg --configure mythtv-common

Ubu_Fester
December 14th, 2011, 01:34 PM
Results:


Setting up mythtv-common (0.23.1+fixes26437-0ubuntu1) ...
dpkg: error processing mythtv-common (--configure):
subprocess installed post-installation script returned error exit status 128
Errors were encountered while processing:
mythtv-common
My thoughts now are:
- backup mythtv database
- wipe mythtv
- clean reinstall of mythtv
- restore database

But if there are some simpler diagnostic tests or other ways to reinstall, I'll try those first.:confused:

nickrout
December 14th, 2011, 07:47 PM
Results:


Setting up mythtv-common (0.23.1+fixes26437-0ubuntu1) ...
dpkg: error processing mythtv-common (--configure):
subprocess installed post-installation script returned error exit status 128
Errors were encountered while processing:
mythtv-common
My thoughts now are:
- backup mythtv database
- wipe mythtv
- clean reinstall of mythtv
- restore database

But if there are some simpler diagnostic tests or other ways to reinstall, I'll try those first.:confused:

probably no need to backup the database, but no harm either.

andree_b
December 15th, 2011, 03:05 PM
My thoughts now are:
- backup mythtv database
- wipe mythtv
- clean reinstall of mythtv
- restore database

But if there are some simpler diagnostic tests or other ways to reinstall, I'll try those first.:confused:

May be try upgrading to 0.24 instead of wipe+reinstall?