PDA

View Full Version : [SOLVED] problem with lilo and ubuntu-studio as a third os.



Snocrash
December 3rd, 2011, 06:23 AM
Hi All,

Need a little help here.... After giving up on Ubuntu and Unity/Gnome3, I decided to "go home" to Slackware (where I started many years ago...) for normal Desktop usage. And, as always, it installed and runs great. However, after a few days of playing with kernels and rt patches and SlackBuilds, etc... I decided to just install Ubuntu Studio for my recording desktop because it works so well.

I made a new partition for it on /dev/sda and installed. I skipped the loader install because I figured I already had lilo from Slack and I like that much better.

The issue is that Ubuntu seems to re-ordered my drives from the order Slack used. It has moves /dev/sda to sdb...sdb to sdc.... and sdc to sda.... How is that possible??? What went wrong??? I thought the BIOS handled that....

I tried forcing the drive order in my lilo.conf:

----------

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:

disk = /dev/sda
bios = 0x80
disk = /dev/sdb
bios = 0x81
disk = /dev/sdc
bios = 0x82

append=" vt.default_utf8=0"
boot = /dev/sda
large-memory

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used. We don't specify it here, as there's just one column.
bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 140
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
default=Sno1-rt
# Normal VGA console
#vga = normal
# VESA framebuffer console @ 1024x768x64k
vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda6
label = Linux
read-only
image = /boot/Sno1
root = /dev/sda6
label = Sno1-rt
read-only
image = /mnt/Studio/boot/vmlinuz-2.6.32-35-preempt
initrd = /mnt/Studio/boot/initrd.img-2.6.32-35-preempt
root = /dev/sda7
label = Studio
vga = normal
read-only
# Linux bootable partition config ends
----------

But 'lilo -t -v3 > /tmp/lilo.dump' gives the following:

----------

LILO version 22.8 (test mode), Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2006 John Coffman
Released 19-Feb-2007 and compiled at 14:44:48 on Feb 16 2010
Running Linux kernel 2.6.33.7-rt29-smp on i686

Warning: LBA32 addressing assumed
device-mapper major = 253
raid_setup returns offset = 00000000 ndisk = 0
BIOS VolumeID Device
Reading boot sector from /dev/sda
pf_hard_disk_scan: ndevs=3
0800 1440CA79 /dev/sda
0810 000E4D87 /dev/sdb
0820 DEAADEAA /dev/sdc
Resolve invalid VolumeIDs
Resolve duplicate VolumeIDs
0800 1440CA79 /dev/sda
0810 000E4D87 /dev/sdb
0820 DEAADEAA /dev/sdc
device codes (user assigned pf) = 7
device codes (user assigned) = 7
device codes (BIOS assigned) = 7
device codes (canonical) = 7
Device 0x0800: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 0 sectors.
Using Volume ID 1440CA79 on bios 80
Device 0x0806: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 109370583 sectors.
Using Volume ID 1440CA79 on bios 80
mode = 0x03, columns = 80, rows = 25, page = 0
Using BITMAP secondary loader
Calling map_insert_data
Secondary loader: 19 sectors (0x3800 dataend).
bios_boot = 0x80 bios_map = 0x80 map==boot = 0 map S/N: 1440CA79
Mapping bitmap file /boot/slack.bmp
Device 0x0806: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 109370583 sectors.
Using Volume ID 1440CA79 on bios 80
width=640 height=480 planes=1 bits/plane=8
Calling map_insert_file
Bitmap: 28 sectors.
BIOS data check was okay on the last boot
image_menu_space = 16

Boot other: /dev/sda1, on /dev/sda, loader CHAIN
Device 0x0801: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 63 sectors.
Using Volume ID 1440CA79 on bios 80
Device 0x0800: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 0 sectors.
Using Volume ID 1440CA79 on bios 80
Mapped 6 (4+1+1) sectors.
Added Windows
<dev=0xe0,hd=30,cyl=95,sct=162>

Boot image: /boot/vmlinuz -> vmlinuz-huge-smp-2.6.33.4-smp
Device 0x0806: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 109370583 sectors.
Using Volume ID 1440CA79 on bios 80
Setup length is 26 sectors.
Mapped 10591 sectors.
Added Linux
<dev=0xe0,hd=30,cyl=95,sct=165>
"ro root=806 vt.default_utf8=0"

Boot image: /boot/Sno1
Device 0x0806: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 109370583 sectors.
Using Volume ID 1440CA79 on bios 80
Setup length is 26 sectors.
Mapped 10119 sectors.
Added Sno1-rt *
<dev=0xe0,hd=175,cyl=102,sct=160>
"ro root=806 vt.default_utf8=0"

Boot image: /mnt/Studio/boot/vmlinuz-2.6.32-35-preempt
Device 0x0807: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 358166528 sectors.
Using Volume ID 1440CA79 on bios 80
Setup length is 26 sectors.
Mapped 8029 sectors.
Mapping RAM disk /mnt/Studio/boot/initrd.img-2.6.32-35-preempt
Device 0x0807: BIOS drive 0x80, 255 heads, 30401 cylinders,
63 sectors. Partition offset: 358166528 sectors.
Using Volume ID 1440CA79 on bios 80
RAM disk: 16360 sectors.
Added Studio
<dev=0xe0,hd=175,cyl=103,sct=7>
"ro root=807 vt.default_utf8=0"

BIOS VolumeID Device
80 1440CA79 0800
81 000E4D87 0810
82 DEAADEAA 0820
The boot sector and the map file have *NOT* been altered.
One warning was issued.
----------

Where did "device codes (canonical)=7" come from? Is that normal?? Is that the problem??? Never noticed it before....

I have tried wiping the mbr with dd, and removing the map and boot files from the /boot folder. Then re-running lilo to install it. But anytime I try to boot the Studio image, the kernel swaps /dev/sda, /dev/sdb, /dev/sdc, and fails.

I know I must be missing something here..... any help you can give is appreciated.

Thanks,

Sno

andrew.46
December 3rd, 2011, 12:47 PM
Could be a little late but the best way to multiboot with Lilo is to install Lilo to mbr and boot slackware from this. Then install Ubuntu to its partition and install grub to the root of this Ubuntu partition rather than the mbr (there is an option to do this during installation). Then chainload the Ubuntu installation from Lilo. Avoids a lot of mess and is easier when Ubuntu changes its kernel...

Snocrash
December 3rd, 2011, 02:58 PM
Could be a little late but the best way to multiboot with Lilo is to install Lilo to mbr and boot slackware from this. Then install Ubuntu to its partition and install grub to the root of this Ubuntu partition rather than the mbr (there is an option to do this during installation). Then chainload the Ubuntu installation from Lilo. Avoids a lot of mess and is easier when Ubuntu changes its kernel...

Nice idea... But yes it is a little late for that. I can boot Studio by adding "root=/dev/sdb7" to the prompt. But I was wondering why. and if it can be fixed so I don't need to do this....

Thanks,

-Sno

Snocrash
December 10th, 2011, 06:10 PM
Well.... Finally got around to setting up the networking on the ubuntu side. Upgraded the kernel and BANG.... Fixed.... It orders the drives correctly.... :D

Still not sure what the issue was with the original kernel tho....


-Sno