PDA

View Full Version : Xserver 1.11.2 is released



Harry33
November 5th, 2011, 07:03 PM
Those, who are using 1.11 series xserver might have noticed that there is a new release (1.11.2) available from Xorg-edgers PPA.
This is in the Oneiric branch, but it works very well with Precise too.

For people using xserver 1.10, upgrading to xserver 1.11 demands you to update all input and video drivers too. These are also available from Xorg-edgers.
So go ahead and break your X :D .

VinDSL
November 6th, 2011, 08:04 AM
So go ahead and break your X :D .
You crystallized my thoughts exactly... :D

dino99
November 6th, 2011, 10:41 AM
i've seen somewhere that ATI driver dont work with 1.11 yet

" Meanwhile the AMD Catalyst driver still doesn't support the X.Org Server 1.11 series, but it will later in the month. " [phoronix]

Harry33
November 6th, 2011, 11:51 AM
i've seen somewhere that ATI driver dont work with 1.11 yet

" Meanwhile the AMD Catalyst driver still doesn't support the X.Org Server 1.11 series, but it will later in the month. " [phoronix]

Right, it will take time for AMD. Nvidia is already there.

Harry33
November 9th, 2011, 06:56 PM
And now the xserver 1.11.2 + git 20111109 is available from Xorg-edgers (precise branch) too.

Starks
November 9th, 2011, 11:59 PM
Remember, 1.11 doesn't work with Unity yet because of the hard dependency on Unity.

Harry33
November 10th, 2011, 10:44 AM
Remember, 1.11 doesn't work with Unity yet because of the hard dependency on Unity.

That is the way it is now.
Anyway, no problem for me because I do not use nor have installed Unity.
I am using Gnome-shell (from Ricotz testing PPA)
and Xserver 1.11.2 (from Xorg-edgers).
With nvidia-current (290.06) these work pretty well now.

Starks
November 10th, 2011, 10:51 AM
Meant to say "hard dependency on Utouch", but Unity works too.

Harry33
November 10th, 2011, 01:40 PM
Meant to say "hard dependency on Utouch", but Unity works too.

Perhaps you meant to say that in setups with xserver 1.11 series installed, Compiz segfaults when starting unity.
This is because xserver 1.11 does not have the multitouch support at the moment and Compiz needs to have it.


Se this bug (# 860707) report of Robert Hooker:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/860707

rockorequin
November 20th, 2011, 02:45 AM
Robert Hooker added a patched unity to xorg-edgers, so now unity doesn't crash if you're using the PPA.

Everything works fine on my intel system except for google-earth, which can't see glx so it asks if I want to switch to DirectX mode (!).