PDA

View Full Version : [SOLVED] Lenovo G770 disabled bluetooth



tomek_wap
November 2nd, 2011, 11:57 PM
Hello all,

Having an annoying issue with built in bluetooth module.
Notebook is Lenovo G770.

Wireless is working good.
Bluetooth in Bluetooth manager/settings is shows as "bluetooth is disabled".

Switching to "ON" does nothing.

Tried Broadcom STA Drivers, but nothing seems to help.

Can't find any related post anywhere that would represent my case.

Pls help. Thnx!

Redblade20XX
November 3rd, 2011, 04:03 AM
If your bluetooth is integrated, check your BIOS and see if it's disabled there. If not, we'll troubleshoot further! :)

- Red

tomek_wap
November 3rd, 2011, 10:20 AM
in bios i can only see: wireless lan supporter

with no option do enable/disable or whatever

bluetooth is most likely integrated with wireless lan mdule. there is a hardware switch, which is for switching on/off wlan and bluetooth.

hardware information that ive managed to get out of ubuntu:

Wireless interface product: AR9285 Wireless Network Adapter (PCI-Express) vendor: Atheros Communications Inc.

nothing more ...

Edit: borrowed a Pentagram branded BT dongle ... works like a charm! :) but still I want to use what I paid for, i.e. built in BT module.

tomek_wap
November 28th, 2011, 07:54 PM
Just a quick note: problem solved by turning on the Bluetooth in Windows ... then it started to work in Ubuntu ... how strange, I mean is s/w switch directly "connected" to hardware?

Anyways, it all works fine now :)