PDA

View Full Version : [xubuntu] Xubuntu network proxy settings



cortman
October 31st, 2011, 09:37 PM
How can I change the proxy settings for my network connection? In Xubuntu 11.10.

Toz
November 1st, 2011, 02:20 PM
Add the following to /etc/environment:


http_proxy="http://user:password@proxy:port"
https_proxy="http://user:password@proxy:port"
ftp_proxy="http://user:password@proxy:port"
export http_proxy https_proxy ftp_proxy

Log out and back in again for it to take effect,

cortman
November 1st, 2011, 03:44 PM
I tried, it didn't work.
Is there no GUI way to do it in Xubuntu?

gsmanners
November 1st, 2011, 05:38 PM
It isn't just Xubuntu. Linux as a general rule doesn't "proxy" anything. Certain applications (like Firefox) can set up a proxy connection, but I suspect that's not what you want either. If you have a VPN connection, you can easily configure that through the GUI (using the network applet).

Toz
November 1st, 2011, 06:04 PM
I tried, it didn't work.
Is there no GUI way to do it in Xubuntu?

Okay. Just verified my settings here at work:

-rw-r--r-- 1 root root 296 2011-11-01 12:50 /etc/profile.d/proxy.sh

export http_proxy="http://user:password@proxyserver:port"
export https_proxy="http://user:password@proxyserver:port"
export ftp_proxy="http://user:password@proxyserver:port"

export HTTP_PROXY="http://user:password@proxyserver:port"
export HTTPS_PROXY="http://user:password@proxyserver:port"
export FTP_PROXY="http://user:password@proxyserver:port"

...You could also use /etc/environment, but the method is to put your scripts in /etc/profile.d. I just recently rebuilt and added them here this time.

For the apt tools to work, I also have:

$ -rw-r--r-- 1 root root 74 2011-10-26 10:09 /etc/apt/apt.conf.d/50proxy

Acquire {
Retries "0";
HTTP {
Proxy "http://user:password@proxyserver:port";
};
};


Naturally, I have the correct values in the files in place of the keywords "user" "password" "proxyserver" "port"