PDA

View Full Version : [SOLVED] 11.10 fresh install, wireless is very slow.



rkrizan
October 14th, 2011, 06:16 AM
Completed a fresh install of Ubuntu 11.10, and now the wireless is extremely slow. I cannot get speeds over 10kbps, if that at all. However, my other laptop can download the same file from the same location at nearly 2Mbps. Any suggestions?

rkrizan
October 14th, 2011, 07:23 AM
The laptop is a Dell E1505:

root@pharaoh:~# lspci|grep Network
0b:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
root@pharaoh:~# lsmod|grep iwl
iwl4965 123423 0
iwl_legacy 71673 1 iwl4965
mac80211 271515 2 iwl4965,iwl_legacy
cfg80211 169178 3 iwl4965,iwl_legacy,mac80211
root@pharaoh:~# dmesg|grep iwl
[ 17.114080] iwl4965: Intel(R) Wireless WiFi 4965 driver for Linux, in-tree:
[ 17.114083] iwl4965: Copyright(c) 2003-2011 Intel Corporation
[ 17.114171] iwl4965 0000:0b:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 17.114202] iwl4965 0000:0b:00.0: setting latency timer to 64
[ 17.114253] iwl4965 0000:0b:00.0: Detected Intel(R) Wireless WiFi Link 4965AGN, REV=0x4
[ 17.156665] iwl4965 0000:0b:00.0: device EEPROM VER=0x36, CALIB=0x5
[ 17.157681] iwl4965 0000:0b:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
[ 17.157836] iwl4965 0000:0b:00.0: irq 43 for MSI/MSI-X
[ 17.175236] iwl4965 0000:0b:00.0: loaded firmware version 228.61.2.24
[ 17.424261] ieee80211 phy0: Selected rate control algorithm 'iwl-4965-rs'
[ 103.746511] iwl4965 0000:0b:00.0: Aggregation not enabled for tid 0 because load = 0
[ 151.655683] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 0
[ 169.864892] iwl4965 0000:0b:00.0: Aggregation not enabled for tid 1 because load = 10
[ 1440.676102] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 1
[ 2281.534724] iwl4965 0000:0b:00.0: Error sending TX power (-5)
[ 2281.550232] iwl4965 0000:0b:00.0: Attempting to modify non-existing station 31
[ 2281.552523] iwl4965 0000:0b:00.0: Attempting to modify non-existing station 0
[ 2281.570436] iwl4965 0000:0b:00.0: Error sending TX power (-5)
[ 2281.613246] iwl4965 0000:0b:00.0: PCI INT A disabled
[ 2315.833840] iwl4965: Intel(R) Wireless WiFi 4965 driver for Linux, in-tree:
[ 2315.833843] iwl4965: Copyright(c) 2003-2011 Intel Corporation
[ 2315.833942] iwl4965 0000:0b:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 2315.833988] iwl4965 0000:0b:00.0: setting latency timer to 64
[ 2315.834217] iwl4965 0000:0b:00.0: Detected Intel(R) Wireless WiFi Link 4965AGN, REV=0x4
[ 2315.876711] iwl4965 0000:0b:00.0: device EEPROM VER=0x36, CALIB=0x5
[ 2315.876799] iwl4965 0000:0b:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
[ 2315.876934] iwl4965 0000:0b:00.0: irq 43 for MSI/MSI-X
[ 2315.880479] iwl4965 0000:0b:00.0: loaded firmware version 228.61.2.24
[ 2315.882659] ieee80211 phy1: Selected rate control algorithm 'iwl-4965-rs'
[ 2333.616126] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 0
[ 2566.711444] iwl4965 0000:0b:00.0: Aggregation not enabled for tid 0 because load = 2
[ 2703.136109] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 0
[ 2706.725598] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 1
[ 2963.141047] iwl4965 0000:0b:00.0: Error sending TX power (-5)
[ 2963.158411] iwl4965 0000:0b:00.0: Attempting to modify non-existing station 31
[ 2963.160706] iwl4965 0000:0b:00.0: Attempting to modify non-existing station 0
[ 2963.170462] iwl4965 0000:0b:00.0: Error sending TX power (-5)
[ 2963.222157] iwl4965 0000:0b:00.0: PCI INT A disabled
[ 2970.877086] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[ 2970.877090] iwlagn: Copyright(c) 2003-2011 Intel Corporation
[ 3003.955910] iwl4965: Intel(R) Wireless WiFi 4965 driver for Linux, in-tree:
[ 3003.955917] iwl4965: Copyright(c) 2003-2011 Intel Corporation
[ 3003.956079] iwl4965 0000:0b:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 3003.956147] iwl4965 0000:0b:00.0: setting latency timer to 64
[ 3003.956579] iwl4965 0000:0b:00.0: Detected Intel(R) Wireless WiFi Link 4965AGN, REV=0x4
[ 3003.999627] iwl4965 0000:0b:00.0: device EEPROM VER=0x36, CALIB=0x5
[ 3003.999677] iwl4965 0000:0b:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
[ 3003.999918] iwl4965 0000:0b:00.0: irq 43 for MSI/MSI-X
[ 3004.003128] iwl4965 0000:0b:00.0: loaded firmware version 228.61.2.24
[ 3004.003528] ieee80211 phy2: Selected rate control algorithm 'iwl-4965-rs'
[ 3032.756120] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 0
[ 3040.565656] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 1
[ 3113.092614] iwl4965 0000:0b:00.0: Error sending TX power (-5)
[ 3113.110243] iwl4965 0000:0b:00.0: Attempting to modify non-existing station 31
[ 3113.112521] iwl4965 0000:0b:00.0: Attempting to modify non-existing station 0
[ 3113.126474] iwl4965 0000:0b:00.0: Error sending TX power (-5)
[ 3113.177662] iwl4965 0000:0b:00.0: PCI INT A disabled
[ 3134.786520] iwl4965: Intel(R) Wireless WiFi 4965 driver for Linux, in-tree:
[ 3134.786523] iwl4965: Copyright(c) 2003-2011 Intel Corporation
[ 3134.786616] iwl4965 0000:0b:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 3134.786662] iwl4965 0000:0b:00.0: setting latency timer to 64
[ 3134.786713] iwl4965 0000:0b:00.0: Detected Intel(R) Wireless WiFi Link 4965AGN, REV=0x4
[ 3134.829377] iwl4965 0000:0b:00.0: device EEPROM VER=0x36, CALIB=0x5
[ 3134.829406] iwl4965 0000:0b:00.0: Tunable channels: 11 802.11bg, 13 802.11a channels
[ 3134.829548] iwl4965 0000:0b:00.0: irq 43 for MSI/MSI-X
[ 3134.832960] iwl4965 0000:0b:00.0: loaded firmware version 228.61.2.24
[ 3134.833442] ieee80211 phy3: Selected rate control algorithm 'iwl-4965-rs'
[ 3152.136140] iwl4965 0000:0b:00.0: iwl4965_tx_agg_start on ra = 00:24:b2:17:a3:ba tid = 0
[ 3649.791751] iwl4965 0000:0b:00.0: Aggregation not enabled for tid 1 because load = 0
root@pharaoh:~#

Flashman2003
October 14th, 2011, 02:59 PM
Same problem here with a vaio fz-21s

Very annoying (beside having to use unity)

majed
October 14th, 2011, 08:07 PM
Same problem here on Lenovo Y430.. connecting the ethernet cable, speed is fine but wireless is SO slow!!!

All was fine when i was using 11.04 this morning but not now with 11.10 :(

majed
October 14th, 2011, 08:50 PM
WORKAROUND:

I disabled IPv6 as per http://www.unixmen.com/linux-tutorials/linux-distributions/linux-distributions4-ubuntu/1785-resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal

Works fine now :)

I hope the issue will be fixed before we have to use IPv6! ;)

Flashman2003
October 14th, 2011, 11:01 PM
Same problem on vaio fz-21s. Disabling IPv6 does not work. And I need IPv6 anyway.

Ubuntu is using the iwl4965 driver and I can barely open a page. 56k flashback

Wifi works fine on windows.

I wonder if the problem is that i use wifi n and not b. What do you guys use?

oskreso
October 14th, 2011, 11:32 PM
Hi,

I have HP 6710b and have same problem with wireless. It's very slow.

:confused:

rkrizan
October 15th, 2011, 01:37 AM
That didn't work for me.

rkrizan
October 15th, 2011, 05:19 AM
Just tested the wireless connection via 11.10 LiveCD on my 1545 with an Intel Wifi Link 5100 card. Same issue. How fun! Maybe it's time to abandon Ubuntu for another distribution.

oskreso
October 15th, 2011, 10:09 AM
I agree!

I am going back to 11.04.

room271
October 15th, 2011, 02:37 PM
I have the same problem. Wireless is very slow for my Dell M14x after the upgrade - it worked perfectly with 11.04.

The link with instructions above seems to have helped a bit, but still very slow.

Does anyone know if there is a revert - to easily restore the previous version of Ubuntu? I'm guessing not but thought I'd ask.

I like a lot about 11.10 but without internet it is pretty useless :(

oskreso
October 15th, 2011, 06:28 PM
My problem is related to wireless encryption. When I change WPA2 to WEP, it works fine.
But this is not the solution.

Wild Man
October 15th, 2011, 09:24 PM
Hi Flashman2003, you should try b,g, speed and see if that helps, it has helped some.
Thank you

rkrizan
October 15th, 2011, 09:54 PM
I've tried both b&g, no such luck. Something else that bothers me about 11.10, no Gnome classic fallback, such as the case with 11.04. I dislike unity, and I prefer the classic UI. However, the fallback mode is no longer on 11.10, and installing it gives me an incomplete Gnome desktop. It's like Ubuntu is forcing us that dislike Unity to deal with Unity or go elsewhere. So the laptop I am currently using has been reverted back to 11.04, and my primary laptop is in the process of getting Debian 6.0 installed on it. I'm glad I have separate /home partitions.

Airward
October 15th, 2011, 11:14 PM
WORKAROUND:

I disabled IPv6 as per http://www.unixmen.com/linux-tutorials/linux-distributions/linux-distributions4-ubuntu/1785-resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal

Works fine now :)

I hope the issue will be fixed before we have to use IPv6! ;)

It seems, that my connection got even slower after this...

Flashman2003
October 15th, 2011, 11:30 PM
Hi Flashman2003, you should try b,g, speed and see if that helps, it has helped some.
Thank you

Nothing helps, not even using WEP instead of WPA/WPA2. I cannot use none encryption to test but what would be the point

Wild Man
October 15th, 2011, 11:38 PM
Hi Flashman2003,
Please try this and if it helps we will need to make it permanent.

sudo ifconfig wlan0 down
sudo rmmod -f iwl4965
sudo modprobe iwl4965 11n_disable=1
sudo ifconfig iwl4965 up
Thank you

rkrizan
October 16th, 2011, 01:25 AM
Hi Flashman2003,
Please try this and if it helps we will need to make it permanent.

sudo ifconfig wlan0 down
sudo rmmod -f iwl4965
sudo modprobe iwl4965 11n_disable=1
sudo ifconfig iwl4965 up
Thank you


I tested this on my Dell 1545 that has a Wifi Link 5100 card using the 64-bit 11.10 LiveCD, and this did do this trick. I will be testing it on my E1505 via 32-bit LiveCD as well, and will report back here.

Wild Man
October 16th, 2011, 01:27 AM
Hi, that will only work if the other computer is using the same driver.

So we do need to make that permanent on at least one computer correct?
Thank you

rkrizan
October 16th, 2011, 01:49 AM
Hi, that will only work if the other computer is using the same driver.

So we do need to make that permanent on at least one computer correct?
Thank you

The Dell 1545 uses the iwlagn driver. So easy enough I removed the iwlagn kernel module, and modprobed it back with the '11n_disable=1" option, and it works great.

I just tested it on the E1505, that uses the iwl4965 driver, and following the same formula of removing the iwl4965 module, re-adding it via modprobe iwl4965 11n_disable=1, and this too, is now working as it should. I get proper download rates on both machines.

Now, how would one go about making this permanent without having to reset the kernel module every time the computer is restarted?

Wild Man
October 16th, 2011, 02:00 AM
Hi,
To disable 802.11n on this card create /edit your /etc/modprobe.d/options.conf file like this.
Code:

gksu gedit /etc/modprobe.d/options.conf
And add the following to it:

options iwl4965 11n_disable=1
proof read then save and exit.
Thank you

rkrizan
October 16th, 2011, 02:22 AM
Installing 11.10 fresh on the Dell E1505. Will report back here with results.

Wild Man
October 16th, 2011, 02:24 AM
Okay I will keep my fingers crossed!!!

rkrizan
October 16th, 2011, 02:58 AM
So far so good. 11.10 is now installed. I mounted the root partition and edited the options.conf file, or rather created and added the option, before I even restarted for the first time from the LiveCD. So it now works on the E1505 as it should. I will be doing the same on the 1545 here shortly. Thanks.

rkrizan
October 16th, 2011, 04:14 AM
So far so good on the 1545 as well. Thanks for the help! I'll mark this thread as solved. Hopefully others will chime in and let us know if it worked for them as well.

Wild Man
October 16th, 2011, 04:15 AM
Hi, your very welcome! I am glad I could help.

nerderello
October 16th, 2011, 11:18 AM
no, doesn't work for me.

I've tried the "disable IPV6", no change.

I've tried the use b or g (I have an Asus N13 dongles and so amended /etc/Wireless/RT3070STA/RT3070STA.dat so that Wirelessmode = 4 (forces it onto b - 11 megabits per second rate - confirmed with 'iwlist rate') (an aside, odd number/name to give to file, as the driver is called rt2800usb).

To give you an idea of the performance drop with this version of Ubuntu (11.10), I run http://www.speedtest.net/ and get about 0.8 of a meg. I then reboot my PC and load a copy of Mint from another partition and re-run the test and get over 5 meg.

nerderello
October 16th, 2011, 02:52 PM
this is a Kernel 3 issue (3.0.0-12-generic) .

I've just rebooted, but used a 'previous version' option that was put into Grub when I upgraded from 10.10 to 11.04. This has allowed me to boot with kernel 2.6.38-11-generic.

Now, when I run a speedtest I get 5 meg (rather than the 0.8 meg that kernel version 3.0.0-12-generic gives.

So it's either the kernel or the driver that goes with it.

ellipsoid
October 16th, 2011, 04:39 PM
I have same problem on VAIO laptop VPC-S11V (iwlagn driver).
I've reverted to 10.04 for now, but will maybe try some of the suggestions here later.

cem.beyaz
October 16th, 2011, 05:32 PM
This is not the real solution..
The wireless card is not working properly...

Flashman2003
October 16th, 2011, 06:42 PM
Disabling n on the adapter instead of the routeur solved it for me. Well, until a solution is found to use wifi n.

Thanks a lot wildmanne39 :)

Now that I remember, in Ubuntu 10.10 I had to enable n manually because it was said to be unstable but it worked fine for me. Then on 11.04 it was enabled by default and worked fine too. I don't know what happened on 11.10 now...

Wild Man
October 16th, 2011, 06:48 PM
Hi nerderello, it is a driver issue, the place you want to change the speed to b,g,n, is in your router and not just n.

Try this please and see if it helps it is only good until you reboot, if it helps we will have to make it permanent.

sudo ifconfig wlan0 down
sudo rmmod -f rt2800usb
sudo modprobe rt2800usb nohwcrypt=1
sudo ifconfig wlan0 up
Thank you

Wild Man
October 16th, 2011, 07:15 PM
Hi Flashman2003, your welcome!

nerderello
October 17th, 2011, 02:13 PM
Hi wildmanne39,
thanks for the reply. Sadly it had no effect.

I've spliced together the commands with the dmesg output:


sudo ifconfig wlan0 down
sudo rmmod -f rt2800usb

[ 524.536533] usbcore: deregistering interface driver rt2800usb

sudo modprobe rt2800usb nohwcrypt=1

[ 547.987353] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987364] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987371] cfg80211: Updating information on frequency 2417 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987378] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987383] cfg80211: Updating information on frequency 2422 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987390] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987395] cfg80211: Updating information on frequency 2427 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987402] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987407] cfg80211: Updating information on frequency 2432 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987413] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987419] cfg80211: Updating information on frequency 2437 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987425] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987430] cfg80211: Updating information on frequency 2442 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987437] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987442] cfg80211: Updating information on frequency 2447 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987448] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987454] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987460] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987465] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987472] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987477] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987484] cfg80211: 2402000 KHz - 2472000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987489] cfg80211: Updating information on frequency 2467 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987496] cfg80211: 2457000 KHz - 2482000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987501] cfg80211: Updating information on frequency 2472 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987507] cfg80211: 2457000 KHz - 2482000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987513] cfg80211: Updating information on frequency 2484 MHz for a 20 MHz width channel with regulatory rule:
[ 547.987519] cfg80211: 2474000 KHz - 2494000 KHz @ KHz), (300 mBi, 2000 mBm)
[ 547.987742] ieee80211 phy2: Selected rate control algorithm 'minstrel_ht'
[ 547.994990] Registered led device: rt2800usb-phy2::radio
[ 547.995039] Registered led device: rt2800usb-phy2::assoc
[ 547.995086] Registered led device: rt2800usb-phy2::quality
[ 548.000113] usbcore: registered new interface driver rt2800usb
[ 548.081207] init: network-interface (wlan0) pre-start process (3092) terminated with status 1
[ 548.084463] init: network-interface (wlan0) post-stop process (3094) terminated with status 1

sudo ifconfig wlan0 up

[ 615.808672] wlan0: authenticate with 00:14:6c:b5:d7:06 (try 1)
[ 615.810182] wlan0: authenticated
[ 615.864642] wlan0: associate with 00:14:6c:b5:d7:06 (try 1)
[ 615.868276] wlan0: RX AssocResp from 00:14:6c:b5:d7:06 (capab=0x431 status=0 aid=1)
[ 615.868280] wlan0: associated
[ 615.876358] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

I had to disable and re-enable Wireless networks in the gui applet, for this to work.

I then tried another speedtest and got 0.8 meg.

As an aside, is there a way of displaying which wireless modes the usb adapter is using? If I do a iwconfig I get (this is after your commands and no reboot has been done) :


lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"SKY95885"
Mode:Managed Frequency:2.462 GHz Access Point: 00:14:6C:B5:D7:06
Bit Rate=18 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=41/70 Signal level=-69 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:93 Invalid misc:2 Missed beacon:0
While an ifconfig gives:

eth0 Link encap:Ethernet HWaddr 00:19:66:8b:14:7c
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:21 Base address:0x4000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:50 errors:0 dropped:0 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3588 (3.5 KB) TX bytes:3588 (3.5 KB)

wlan0 Link encap:Ethernet HWaddr 00:26:18:c5:04:cf
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1836 errors:0 dropped:0 overruns:0 frame:0
TX packets:1892 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1701484 (1.7 MB) TX bytes:872175 (872.1 KB)

Which differs from the output when I boot up with kernel version 2.6.38-11-generic:

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 Ralink STA ESSID:"SKY95885" Nickname:"RT2870STA"
Mode:Managed Frequency=2.462 GHz Access Point: 00:14:6C:B5:D7:06
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Link Quality=100/100 Signal level:-55 dBm Noise level:-63 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
and


eth0 Link encap:Ethernet HWaddr 00:19:66:8b:14:7c
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:21

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 B) TX bytes:100 (100.0 B)

wlan0 Link encap:Ethernet HWaddr 00:26:18:c5:04:cf
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9064 errors:0 dropped:0 overruns:0 frame:0
TX packets:350 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1629716 (1.6 MB) TX bytes:77729 (77.7 KB)

Lexworth
October 17th, 2011, 08:39 PM
I have an Acer Timeline X with an Atheros wireless card and chipset that uses the ath9k driver. I was getting terrible speeds when using WPA2 Enterprise encryption and having to use my institutions guest network. I tried this from a previous post and now I'm getting proper speeds on WPA2 Enterprise.



sudo ifconfig wlan0 down
sudo rmmod -f ath9k
sudo modprobe ath9k nohwcrypt=1
sudo ifconfig wlan0 up


But my question now is what exactly does adding nohwcrypt=1 do and how do I make it permanent?

Thanks for your help wildmanne39.

Wild Man
October 17th, 2011, 09:02 PM
Hi nerderello, letś try this please if it works we will need to make it permanent.

sudo iwconfig wlan0 power off
Do not restart your computer after you run that command.
Thank you

Wild Man
October 17th, 2011, 09:06 PM
Hi Lexworth, that command makes your card use software encryption instead of hardware.

This is how you make it permanent.

Please do:

gksudo gedit /etc/modprobe.d/ath9k.conf
Add a single line:

options ath9k nohwcrypt=1
Proofread carefully, save and close gedit. Reboot.
Thank you

nerderello
October 18th, 2011, 12:36 AM
Hi wildmanne39,
thanks for the suggestion.

Sadly the same result.

Not sure why we're trying to turn off hardware encryption, as my hardware set up works quite happily with earlier versions of the kernel / driver.

But I open to any suggestions.

thanks
Nerderello

nerderello
October 18th, 2011, 12:57 AM
RESOLVED!:popcorn:
Found it.

I use an ASUS N13 USB Wireless dongle, and to get this to work with earlier versions of the kernel/driver, I (like any other user of this adapter) had to add a couple of rules to get it accepted (thanks to forum member Chili555 for that information).

One of the files that had to be created was /etc/modprobe.d/network_drivers.conf . In this file was the single line


install rt2870sta /sbin/modprobe --ignore-install rt2870sta $CMDLINE_OPTS; /bin/echo "0b05 1784" > /sys/bus/usb/drivers/rt2870/new_id


I've put a hash (#) at the beginning of that line (ie. made it into a comment) and rebooted my PC (for good measure, I also pulled the ASUS N13 out and plugged it back in, to make sure that there was nothing loaded into it).

I now get "normal" internet speeds.

I have tried this with and without the 'no hardware encrypt' and it makes no difference.

Many thanks wildmanne39 for your help, but this one has turned out to be down to some sort of driver clash (strange, but the rt2780sta module didn't show up in a lsmod).

But a heads up for all other ASUS N13 users who upgrade.

compaddict
October 18th, 2011, 01:39 AM
HP DV7 2185DX.. Going back to 11.04 till resolved. Fresh install works on b/g wireless with older linksys routers but on wrt120n & my older home n router wireless stalls.
I need my n.

Wild Man
October 18th, 2011, 02:12 AM
Hi nerderello, I am glad you got it sorted out.

That driver is not in 11.10 that is why it does not show up.
Enjoy

LinuxT60
October 18th, 2011, 06:42 AM
Confirming this sorted it out for the Lenovo T410 as well.

I just had to create the .conf with


options iwlagn 11n_disable=1

Obviously I have no 802.11n, but that is by far, less important than B/G connectivity for me.

palimmo
October 20th, 2011, 02:30 PM
Same problem with PB Easynote TJ65 and Ubuntu 11.10.
The wifi connection is slower compared to 11.04.... annoying during live video streaming (TV, etc...)

Could you help me, please?
Here some info:


~$ sudo lshw -C network
*-network
description: Ethernet interface
product: NetLink BCM5784M Gigabit Ethernet PCIe
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: eth0
version: 10
serial: 00:26:2d:5f:5c:c0
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.119 firmware=sb v2.19 latency=0 link=no multicast=yes port=twisted pair
resources: irq:46 memory:f3000000-f300ffff
*-network
description: Wireless interface
product: AR928X Wireless Network Adapter (PCI-Express)
vendor: Atheros Communications Inc.
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 01
serial: 70:1a:04:45:53:c2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath9k driverversion=3.0.0-12-generic firmware=N/A ip=192.168.2.102 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
resources: irq:17 memory:f3100000-f310ffff



~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:26:2d:5f:5c:c0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:16

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3614 errors:0 dropped:0 overruns:0 frame:0
TX packets:3614 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:397638 (397.6 KB) TX bytes:397638 (397.6 KB)

wlan0 Link encap:Ethernet HWaddr 70:1a:04:45:53:c2
inet addr:192.168.2.102 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::721a:4ff:fe45:53c2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:53964 errors:0 dropped:0 overruns:0 frame:0
TX packets:49879 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:40743115 (40.7 MB) TX bytes:9256456 (9.2 MB)



~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"WLAN-7BCE36"
Mode:Managed Frequency:2.412 GHz Access Point: 04:C0:6F:DA:7B:CE
Bit Rate=162 Mb/s Tx-Power=16 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=48/70 Signal level=-62 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:2 Missed beacon:0



~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback



~$ ping -c 4 google.com
PING google.com (209.85.148.105) 56(84) bytes of data.
64 bytes from fra07s07-in-f105.1e100.net (209.85.148.105): icmp_req=1 ttl=57 time=61.5 ms
64 bytes from fra07s07-in-f105.1e100.net (209.85.148.105): icmp_req=2 ttl=57 time=60.4 ms
64 bytes from fra07s07-in-f105.1e100.net (209.85.148.105): icmp_req=3 ttl=57 time=62.1 ms
64 bytes from fra07s07-in-f105.1e100.net (209.85.148.105): icmp_req=4 ttl=57 time=61.4 ms

--- google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 60.413/61.358/62.104/0.655 ms


Should I disable the N connection? How?
Thanks a lot!!

hero1900
November 1st, 2011, 11:32 AM
i don't know how this solved most of the people having issue still so it should be open thread

Wild Man
November 1st, 2011, 06:09 PM
Hi, it is solved because the issue is fixed for the original poster.

You can start your own thread then when it is solved for you, you mark it solved.

People can still get help in this thread on the same issue with the same hardware, when someone is on to help.
Thank you

jmate24
November 2nd, 2011, 03:01 AM
give this a try: http://http://ubuntuforums.org/showthread.php?t=1873731
but instead of wired go to the wireless connection.

Captainawol
December 13th, 2011, 04:55 AM
In case anyone else has this problem I disabled hwecryption and it resolved the issue as far as I can tell and wireless n works fine. The exact name of the option can be found by running modinfo iwl4965 ( the default is 0 enabled I set it to 1 disabled ) and the wireless started to behave itself. You can use the same info found in page two of this thread for adding the option to the /etc/modprobe.d/modprobe.conf file and once there, reboot and all should be right with the world.. and by the way the same fix worked for a laptop I had which had pretty much the same symptoms but was running an atheros chipset with the ath9k driver.

adelani
December 13th, 2011, 04:00 PM
Hi,
To disable 802.11n on this card create /edit your /etc/modprobe.d/options.conf file like this.
Code:

gksu gedit /etc/modprobe.d/options.conf
And add the following to it:

options iwl4965 11n_disable=1
proof read then save and exit.
Thank you
Thanks it works very good
I'm using Ubuntu 11.10 , Vaio VGN - FZ340E & My Problem SOLVED
Many Thanks

fleming164
January 8th, 2012, 01:51 AM
Thanks so much wildmanne39 (http://ubuntuforums.org/member.php?u=508533) :) Solved all my issues :)

Wild Man
January 8th, 2012, 02:49 AM
Hi, your welcome!
Enjoy

siddi
January 8th, 2012, 02:23 PM
hi guys.
I am a bit totally lost here.... I have tried in vain for the last 2 months to fix my wifi after i upgraded to ubuntu 11.10

I have an acer aspire 5570, it connects to the internet but the connection keeps dropping every few seconds...

Am not that tech savvy.

Could anybody please take me tru fixing this?

thanks

regards
sid

Wild Man
January 8th, 2012, 11:36 PM
Hi, please post the output of:

cat /etc/lsb-release; uname -a
lspci -nnk | grep -iA2 net
iwconfig
rfkill list all
lsmod
here by clicking on new reply and click # and paste the information between the brackets.
Thank you

siddi
January 8th, 2012, 11:41 PM
siddharth@siddharth-Aspire-5570:~$ cat /etc/lsb-release; uname -a
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
Linux siddharth-Aspire-5570 3.0.0-14-generic #23-Ubuntu SMP Mon Nov 21 20:34:47 UTC 2011 i686 i686 i386 GNU/Linux
siddharth@siddharth-Aspire-5570:~$ lspci -nnk | grep -iA2 net
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8038 PCI-E Fast Ethernet Controller [11ab:4352] (rev 14)
Subsystem: Acer Incorporated [ALI] Device [1025:0110]
Kernel driver in use: sky2
--
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
Subsystem: Intel Corporation PRO/Wireless 3945BG Network Connection [8086:1005]
Kernel driver in use: iwl3945
Kernel modules: iwl3945
siddharth@siddharth-Aspire-5570:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:"kobold"
Mode:Managed Frequency:2.462 GHz Access Point: 5C:D9:98:16:6C:FC
Bit Rate=48 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=62/70 Signal level=-48 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:45 Missed beacon:0

siddharth@siddharth-Aspire-5570:~$ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
2: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no
3: acer-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
siddharth@siddharth-Aspire-5570:~$ lsmod
Module Size Used by
rfcomm 38408 8
bnep 17923 2
parport_pc 32114 0
ppdev 12849 0
gspca_vc032x 31999 0
gspca_main 27610 1 gspca_vc032x
videodev 85626 1 gspca_main
snd_atiixp_modem 18604 0
snd_via82xx_modem 18377 0
snd_hda_codec_si3054 12864 1
snd_intel8x0m 18498 0
snd_hda_codec_realtek 254125 1
snd_ac97_codec 106082 3 snd_atiixp_modem,snd_via82xx_modem,snd_intel8x0m
joydev 17393 0
ac97_bus 12642 1 snd_ac97_codec
snd_hda_intel 24262 2
snd_hda_codec 91754 3 snd_hda_codec_si3054,snd_hda_codec_realtek,snd_hda _intel
snd_hwdep 13276 1 snd_hda_codec
snd_pcm 80435 7 snd_atiixp_modem,snd_via82xx_modem,snd_hda_codec_s i3054,snd_intel8x0m,snd_ac97_codec,snd_hda_intel,s nd_hda_codec
acer_wmi 23302 0
sparse_keymap 13658 1 acer_wmi
snd_seq_midi 13132 0
snd_rawmidi 25241 1 snd_seq_midi
pcmcia 39822 0
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51567 2 snd_seq_midi,snd_seq_midi_event
btusb 18160 2
arc4 12473 2
tifm_7xx1 12937 0
snd_timer 28932 2 snd_pcm,snd_seq
bluetooth 148839 23 rfcomm,bnep,btusb
snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
tifm_core 15040 1 tifm_7xx1
iwl3945 73360 0
i915 505159 4
yenta_socket 27428 0
pcmcia_rsrc 18367 1 yenta_socket
iwl_legacy 71499 1 iwl3945
mac80211 393459 2 iwl3945,iwl_legacy
snd 55902 18 snd_atiixp_modem,snd_via82xx_modem,snd_hda_codec_s i3054,snd_intel8x0m,snd_hda_codec_realtek,snd_ac97 _codec,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_p cm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
pcmcia_core 21511 3 pcmcia,yenta_socket,pcmcia_rsrc
drm_kms_helper 32889 1 i915
drm 192194 5 i915,drm_kms_helper
cfg80211 172392 3 iwl3945,iwl_legacy,mac80211
psmouse 73673 0
serio_raw 12990 0
soundcore 12600 1 snd
binfmt_misc 17292 1
snd_page_alloc 14115 5 snd_atiixp_modem,snd_via82xx_modem,snd_intel8x0m,s nd_hda_intel,snd_pcm
i2c_algo_bit 13199 1 i915
wmi 18744 1 acer_wmi
video 18908 1 i915
lp 17455 0
parport 40930 3 parport_pc,ppdev,lp
sky2 49317 0
siddharth@siddharth-Aspire-5570:~$

Wild Man
January 9th, 2012, 01:14 AM
Hi siddi, when you post it is helpful if you state your problem exactly, I can only assume your connection is slow but I do not know if you are having other issues with it as well.

Please try this:

gksudo gedit /etc/modprobe.d/iwl3945.conf
Add one line:

options iwl3945 disable_hw_scan=0
save, exit gedit and reboot.
Thanks

siddi
January 9th, 2012, 01:19 AM
hey,

The connection speed is perfectly alright... But every few seconds the wireless signal drops and it gets disconnected. then it scans and connects back again... Sometimes it stays connected for 10 minutes, but sometimes it drops every few seconds.

the first command u gave, gave me back a file.. I typed the second command in the file window that opened and saved it as under modeprobe...

is that right?

Wild Man
January 9th, 2012, 01:26 AM
Hi, always just copy and paste everything for accuracy, and the file just needed to be saved and it will save as the proper name so if you did not change the name it saved it as it was suppose to which is

/etc/modprobe.d/iwl3945.conf
You are having a different issue then I thought so if the problem continues we will open this file and change it to another option now that I know the issue.
Thanks

siddi
January 9th, 2012, 01:29 AM
cool.. as of now... the wireless has not dropped for the first time in 5 minutes.... hopefully it doesn't

thank u very much for the help... very grateful....

Will have to get back to u if the problem persists...

siddi
January 9th, 2012, 01:30 AM
ah well.....
it is still dropping and reconnecting.....

:(

Wild Man
January 9th, 2012, 01:36 AM
Hi siddi, open that file back up and remove

options iwl3945 disable_hw_scan=0
add:

options iwl3945 swcrypto=0
Thanks

siddi
January 9th, 2012, 02:35 AM
still not working :(

Wild Man
January 9th, 2012, 03:02 AM
Hi, please post the output of when you are having trouble connecting:

nm-tool
sudo iwlist scan
lsmod | grep iwl

sudo cat /var/log/syslog | grep -e iwl -e firmware -e wpa -e wlan -e etork | tail -n75
Thanks

siddi
January 9th, 2012, 10:50 AM
siddharth@siddharth-Aspire-5570:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: sky2
State: unavailable
Default: no
HW Address: 00:16:36:8A:50:65

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: off


- Device: wlan0 [kobold] ------------------------------------------------------
Type: 802.11 WiFi
Driver: iwl3945
State: connected
Default: yes
HW Address: 00:18E:5D:03:AD

Capabilities:
Speed: 54 Mb/s

Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points (* = current AP)
wlan-ap: Infra, 00:133:71:16:58, Freq 2412 MHz, Rate 54 Mb/s, Strength 25 WPA
*kobold: Infra, 5C9:98:16:6C:FC, Freq 2462 MHz, Rate 54 Mb/s, Strength 58
paulair: Infra, 00:19:E3:E3:33:17, Freq 2437 MHz, Rate 54 Mb/s, Strength 27 WPA WPA2
BigPondDB44FD: Infra, 00:24:17B:44:FD, Freq 2412 MHz, Rate 54 Mb/s, Strength 35 WPA WPA2

IPv4 Settings:
Address: 192.168.1.2
Prefix: 24 (255.255.255.0)
Gateway: 192.168.1.1

DNS: 192.168.1.1


siddharth@siddharth-Aspire-5570:~$ sudo iwlist scan
[sudo] password for siddharth:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 5C9:98:16:6C:FC
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=55/70 Signal level=-55 dBm
Encryption key:off
ESSID:""
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000000f8e356914c
Extra: Last beacon: 264ms ago
IE: Unknown: 0000
IE: Unknown: 010882848B961224486C
IE: Unknown: 03010B
IE: Unknown: 32040C183060
IE: Unknown: 0706415520010D10
IE: Unknown: 33082001020304050607
IE: Unknown: 33082105060708090A0B
IE: Unknown: DD270050F204104A000110104400010110470010BC329E001D D811B286015CD998166CFC103C000101
IE: Unknown: 050400010000
IE: Unknown: 2A0104
IE: Unknown: 2D1A6E1017FF000000010000000000000000000000000C0000 000000
IE: Unknown: 3D160B070700000000000000000000000000000000000000
IE: Unknown: 7F0101
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F 00
IE: Unknown: 0B0502007E127A
IE: Unknown: DD1E00904C336E1017FF000000010000000000000000000000 000C0000000000
IE: Unknown: DD1A00904C340B070700000000000000000000000000000000 000000
IE: Unknown: DD07000C4304000000
Cell 02 - Address: 00:19:E3:E3:33:17
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=26/70 Signal level=-84 dBm
Encryption key:on
ESSID:"paulair"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000000984013a91
Extra: Last beacon: 960ms ago
IE: Unknown: 00077061756C616972
IE: Unknown: 010482848B96
IE: Unknown: 030106
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: 32080C1218243048606C
IE: Unknown: DD0700039301660000
IE: Unknown: DD06001018020000
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 03 - Address: 5C:D9:98:16:6C:FC
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=55/70 Signal level=-55 dBm
Encryption key:off
ESSID:"kobold"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=000000f8e359c35d
Extra: Last beacon: 52ms ago
IE: Unknown: 00066B6F626F6C64
IE: Unknown: 010882848B961224486C
IE: Unknown: 03010B
IE: Unknown: 2A0104
IE: Unknown: 32040C183060
IE: Unknown: 2D1A6E1017FF000000010000000000000000000000000C0000 000000
IE: Unknown: 3D160B070700000000000000000000000000000000000000
IE: Unknown: 3E0100
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F 00
IE: Unknown: 0B0502007E127A
IE: Unknown: 7F0101
IE: Unknown: DD07000C4304000000
IE: Unknown: 0706415520010D10
IE: Unknown: DD1E00904C336E1017FF000000010000000000000000000000 000C0000000000
IE: Unknown: DD1A00904C340B070700000000000000000000000000000000 000000
IE: Unknown: DD9D0050F204104A0001101044000101103B00010310470010 BC329E001DD811B286015CD998166CFC1021001852616C696E 6B20546563686E6F6C6F67792C20436F72702E1023001C5261 6C696E6B20576972656C6573732041636365737320506F696E 74102400065254323836301042000831323334353637381054 000800060050F20400011011000952616C696E6B4150531008 00020084103C000101
Cell 04 - Address: 00:13:D3:71:16:58
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=22/70 Signal level=-88 dBm
Encryption key:on
ESSID:"wlan-ap"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000003b9b7f20b0
Extra: Last beacon: 1308ms ago
IE: Unknown: 0007776C616E2D6170
IE: Unknown: 010482848B96
IE: Unknown: 030101
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: 200103
IE: Unknown: 0706464920010E10
IE: Unknown: 050400010000
IE: Unknown: 2A0104
IE: Unknown: 32080C1218243048606C

siddharth@siddharth-Aspire-5570:~$ lsmod | grep iwl
iwl3945 73360 0
iwl_legacy 71499 1 iwl3945
mac80211 393459 2 iwl3945,iwl_legacy
cfg80211 172392 3 iwl3945,iwl_legacy,mac80211
siddharth@siddharth-Aspire-5570:~$ sudo cat /var/log/syslog | grep -e iwl -e firmware -e wpa -e wlan -e etork -e | tail -n75
grep: option requires an argument -- 'e'
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information.
siddharth@siddharth-Aspire-5570:~$

Wild Man
January 9th, 2012, 08:43 PM
Hi, please copy and paste all commands for accuracy. Try this one again please.

sudo cat /var/log/syslog | grep -e iwl -e firmware -e wpa -e wlan -e etork | tail -n75
Thanks

siddi
January 9th, 2012, 08:56 PM
siddharth@siddharth-Aspire-5570:~$ sudo cat /var/log/syslog | grep -e iwl -e firmware -e wpa -e wlan -e etork | tail -n75
[sudo] password for siddharth:
Jan 9 23:49:39 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): device state change: activated -> unmanaged (reason 'sleeping') [100 10 37]
Jan 9 23:49:39 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): deactivating device (reason 'sleeping') [37]
Jan 9 23:49:39 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 4405
Jan 9 23:49:39 siddharth-Aspire-5570 avahi-daemon[582]: Withdrawing address record for 192.168.1.2 on wlan0.
Jan 9 23:49:39 siddharth-Aspire-5570 avahi-daemon[582]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.2.
Jan 9 23:49:39 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): cleaning up...
Jan 9 23:49:39 siddharth-Aspire-5570 kernel: [11304.516084] wlan0: deauthenticating from 5c:d9:98:16:6c:fc by local choice (reason=3)
Jan 9 23:49:39 siddharth-Aspire-5570 avahi-daemon[582]: Interface wlan0.IPv4 no longer relevant for mDNS.
Jan 9 23:49:39 siddharth-Aspire-5570 wpa_supplicant[898]: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=3
Jan 9 23:49:39 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): taking down device.
Jan 9 23:49:39 siddharth-Aspire-5570 avahi-daemon[582]: Interface wlan0.IPv6 no longer relevant for mDNS.
Jan 9 23:49:39 siddharth-Aspire-5570 avahi-daemon[582]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::218:deff:fe5d:3ad.
Jan 9 23:49:39 siddharth-Aspire-5570 avahi-daemon[582]: Withdrawing address record for fe80::218:deff:fe5d:3ad on wlan0.
Jan 10 06:53:46 siddharth-Aspire-5570 kernel: [11310.697456] iwl3945 0000:03:00.0: restoring config space at offset 0xf (was 0x100, writing 0x10b)
Jan 10 06:53:46 siddharth-Aspire-5570 kernel: [11310.697526] iwl3945 0000:03:00.0: restoring config space at offset 0x4 (was 0x0, writing 0x44100000)
Jan 10 06:53:46 siddharth-Aspire-5570 kernel: [11310.697541] iwl3945 0000:03:00.0: restoring config space at offset 0x3 (was 0x0, writing 0x10)
Jan 10 06:53:46 siddharth-Aspire-5570 kernel: [11310.697561] iwl3945 0000:03:00.0: restoring config space at offset 0x1 (was 0x100000, writing 0x100406)
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): now managed
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): bringing up device.
Jan 10 06:53:48 siddharth-Aspire-5570 kernel: [11315.775767] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): preparing device.
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): deactivating device (reason 'managed') [2]
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): supplicant interface state: starting -> ready
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): device state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
Jan 10 06:53:48 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): supplicant interface state: ready -> inactive
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) starting connection 'kobold'
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0/wireless): connection 'kobold' requires no security. No secrets needed.
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jan 10 06:53:50 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): supplicant interface state: inactive -> scanning
Jan 10 06:53:51 siddharth-Aspire-5570 wpa_supplicant[898]: Trying to authenticate with 5c:d9:98:16:6c:fc (SSID='kobold' freq=2462 MHz)
Jan 10 06:53:51 siddharth-Aspire-5570 wpa_supplicant[898]: Trying to associate with 5c:d9:98:16:6c:fc (SSID='kobold' freq=2462 MHz)
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): supplicant interface state: scanning -> authenticating
Jan 10 06:53:51 siddharth-Aspire-5570 kernel: [11318.793118] wlan0: authenticate with 5c:d9:98:16:6c:fc (try 1)
Jan 10 06:53:51 siddharth-Aspire-5570 kernel: [11318.795114] wlan0: authenticated
Jan 10 06:53:51 siddharth-Aspire-5570 kernel: [11318.795701] wlan0: associate with 5c:d9:98:16:6c:fc (try 1)
Jan 10 06:53:51 siddharth-Aspire-5570 kernel: [11318.798206] wlan0: RX AssocResp from 5c:d9:98:16:6c:fc (capab=0x401 status=0 aid=1)
Jan 10 06:53:51 siddharth-Aspire-5570 kernel: [11318.798216] wlan0: associated
Jan 10 06:53:51 siddharth-Aspire-5570 kernel: [11318.800151] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Jan 10 06:53:51 siddharth-Aspire-5570 wpa_supplicant[898]: Associated with 5c:d9:98:16:6c:fc
Jan 10 06:53:51 siddharth-Aspire-5570 wpa_supplicant[898]: CTRL-EVENT-CONNECTED - Connection to 5c:d9:98:16:6c:fc completed (auth) [id=0 id_str=]
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): supplicant interface state: authenticating -> completed
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network 'kobold'.
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): device state change: config -> ip-config (reason 'none') [50 70 0]
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Beginning DHCPv4 transaction (timeout in 45 seconds)
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): DHCPv4 state changed nbi -> preinit
Jan 10 06:53:51 siddharth-Aspire-5570 dhclient: Listening on LPF/wlan0/00:18:de:5d:03:ad
Jan 10 06:53:51 siddharth-Aspire-5570 dhclient: Sending on LPF/wlan0/00:18:de:5d:03:ad
Jan 10 06:53:51 siddharth-Aspire-5570 dhclient: DHCPREQUEST of 192.168.1.2 on wlan0 to 255.255.255.255 port 67
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): DHCPv4 state changed preinit -> reboot
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Get) scheduled...
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Get) started...
Jan 10 06:53:51 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) started...
Jan 10 06:53:51 siddharth-Aspire-5570 avahi-daemon[582]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.2.
Jan 10 06:53:51 siddharth-Aspire-5570 avahi-daemon[582]: New relevant interface wlan0.IPv4 for mDNS.
Jan 10 06:53:51 siddharth-Aspire-5570 avahi-daemon[582]: Registering new address record for 192.168.1.2 on wlan0.IPv4.
Jan 10 06:53:52 siddharth-Aspire-5570 NetworkManager[594]: <info> (wlan0): device state change: ip-config -> activated (reason 'none') [70 100 0]
Jan 10 06:53:52 siddharth-Aspire-5570 NetworkManager[594]: <info> Policy set 'kobold' (wlan0) as default for IPv4 routing and DNS.
Jan 10 06:53:52 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) successful, device activated.
Jan 10 06:53:52 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete.
Jan 10 06:53:52 siddharth-Aspire-5570 NetworkManager[594]: <info> Activation (wlan0) Stage 4 of 5 (IP4 Configure Get) complete.
Jan 10 06:53:53 siddharth-Aspire-5570 avahi-daemon[582]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::218:deff:fe5d:3ad.
Jan 10 06:53:53 siddharth-Aspire-5570 avahi-daemon[582]: New relevant interface wlan0.IPv6 for mDNS.
Jan 10 06:53:53 siddharth-Aspire-5570 avahi-daemon[582]: Registering new address record for fe80::218:deff:fe5d:3ad on wlan0.*.
Jan 10 06:54:02 siddharth-Aspire-5570 kernel: [11329.408075] wlan0: no IPv6 routers present

Wild Man
January 9th, 2012, 09:07 PM
Hi, make sure your settings are like the ones in the screen shot except leave auto connect checked.
Thanks

siddi
January 9th, 2012, 09:17 PM
do i have to change to DHCP adresses only?
and change it to 8.8.8.8, 8.8.4.4?

cos at the moment i have " Automatic DHCP"

Wild Man
January 9th, 2012, 09:18 PM
Hi, yes please.
Thanks

siddi
January 9th, 2012, 09:21 PM
done and waiting.... need to restart?

Wild Man
January 9th, 2012, 09:22 PM
Yes.
Thanks

siddi
January 9th, 2012, 09:55 PM
still the same!!!

Wild Man
January 9th, 2012, 10:15 PM
Hi, did you set ipv6 to ignore?
thanks

siddi
January 9th, 2012, 11:55 PM
yes
thanks

Wild Man
January 10th, 2012, 12:31 AM
Hi, you may want to install wicd and get rid of network manager and see if that helps, but you must install wicd first.

Wicd will not show up in the panel so you have to click on dash to set it up.
The run this command to get rid of network manager then reboot.

sudo apt-get purge network-manager network-manager-gnome
Thanks

siddi
January 10th, 2012, 12:47 AM
is it the Wicd network manager from the 'ubuntu software center'?

Wild Man
January 10th, 2012, 12:48 AM
Hi, yes it is.
Thanks

siddi
January 10th, 2012, 08:06 AM
i installed WICD and uninstalled network manager.

WICD recognizes the network and is even connected to it, but internet is not working....

No downloading or uploading....

Should i connect to the modem by cable and reinstall network manager?

Wild Man
January 10th, 2012, 08:20 PM
Hi siddi, did you put in a static ip address and I believe with wicd you have to use dhclient instead of dhcp after you check those settings if it is not working right post the output of:

sudo cat /var/log/syslog | grep -e iwl -e firmware -e wpa -e wlan -e etork | tail -n75
so we can see what is going on with the connection after wicd was installed.

Also remember to keep ipv6 turned off.

I will not be on much today because it is my birthday.
Thanks

siddi
January 13th, 2012, 09:58 AM
hi,
Things have changed since i last posted. My flatmate has got a mini wifi mobile modem.
It has a wifi key with numbers... I presume the WPA number...
WICD is recognising the modem but it jsut wud not connect.... i have tried all combinations... it just won't happen...

Radio89
April 12th, 2012, 08:39 AM
Writing here as a reference for google.



Try this please and see if it helps it is only good until you reboot, if it helps we will have to make it permanent.

sudo ifconfig wlan0 down
sudo rmmod -f rt2800usb
sudo modprobe rt2800usb nohwcrypt=1
sudo ifconfig wlan0 upThank you

Thanks: worked for me too with rt2x00usb drivers and 12.04 upgrade. Of course commands corrected as follow, my interface is wlan3 (don't know why).

sudo ifconfig wlan3 down
sudo rmmod -f rt2x00usb
sudo modprobe rt2x00usb nohwcrypt=1
sudo ifconfig wlan3 up
and then I created the /etc/modprobe.d/rt2x00usb.conf file with

options rt2x00usb nohwcrypt=1
After a while the connection stop working (no ping to router or anything) and Tx excessive retries: in iwconfig started to increase.

Again, thanks!