PDA

View Full Version : [SOLVED] Grub & Startup



GoffyGoober
September 23rd, 2011, 07:26 PM
My start up is buggy, and goes something like this:

Press the powerbutton
Grub opens
Press enter
Lots of black and white vertical lines with the actual text illegible and strange saying things like: %df~`0,d/ : (
(Yes the ": (" appears, maybe saying "false")
Once it gets to the last line in the list, it kinda stop, and does nothing more in the way of startup
I press reboot
It reboots
grub appears now with higher resolution, and a purple-ish background
Press enter
Wait a while, it starts up
Ubuntu login opens
I login
I logout
I login
(The second login is so that it doesn't log me out right in the middle of me using it, logging me out instantly without warning)


Is there any way to make it normal, like it should?

MetalRider
October 5th, 2011, 07:51 PM
I have the same problem since I took Windows XP off of my system. When I had Ubuntu installed through Windows XP and selected to boot up using Ubuntu, everything was fine and I never had this problem.

JRV
October 5th, 2011, 09:12 PM
I had this problem with an SIS graphics chip awhile back.

What version of Ubuntu are you using?
Do you have SIS graphics?

To get rid of vertical lines go to the terminal, CD to your root directory.


sudo gedit etc/x11/xorg.conf

You can substitute the editor of your choice for gedit.

If you have an etc/x11/xorg.conf file add this to the device section:


Driver "vesa"

If the file is blank copy this text:



Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection



If you absolutely can not see what you are doing to edit the file boot from a Puppy Linux Live CD to make the edits.

I hope this helps.

MetalRider
October 6th, 2011, 07:50 AM
I'm using 11.04 myself. Could you please break that down a little more for a guy that could basically be considered "plug 'n' play: ;)

Ok.......I went to the terminal screen and entered the first code line, and got this as a response:

(gedit:1925): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.6XGR2V': No such file or directory

(gedit:1925): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

I did have a window titled etc/x11/xorg.conf open up, and there was nothing in it. Am I correct in assuming that is where I should have then pasted the third code you gave qne then saved the file?

Now what? My apologies in advance. I have no real knowledge of Linus or Ubuntu as yet, and had precious little desire to do much of anything with Windows other than use it.

JRV
October 7th, 2011, 12:36 AM
If you have SIS graphics the vesa driver is the only way to make it work.
Try pasting the code into the file.
I don't think there is any way it could make it worse.

MetalRider
October 7th, 2011, 07:48 PM
Thanks! I will give this a try this weekend when I have some time to play. For right now, it is just a nuisance more than anything else. Thank goodness for three day weekends, especially after coming off a 20 day straight work stretch.

JRV
October 7th, 2011, 09:20 PM
The solution in this thread might also help:

http://ubuntuforums.org/showthread.php?t=1852968

GoffyGoober
October 7th, 2011, 10:57 PM
The vesa driver? xorg.conf is using "nivida". Is there some unwritten rule that Linux doesn't like nivida graphics cards? Anyways it ONLY happens on startup, before login. Grub isn't even purple, like it should be, probably meaning it Grub isn't looking at all of it's setup files all the time...

MetalRider
October 10th, 2011, 12:07 AM
Hmm, it just sank in this topic is for folks with ASUS computers.. I am running a home built with an ASUS A8N-E mobo. Would the proposed solution still be applicable?

GoffyGoober
October 11th, 2011, 11:15 PM
Actually, I haven't gotten an answer yet, except for that one which I questioned, and it is quite an old model. But I think it may have something to do with even new Asus computers.

GoffyGoober
October 15th, 2011, 12:42 AM
Lately, I was just starting up my computer, and decided to press the F keys! It worked. When it brings up the loading screen I start, and go at a relaxed pace. There are still vertical bars but I now have to say this: who cares? And having the check disk thing, I think I will now let it do so, as I can't keep it to happen. I don't know if this will work every time as I have just done it a second time...