PDA

View Full Version : [SOLVED] New Ubuntu and cannot connect to wireless internet



Gators79
September 18th, 2011, 03:01 AM
Hello. I am very new to this. I downloaded the new ubuntu 11 something and I don't think it is reconizing my wireless internet at all. I put in I have ATT u-verse 2Wire 3800 HGV-B and I have a Dell Inspiron 1440 PP42L. I am having to switch back and forth between Windows and ubuntu in order to get on the internet and post this so I don't know how I can copy and paste or do a screen shot for the things you need to know. Please help. Let me know what other info you need. Thanks.

Wild Man
September 18th, 2011, 06:09 AM
Hi, welcome to the forum! please run these commands in a terminal, you can open one by hitting ctrl+alt+t then copy and paste the commands into the terminal, then copy the results to a jump drive and paste them here:

cat /etc/lsb-release; uname -a

sudo lshw -C network

lspci -nn | grep -e 0280 -e 0200

iwconfig

rfkill list all

lsmod
by clicking on new reply and click # and paste the information between the brackets.
Thank you

Megaptera
September 18th, 2011, 07:12 AM
Gators79,
In Ubuntu ... Have you tried using the menu bar on the top panel?
System > Administration > Hardware drivers clicking on that gets me the drivers I need and installs them on my Dell - no other intervention on my part.
Worth a try if not already done?

gnusci
September 18th, 2011, 08:19 AM
Try wicd

http://wicd.sourceforge.net/

mrgs
September 18th, 2011, 10:17 AM
Have you installed all bug fixes to Ubuntu using wired internet access?

Gators79
September 18th, 2011, 02:32 PM
Hi, welcome to the forum! please run these commands in a terminal, you can open one by hitting ctrl+alt+t then copy and paste the commands into the terminal, then copy the results to a jump drive and paste them here:

cat /etc/lsb-release; uname -a

sudo lshw -C network

lspci -nn | grep -e 0280 -e 0200

iwconfig

rfkill list all

lsmod
by clicking on new reply and click # and paste the information between the brackets.
Thank you

I'm having a problem copying and pasting to jump drive. I copied the text fine but when I try to paste in my jump drive it doesn't give me that option. Am I doing something wrong?

praseodym
September 18th, 2011, 02:42 PM
Copy it into a .txt file and upload it.

Gators79
September 18th, 2011, 03:29 PM
Here is what I came up with. Hope this helps. Thank you.


Hi, welcome to the forum! please run these commands in a terminal, you can open one by hitting ctrl+alt+t then copy and paste the commands into the terminal, then copy the results to a jump drive and paste them here:
[CODE]cat /etc/lsb-release; uname -a
[DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"
Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux]
[CODE]sudo lshw -C network [
*-network
description: Network controller
product: BCM4312 802.11b/g LP-PHY
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:0c:00.0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:17 memory:f69fc000-f69fffff
*-network
description: Ethernet interface
product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:09:00.0
logical name: eth0
version: 02
serial: a4:ba:db:a7:8a:d4
size: 10Mbit/s
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:44 ioport:de00(size=256) memory:f0010000-f0010fff memory:f0000000-f000ffff memory:f0020000-f003ffff
*-network DISABLED
description: Wireless interface
physical id: 2
logical name: wlan0
serial: 70:1a:04:e3:8c:d0
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=2.6.38-8-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg]
[CODE]lspci -nn | grep -e 0280 -e 0200[
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)]
[CODE]iwconfig[
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off]
[CODE]rfkill list all[
0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no]
[CODE]lsmod[
Module Size Used by
parport_pc 32111 0
ppdev 12849 0
nls_iso8859_1 12617 1
nls_cp437 12751 1
vfat 17335 1
fat 55505 1 vfat
nls_utf8 12493 2
isofs 39571 2
binfmt_misc 13213 1
snd_hda_codec_idt 60537 1
arc4 12473 2
snd_hda_intel 24140 2
snd_hda_codec 90901 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 13274 1 snd_hda_codec
snd_pcm 80244 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 13132 0
snd_rawmidi 25269 1 snd_seq_midi
i915 450944 3
snd_seq_midi_event 14475 1 snd_seq_midi
snd_seq 51291 2 snd_seq_midi,snd_seq_midi_event
b43 296610 0
joydev 17322 0
mac80211 257001 1 b43
dell_wmi 12601 0
snd_timer 28659 2 snd_pcm,snd_seq
snd_seq_device 14110 3 snd_seq_midi,snd_rawmidi,snd_seq
sparse_keymap 13666 1 dell_wmi
uvcvideo 66851 0
drm_kms_helper 40745 1 i915
dell_laptop 13515 0
videodev 75143 1 uvcvideo
snd 55295 13 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_ hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
dcdbas 14054 1 dell_laptop
cfg80211 156212 2 b43,mac80211
drm 180037 4 i915,drm_kms_helper
psmouse 73312 0
soundcore 12600 1 snd
i2c_algo_bit 13184 1 i915
serio_raw 12990 0
snd_page_alloc 14073 2 snd_hda_intel,snd_pcm
video 18951 1 i915
lp 13349 0
parport 36746 3 parport_pc,ppdev,lp
usbhid 41704 0
usb_storage 43946 2
hid 77084 1 usbhid
uas 17676 0
ahci 21591 2
r8169 42534 0
libahci 25548 1 ahci
ssb 45942 1 b43]
by clicking on new reply and click # and paste the information between the brackets.
Thank you

Gators79
September 18th, 2011, 03:31 PM
Didn't come out the way it was supposed to I guess. I tried.

Wild Man
September 18th, 2011, 03:56 PM
Hi, here is the best way to get this card working since you do not have internet access.

Download the b43 zip file to your jump drive, then drag and drop the file to your desktop. Right-click it and select Extract Here. Open a terminal and do:

sudo mkdir /lib/firmware/b43
sudo cp Desktop/b43/* /lib/firmware/b43
sudo rmmod -f b43
sudo rmmod -f ssb
sudo modprobe b43
run those commands one at a time then your wireless should be working.
Thank you

Gators79
September 18th, 2011, 04:24 PM
You are awesome!! It worked. Thank you so much.

Wild Man
September 18th, 2011, 04:55 PM
Hi, your are very welcome! if I help you even a little would you click on the red text in my signature and show your support for me becoming an ubuntu member? also would you please go to the top of the page and mark this thread solved by clicking on thread tools. Thank you so much.