PDA

View Full Version : Could not perform immediate configuration on 'unity-2d'



Justin Trouble
September 12th, 2011, 01:04 PM
I thought I'd have a play with Oneiric!

Trouble is the upgrade failed part way through the install with the error:


Could not perform immediate configuration on 'unity-2d'

I'm just trying to work out what's wrong.

Has anyone seen this before and can help?

Thanks!

cariboo907
September 12th, 2011, 04:23 PM
It could be several things. To complete the upgrade, start in recovery mode and select dpkg from the menu.

BiggieStylein
September 12th, 2011, 08:52 PM
I had this same problem while running apt-get dist-upgrade. I've been running Oneiric for a while now, so it wasn't a recent upgrade. I solved it by running dpkg -i on the new unity-2d .deb file, then running apt-get dist-upgrade again and it worked fine. Not sure what the problem is though, or why apt stopped... but at least its easy enough to get around.