PDA

View Full Version : [SOLVED] Terminal; ctrl-alt-t



douham
August 29th, 2011, 09:49 AM
Hi, is there a new key combo to launch the terminal; Ctrl-Alt_T does not work.

Iḿ also used to my os remembering the last status of num-lock (either on or off)

These are´nt major issues, just annoyances

godhika
August 29th, 2011, 09:56 AM
You change atleast ctrl-alt-t as a terminal shortcut in ccsm under gnome compatibility.

lucazade
August 29th, 2011, 09:58 AM
In unity-2d ctrl-alt-t works correctly, I use it often.
It looks like this shortcut is disabled in ccsm under key bindings (for unity-3d)

edit: godhika beated me :)

VinDSL
August 29th, 2011, 10:05 AM
You need to go into:

CCSM -> General -> Gnome Compatibility -> Commands
Enable "Open a terminal"
Then "Grab key combination"


Aren't alphas fun?!?!?

edit: godhika beated me too :D

coffeecat
August 29th, 2011, 12:20 PM
Rhetorical question: why, oh why, oh why, did they disable ctrl-alt-T by default? When you boot into a new Oneiric install and are confronted by just wallpaper and a cursor (sounds like it's happened to others too by what I've read), it's the first thing you need! :p

VinDSL
August 29th, 2011, 12:25 PM
Rhetorical question: why, oh why, oh why, did they disable ctrl-alt-T by default?
Beats me!

I *guess* they're trying to keep us on our ctrl-alt-Toes... ;)

lucazade
August 29th, 2011, 12:28 PM
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/820266

rbrick49
August 29th, 2011, 01:41 PM
ctrl-alt-t is no big deal except you have to do, files /usr/sshare/applications if you want it to work or recovery mode

VinDSL
August 30th, 2011, 07:58 AM
ctrl-alt-t is no big deal except you have to do, files /usr/sshare/applications if you want it to work or recovery mode
Huh?

jerrylamos
August 31st, 2011, 01:33 AM
You need to go into:

CCSM -> General -> Gnome Compatibility -> Commands
Enable "Open a terminal"
Then "Grab key combination"


Aren't alphas fun?!?!?

edit: godhika beated me too :D

Tried ccsm. Got bug 832458:

ccsm crashed with KeyError in compizconfig.Plugin.ApplyStringExtensions (src/compizconfig.c:6780)(): '\xd0\t\x9b\n\x01'

When ccsm does run, after crashing, doesn't display anything I can see like "Open a terminal" since all the choices are blank.

So I select Dash then open a terminl and save it on the launcher. Kind of slow and unhandy but works. Come to think of it, that's my general comment on Unity-3D.

Jerry

sgage
August 31st, 2011, 01:49 AM
What's the matter with system settings/keyboard/shortcuts?

Works fine here.

VinDSL
August 31st, 2011, 07:52 AM
I select Dash then open a terminl and save it on the launcher. Kind of slow and unhandy but works. Come to think of it, that's my general comment on Unity-3D.
Heh! I hear ya!

Oh, well, they're getting there.

I don't *think* they disabled Ctrl-Alt-T on purpose... ;)

mc4man
August 31st, 2011, 02:55 PM
I don't *think* they disabled Ctrl-Alt-T on purpose... ;)
Maybe it's an oversight, (not enabling in gnomecompat) or just following the gnome3 default which is not to have 'Launch Terminal' set

If one was to open GS > SS > keyboard > launchers it's listed but not bound.
If set to Crtl+Alt+T in GS then it will then automatically be set in Unity > compiz > gnomecompat if not already

CaptainMark
September 1st, 2011, 07:32 AM
the ops other question about the num lock, its getting on my nerves, is everyone having this problem? i have my bios set to 'num lock state on' but ubuntu 11.10 overides this, natty doesnt, nor does any other distro on a live session

douham
September 1st, 2011, 07:47 AM
the ops other question about the num lock, its getting on my nerves, is everyone having this problem? i have my bios set to 'num lock state on' but ubuntu 11.10 overides this, natty doesnt, nor does any other distro on a live session

Thanks for reminding me about this CaptainMark.
edit: I don´t have a user password with numbers, but Iḿ just used to having num lock on all the time.

VinDSL
September 1st, 2011, 08:42 AM
the ops other question about the num lock, its getting on my nerves, is everyone having this problem? i have my bios set to 'num lock state on' but ubuntu 11.10 overides this, natty doesnt, nor does any other distro on a live session
Yes, I've been having this problem too!

I cannot tell you how many problems it has caused for me, when I'm coding. Makes me want to smash my keyboard with a hammer.

Lubuntu (daily build) has the same problem.

I tried Xubuntu (daily build), and I think it had this problem too - can't remember.

I also tried Mandriva 2011 (final) aka “Hydrogen" the other night. I *think* it worked in Mandriva, but I wouldn't swear to it.

Anyway, I have a feeling that this "Num Lock" problem is coming from upstream...

douham
September 1st, 2011, 01:13 PM
the ops other question about the num lock, its getting on my nerves, is everyone having this problem? i have my bios set to 'num lock state on' but ubuntu 11.10 overides this, natty doesnt, nor does any other distro on a live session

I only just noticed that Num Lock turns off each time I log out and then log back in. However it stays on when I resume from standby.

ratcheer
September 1st, 2011, 01:19 PM
I also have the NumLock problem in Oneiric. Is there a bug open on this?

Tim

CaptainMark
September 2nd, 2011, 07:50 AM
i cant find anything on launchpad, we should make a bug report but which package would this be related to, i would guess it would be lightdm, because gdm used to be in charge of setting numlock on so i guess theyve overlooked it when coding lightdm, any thoughts?

mc4man
September 2nd, 2011, 07:55 AM
numlock - lightdm
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/835532

ratcheer
September 2nd, 2011, 12:50 PM
Thanks, mc4man. I have added my "me too". There are currently only the originator and I, so more of you need to go add to it.

Tim

CaptainMark
September 3rd, 2011, 06:16 PM
im in

Hakunka-Matata
September 4th, 2011, 09:44 PM
Running on Stock 11.10 beta


Linux 1110-b1 3.0.0-10-generic-pae #16-Ubuntu SMP Fri Sep 2 20:09:42 UTC 2011 i686 athlon i386 GNU/Linux

CTRL-ALT-T does not work to bring up Teminal: What's the Shortcut now?

mc4man
September 4th, 2011, 10:10 PM
In unity if you have compizconfig-settings-manager (ccsm) installed then open it up > gnome compatibility > commands & enable it there.
If you happen to have gnome-shell installed it can be set in System Settings > Keyboard > Launchers (if set in GS it will then automatically be enabled in ccsm > gnomecompat

Or it can be set to another binding if desired in System Settings > Keyboard > Shortcuts > Custom shortcuts

jerrylamos
September 4th, 2011, 11:03 PM
I select "dash home" and type in ter which puts a terminal picture on the launcher.

With right click you can "keep in launcher". Even stays there on reboot.

If you already have a terminal you can right click on the launcher icon and open a "new terminal".

A bit clumsier and definitely slower than just Ctrl-Alt-t but it works.

Now the launcher isn't very big, eight plus "dash" and "trash" but in test mode I haven't often filled it up yet. I do delete icons I don't use like Impress and Software Center and Ubuntu One.

I use network copy (when its working on Oneiric) between my netbook, notebook, tower, and my wife's two Windoze. She uses Windoze because she supports a couple websites that use proprietary $$$ software not available on linux. Yet. If ever.

Jerry

fjgaude
September 4th, 2011, 11:12 PM
Running on Stock 11.10 beta



CTRL-ALT-T does not work to bring up Teminal: What's the Shortcut now?

Just what the doctor ordered... thanks! Now we have the best of all worlds with the Dash, just enter a t, and the Terminal icon shows. You can drag it into the Launcher and then right-click Keep in launcher. Now Ctrl-Alt-t. Two ways.

fjgaude
September 4th, 2011, 11:13 PM
In unity if you have compizconfig-settings-manager (ccsm) installed then open it up > gnome compatibility > commands & enable it there.
If you happen to have gnome-shell installed it can be set in System Settings > Keyboard > Launchers (if set in GS it will then automatically be enabled in ccsm > gnomecompat

Or it can be set to another binding if desired in System Settings > Keyboard > Shortcuts > Custom shortcuts

Just what the doctor ordered... thanks! Now we have the best of all worlds with the Dash, just enter a t, and the Terminal icon shows. You can drag it into the Launcher and then right-click Keep in launcher. Now Ctrl-Alt-t. Two ways.

cariboo907
September 5th, 2011, 02:42 AM
Merged two threads on the same subject.