PDA

View Full Version : [ubuntu] Via vt1705



nsathees
August 29th, 2011, 06:01 AM
Hi,
I have changed my motherboard from ASUS to ASROCK. The ASUS motherboard came with VT1708 sound chip and the ASROCK comes with 1705.

The system works without a glitch except the sound.

I have sound playback but the volume level is very low and if I connect the microphone It makes terrible noise. I check the driver is still for the VT1708

here is the output http://www.alsa-project.org/db/?f=45eec94bd186dac4ed88a3cbb6f22ec8944e76fd

Is there any driver for 1705 HD Audio codec (5.1)?

How can I handle this problem?

I have found one tread on this issue and that wasn't solved. I don't have the luxury of getting a sound card or another motherboard.

Please help as my job requires me to communicate via skype.

Thank you!

nsathees
August 29th, 2011, 06:46 AM
if anyone could direct me how to use this patch?
http://article.gmane.org/gmane.linux.alsa.devel/83342/match=vt1705

lidex
August 30th, 2011, 03:43 AM
if anyone could direct me how to use this patch?
http://article.gmane.org/gmane.linux.alsa.devel/83342/match=vt1705

The patches should be applied in latest snapshot. Try updating your alsa-driver-modules.
Using a Terminal="Applications->Accessories->Terminal"
Add the ubuntu-audio-dev ppa:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
Now install:

sudo apt-get install linux-alsa-driver-modules-$(uname -r)
Reboot
Go to "System ->Preferences ->Sound" and make sure the correct soundcard is default and adjust your profile on the hardware tab.
On the output tab choose the correct device.
Check your levels in alsamixer.

alsamixer
Press <F6> to select the correct soundcard.
Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.

ihc100
September 17th, 2011, 06:48 PM
Thank you very much.

sensenku
April 14th, 2012, 12:38 PM
Hi,my name is Mehman, I just added this repo and did every thing you wrote,but nothing happened :(

Temüjin
April 14th, 2012, 04:14 PM
What version of Ubuntu are you using?

sensenku
April 14th, 2012, 04:41 PM
Ubuntu Desktop 11.10

Temüjin
April 14th, 2012, 04:48 PM
Reverse the previous change:

sudo apt-get remove linux-alsa-driver-modules-$(uname -r)

Try this PPA:

sudo apt-add-repository ppa:ubuntu-audio-dev/alsa-daily
sudo apt-get update
sudo apt-get install alsa-hda-dkms

Then restart. If it still does not work, please provide alsa-info: https://wiki.ubuntu.com/Audio/AlsaInfo

sensenku
April 14th, 2012, 05:28 PM
I am just going to do this,just wait a moment

sensenku
April 14th, 2012, 05:36 PM
Installation complated,but there is no sound :(

Temüjin
April 14th, 2012, 05:46 PM
Installation complated,but there is no sound :(
...

If it still does not work, please provide alsa-info: https://wiki.ubuntu.com/Audio/AlsaInfo

sensenku
April 14th, 2012, 05:52 PM
Here is my error or problem for solving http://www.alsa-project.org/db/?f=cda4be8c20546865e64f294e5e1e7617e3ed9e5f

Temüjin
April 14th, 2012, 06:23 PM
Driver version: 1.0.24
This means that you did not install alsa-hda-dkms (or forgot to reboot). Driver version should be 1.0.25.

sensenku
April 14th, 2012, 06:30 PM
I just made it,opened terminal and typed alsamixer and alsamixer opened,and increased somthings and made some thing Stereo Mixer and all done! YYYYYYeeeeepppppppaaaaaa :)

confused57
May 1st, 2012, 03:13 AM
Tried all of the suggestions in this thread & other sources to no avail. Here's what alsamixer shows:
Card: HDA ATI SB
Chip: VIA VT1705

I was able to get sound working by opening a terminal:

alsamixer

Pressed the right arrow to "Independ"(there are other settings that are not displayed on the initial screen), then arrow up to toggle the setting from "off" to "on".

Thought I'd mention what worked for me, if someone else has this chipset with no sound.