PDA

View Full Version : [ubuntu] Disable WiMAX init at Bootup?



Elmer Fudd
August 28th, 2011, 10:57 PM
Any easy way to stop the initialization of WiMax during bootup? I don't use Wimax and it noticeably slows down the boot up process.

Sony F-Series laptop running 10.10.

02:00.0 Network controller: Intel Corporation Centrino Advanced-N + WiMAX 6250 (rev 5f)

chili555
August 29th, 2011, 02:16 PM
I'd suggest you look in the computer's BIOS first to see if there is any option to disable wimax. You might also see if there is any module loaded to enable wimax:
lsmod | grep wimaxIf so, it may be helpful to blacklist it:
sudo su
echo "blacklist <some_module>" >> /etc/modprobe.d/blacklist.conf
exit

Elmer Fudd
September 1st, 2011, 04:13 AM
Thank you for the suggestions.
I have already tried to disable WiMax in the BIOS (unavailable) and did find and blacklist the 'wimax' module in blacklist.conf.
It still initializes and shows "WiMax ready" during bootup.
Not a big problem. Just annoying having something I don't use delaying the bootup.

chili555
September 1st, 2011, 11:26 AM
Is there a wimax listing in here?
rfkill list allIf so, does it help to do:
sudo rfkill block wimaxIs that a declaration you could add without the 'sudo' to /etc/rc.local?

Elmer Fudd
September 3rd, 2011, 03:58 AM
"rfkill list all" returns:


0: sony-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: sony-wimax: WiMAX
Soft blocked: yes
Hard blocked: no
2: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
4: i2400m-usb:1-1.5:1.0: WiMAX
Soft blocked: yes
Hard blocked: no
5: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Ran "rfkill block wimax" both in root terminal and in "/etc/rc.local" at boot. No change.

lfruiz
October 4th, 2011, 02:48 AM
nd im having this "bug" as well... got the asus g73 and this is the only thing that bugs me..:(