PDA

View Full Version : [ubuntu] How to set my Nvidia GT 335m under ubuntu to 96 dpi (1366X768)



etiennenoel
August 24th, 2011, 03:42 PM
In my xorg.conf file, I have this configuration

Section "Monitor" # HorizSync source: edid, VertRefresh source: edid # 1366X768 96dpi Identifier "Monitor0" VendorName "Unknown" ModelName "AUO" DisplaySize 361 203 HorizSync 30.0 - 75.0 VertRefresh 60.0 Option "DPMS" # DisplaySize 270 203 # 1024x768 96dpi # DisplaySize 338 254 # 1280x960 96dpi # DisplaySize 338 270 # 1280x1024 96dpi # DisplaySize 370 277 # 1400x1050 96dpi # DisplaySize 423 370 # 1600x1400 96dpi EndSection Hovewever, under nvidia control panel or running this command :

xdpyinfo | grep reso I get this as a result:

resolution: 111x114 dots per inch

realzippy
August 24th, 2011, 03:52 PM
..can you post your (whole) xorg.conf again in a way that it is readable?

etiennenoel
August 24th, 2011, 05:25 PM
Sorry for that, here is the xorg.conf

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
# 1366X768 96dpi
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AUO"
DisplaySize 361 203
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"
# DisplaySize 270 203 # 1024x768 96dpi
# DisplaySize 338 254 # 1280x960 96dpi
# DisplaySize 338 270 # 1280x1024 96dpi
# DisplaySize 370 277 # 1400x1050 96dpi
# DisplaySize 423 370 # 1600x1400 96dpi
EndSection

realzippy
August 24th, 2011, 05:28 PM
Is this your whole xorg.conf or only the monitor section?
Where is it from?Did you create it yourself?
Did you install the nvidia driver?

Please post output from:


lspci | grep VGA

etiennenoel
August 24th, 2011, 05:29 PM
Only the monitor, here's the whole. It comes from the nvidia-driver :

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@roseapple) Fri Feb 25 14:43:24 UTC 2011


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
# 1366X768 96dpi
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AUO"
DisplaySize 361 203
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"
# DisplaySize 270 203 # 1024x768 96dpi
# DisplaySize 338 254 # 1280x960 96dpi
# DisplaySize 338 270 # 1280x1024 96dpi
# DisplaySize 370 277 # 1400x1050 96dpi
# DisplaySize 423 370 # 1600x1400 96dpi
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 335M"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

realzippy
August 24th, 2011, 05:37 PM
Can you please create a new xorg.conf with


sudo nvidia-xconfig

and post again?(think you have edited some stuff manually!?)

etiennenoel
August 24th, 2011, 05:39 PM
Here you go :
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 (buildmeister@swio-display-x86-rhel47-07.nvidia.com) Mon Apr 18 15:15:12 PDT 2011

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@roseapple) Fri Feb 25 14:43:24 UTC 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
# 1366X768 96dpi
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AUO"
DisplaySize 361 203
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"
# DisplaySize 270 203 # 1024x768 96dpi
# DisplaySize 338 254 # 1280x960 96dpi
# DisplaySize 338 270 # 1280x1024 96dpi
# DisplaySize 370 277 # 1400x1050 96dpi
# DisplaySize 423 370 # 1600x1400 96dpi
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 335M"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Thanks for your time !

realzippy
August 24th, 2011, 05:42 PM
Which laptop?
or:
Are you sure it has 1366x768 native resolution?

etiennenoel
August 24th, 2011, 05:44 PM
My laptop is an Asus N82J-N82JQ

An yes, under windows the 1366X768 resolution is shown and also under ubuntu but the dpi is not set to 96 under ubuntu.

realzippy
August 24th, 2011, 05:56 PM
Can you try this as xorg.conf:

gksudo gedit /etc/X11/xorg.conf


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AUO"
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"
Option "UseEdidDpi" "FALSE" #added (admit I am not sure which section)
Option "DPI" "96 x 96" #added "
Modeline "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync #added
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 335M"
Option "UseEdidDpi" "FALSE" #added
Option "DPI" "96 x 96" #added
Option "ModeDebug" "True" #added,gives more info in Xorg.0.log
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
SubSection "Display"
Depth 24
Modes "1368x768_60"
EndSubSection
EndSection

Reboot or restart xserver

etiennenoel
August 26th, 2011, 01:34 PM
I tried the config you mentionned but my x server wouldn't start. I had to go into safe mode and recopy my xorg.conf from xorg.conf.backup

realzippy
August 26th, 2011, 01:51 PM
Strange.Maybe due to the fact that it is an optimus laptop.
Can you post output from:

lspci | grep VGA

Also try

gconftool-2 -s --type float /desktop/gnome/font_rendering/dpi 96
does it change anything?

etiennenoel
August 26th, 2011, 02:43 PM
Here is the output of :

lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation GT215 [GeForce GT 335M] (rev a2)


For the command:
gconftool-2 -s --type float /desktop/gnome/font_rendering/dpi 96


Nothing is changed. When I execute the function
xdpyinfo | grep reso

It still shows
resolution: 111x114 dots per inch

realzippy
August 26th, 2011, 02:51 PM
I have no idea.
Will think things over..
Suggest to ask a wiser guy:
Send a pm to catkiller (http://ubuntuforums.org/member.php?u=65401),tell him it was me who told you to and ask him if he could have a look at this thread.
Sorry..

etiennenoel
August 26th, 2011, 02:54 PM
Thanks for your time, the pm is sent.

realzippy
September 3rd, 2011, 08:40 PM
Can you open your current working xorg.conf

gksudo gedit /etc/X11/xorg.conf
and add into the "device" section the line:

Option "ModeDebug" "True"
which gives a more detailed log file.
Then reboot and run:

sudo nvidia-bug-report.sh
which creates a bug report file in your user's home directory.
Attach that file (too long for posting)

BicyclerBoy
September 3rd, 2011, 10:03 PM
There a typo in post #10
The custom modeline name does not match that listed in the screen section.
1366 vs 1368

Note that 1366 is not a standard video mode & CVT will not calculate it.
(pixel counts should be divisible by 8 for electronic & numerical efficiency)
The nvidia driver will have a 1366 mode because so many 16x9 LCDs use this size.

realzippy
September 4th, 2011, 08:06 AM
Thanks,edited it.
Indeed typo,my added modeline was correct.
1366x768 is used in OP's original xorg.conf although.

BicyclerBoy
September 4th, 2011, 09:19 PM
So why does the OP think there is anything wrong ?
The dpi calculation is made from the display size & video mode.
The OP could massage the display size to get 96dpi..but why ?

The linux nVidia driver may just be reporting the real dpi.

Windows XP GUI does not support scalable widgets/icons etc so a fixed square 96dpi became the common/popular defacto standard & could be one of the reasons there are no small high resolution DFPs.

SeijiSensei
September 6th, 2011, 07:51 PM
Try editing the Monitor section and get rid of the spaces in the DPI so it reads:


Option "DPI" "96x96"

Also try removing the identical Option declaration from the Device stanza.

I have to use 100x100 to get the correct resolution on my Sony TV. (Maybe I should be using 96x96, but 100x100 works.) I've been using this option with every iteration of the NVIDIA driver since Ubuntu 8.10; otherwise the text on my display is minute and undecipherable. I only have one such Option declaration, and it's in my Monitor stanza.

elnur
October 18th, 2011, 06:28 PM
Try editing the Monitor section and get rid of the spaces in the DPI so it reads:


Option "DPI" "96x96"

Also try removing the identical Option declaration from the Device stanza.


Thanks, man! Worked like a charm.