PDA

View Full Version : [ubuntu] audio jack not working



bahjat
August 23rd, 2011, 01:58 PM
hello i am fairly new to ubuntu and i have a toshiba satellite A200 32 bit
my sound from internal speakers is working but every time i connect my headphones it doesn't work any idea why thank you in advance.

this is the link for the script : http://www.alsa-project.org/db/?f=1c0e6dc078d96c7fd02bc5904c33924b18d69c27

handy
August 23rd, 2011, 09:38 PM
Welcome to the forums; have you been through this thread:

http://ubuntuforums.org/showthread.php?t=205449

When you do find a solution to a thread you start, it is appreciated if you open you original post (OP) & mark the beginning of the title as [SOLVED]. Enjoy your stay.

bahjat
August 24th, 2011, 02:26 AM
i have tried that solution but it didn't work every time i get to step 4 and type in this code :

sudo modprobe snd-

it gives me fatal commandnot found or something like that

lidex
August 24th, 2011, 09:42 AM
Try this using a Terminal="Applications->Accessories->Terminal"

echo "options snd-hda-intel model=toshiba" | sudo tee -a /etc/modprobe.d/alsa-base.conf Reboot

bahjat
August 24th, 2011, 10:27 AM
@lidex using that code didn't work i entered it and after it askes me to enter my password nothing happens it stays open this is what i get:

bahjat@Godzilla:~$ echo "option snd-hda-intel model=toshiba"
option snd-hda-intel model=toshiba
bahjat@Godzilla:~$ sudo tee -a /etc/modprobe.d/alsa-base.conf
[sudo] password for bahjat:


and i have rebooted and nothing changed!

lidex
August 28th, 2011, 11:41 PM
@lidex using that code didn't work i entered it and after it askes me to enter my password nothing happens it stays open this is what i get:

bahjat@Godzilla:~$ echo "option snd-hda-intel model=toshiba"
option snd-hda-intel model=toshiba
bahjat@Godzilla:~$ sudo tee -a /etc/modprobe.d/alsa-base.conf
[sudo] password for bahjat:


and i have rebooted and nothing changed!

Did you copy and paste that command or type it in? There is a typo, option should be options
Change it here:

gksu gedit /etc/modprobe.d/alsa-base.conf