View Full Version : [ubuntu] Wireless disabled at startup

August 5th, 2011, 01:42 PM
Hello, im having a trouble getting working wireless on my ASUS F5SL laptop.
I'm using Ubuntu 11.04, after i turn on laptop all networks are disconnected and wireless disabled it doesn't show any connectable networks.
Wireless card Atheros AR5001.
If i try to turn off or restart network, wireless card disables fully it doesnt show on command ifconfig (wireless disabled by hardware switch)
I tried ifconfig wlan0 up but then i get siocsifflags operation not possible due to rf-kill.

rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

Tried rfkill unblock all and nothing happened hard blocked remained the same.
I tried reseting BIOS to defaults but that didn't help I even tried if wireless works in UBUNTU 11.04 live cd booted from usb it also didn't work.
If i try restarting laptop i still get wireless disabled by hardware switch
Only when i shutdown and turn on laptopi get my wireless card appearin ifconfig but when i try to mess around with it goes wireless disabled by hardware switch.
It did work beforebut after i was messing aroundwith aircrack-ng program, after shutdown wireless didnt work..
I really hope you guys can help me.

August 5th, 2011, 02:09 PM
Im sorry guys i am an idiot, when i was putting laptop in bag i accidentally moved button on side and switched off wireless.....
Everything works fine now.

August 11th, 2011, 07:30 AM
The success of the series has inspired short videos for mobile phones, several official tie-ins in print and on the Internet, as well as a video game.