PDA

View Full Version : [ubuntu] Internetconnections works randomly



hamena314
July 31st, 2011, 11:01 AM
Hello,

3 of my computers have problems with the internet connection.
Sometimes it works, but most of the times it simply doesnt.
I can ping our router and the switches, but nothing in the internet.
Pinging a DNS like 8.8.8.8 wont work either, so this might not be a DNS problem.

Restarting the pc / network changes nothing.

Here some output:


cat /var/lib/NetworkManager/NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=false
WWANEnabled=true



ifconfig -a
eth0 Link encap:Ethernet Hardware Adresse 00:13:77:f1:b2:28
inet Adresse:10.1.2.14 Bcast:10.1.2.255 Maske:255.255.255.0
inet6-Adresse: fe80::213:77ff:fef1:b228/64 Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
RX packets:1159 errors:0 dropped:0 overruns:0 frame:0
TX packets:118 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:115856 (115.8 KB) TX bytes:13984 (13.9 KB)
Interrupt:18

lo Link encap:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metrik:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:720 (720.0 B) TX bytes:720 (720.0 B)

wlan0 Link encap:Ethernet Hardware Adresse 00:24:2b:bc:02:19
BROADCAST MULTICAST MTU:1500 Metrik:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



cat /etc/network/interfaces

auto lo
iface lo inet loopback




cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 10.1.2.1
nameserver 212.202.215.1




route -n
Kernel-IP-Routentabelle
Ziel Router Genmask Flags Metric RefUse Iface
10.1.2.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 10.1.2.1 0.0.0.0 UG0 0 0 eth0


1 of my computers has also windows 7 which works fine.

HAVE PHUN!

jmoorse
August 2nd, 2011, 02:07 AM
Hi, do all the affected machines lose connection at the same time?

Are they all Ubuntu?

Do they connect in the same manner (eg: through the same switch) as the Win 7 box?

Can you post the output of 'dmesg' when the interruption is noticed?

And the 'traceroute 8.8.8.8' output during the interruption.