PDA

View Full Version : [ubuntu] Unable to download updates



TXbirder
July 29th, 2011, 08:17 PM
Twice this week I've tried to download " Important security updates". Each time the response is:


W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt_0.7.25.3ubuntu9.5_amd64.deb
404 Not Found [IP: 91.189.88.30 80]

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-utils_0.7.25.3ubuntu9.5_amd64.deb
404 Not Found [IP: 91.189.88.30 80]


W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/l/logrotate/logrotate_3.7.8-4ubuntu2.1_amd64.deb
404 Not Found [IP: 91.189.88.30 80]


W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/d/dbus/libdbus-1-3_1.2.16-2ubuntu4.2_amd64.deb
404 Not Found [IP: 91.189.88.30 80]


W: Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.42-1ubuntu2.1_amd64.deb
404 Not Found [IP: 91.189.92.167 80]


W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/a/apt/apt-transport-https_0.7.25.3ubuntu9.5_amd64.deb
404 Not Found [IP: 91.189.88.30 80]


W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/p/python-apt/python-apt_0.7.94.2ubuntu6.2_amd64.deb
404 Not Found [IP: 91.189.88.30 80]


W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/d/dbus/dbus_1.2.16-2ubuntu4.2_amd64.deb
404 Not Found [IP: 91.189.88.30 80]


W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/d/dbus/dbus-x11_1.2.16-2ubuntu4.2_amd64.deb
404 Not Found [IP: 91.189.88.30 80]

What am I doing wrong? I have successfully downloaded other updates.

John

bodhi.zazen
July 29th, 2011, 09:00 PM
try


sudo apt-get update
sudo apt-get upgrade

akoskm
July 29th, 2011, 09:46 PM
Have you tried to switch your download source to the Main server?
Update Manager > Settings > Ubuntu Software > Download from: Main server.

bodhi.zazen
July 29th, 2011, 09:55 PM
Have you tried to switch your download source to the Main server?
Update Manager > Settings > Ubuntu Software > Download from: Main server.

If you look at the links in question, you will see the package version is outdated, and thus the user has to update the database, as indicated in my post :twisted:

akoskm
July 29th, 2011, 10:29 PM
If you look at the links in question, you will see the package version is outdated, and thus the user has to update the database, as indicated in my post :twisted:

I'm sorry for my response, sir!:lolflag:

bodhi.zazen
July 29th, 2011, 10:33 PM
I'm sorry for my response, sir!:lolflag:

NP, was just trying to show you how to debug the OP question.

Is it a problem with the server / url or is a problem of updating the database ?

The solution is dependent on answering that question first ^^

TXbirder
July 30th, 2011, 12:22 AM
The terminal entry did the job. Thanks.
John