View Full Version : [gnome] Firefox says "not a directory" when clicking on downloaded file

July 24th, 2011, 03:06 PM
Hi. I've upgraded Maverick to Natty, and since then I'm having one problem with Firefox.

I have a list of downloaded files in FF. Clicking on every file (pdf, png, iso, etc) gives me an error, like: "Can't open <filename>: This location is not a directory". The error message is the same as if I'd run nautilus <filename>, and in fact it seems to originate from nautilus. Also FF seems to ignore my settings under Preferences -> Applications, where I can choose what program to use for different file types. Does anyone know the solution for this?

July 25th, 2011, 08:25 PM
I've tried removing .mozilla folder in my ~. Firefox had default settings again, but problem persisted.

July 25th, 2011, 08:34 PM
scan your filesystem for errors by doing:

sudo touch /forcefsck

and reboot. See if the problem persists then.

July 26th, 2011, 01:54 AM
Try removing the "exo-utils".

sudo apt-get remove exo-utils

This also removes thunar but worked for me.

July 26th, 2011, 06:37 PM
Removal of exo-utils helped, thanks!

The problem is that with removing exo-utils, apt wants also to delete xfce4-terminal, which I use instead of gnome-terminal. But now I have a hint where to look for the real problem. Thanks again ;]