PDA

View Full Version : [ubuntu] Dual screen Issues



Alex---1
July 14th, 2011, 01:52 AM
Hi all

New to the whole Linux scene and new to the forum so bare with me.... :)

I recently installed Ubuntu 11.04 and was loving it until now. I can't get my dual monitor setup to work and I've spent hours tonight trying to get it going.

I tried this: http://www.bamweb.nl/computer/linux/295 and this worked really well, I ran up Nvidia X server settings and saved the config but as soon as I reboot it changes the resolutions on my primary monitor and makes the secondary one unusable.

I've spent hours trying to get this going and can't for the life of me get it right, I hate to say it but dual monitors on M$ is so amazingly simple compared to this, plug in, CTRL+P, done. This has been a nightmare and I'm almost on the point of uninstalling this and going back to winblows :(

My specs are :

Core 2 duo
4 gigs of DDR2
Nvidia GTX 570
Primary Monitor - 24"
Secondary - 19"

Thanks a lot in advance.

Alex---1
July 14th, 2011, 09:49 AM
Anybody? I switched to mint this morning and that was even worse. Back on Ubuntu now but still don't know what's wrong with it.

Thanks

realzippy
July 14th, 2011, 10:23 AM
Why do you use disper?
Do you unplug your 2nd monitor often?
(disper is made to handle different monitor setups.If
you want a static dual monitor setup,Twinview,Xinerama,
you should not use disper.)
Can you post your current xorg.conf file ?

...btw,welcome to UF!

Alex---1
July 14th, 2011, 07:26 PM
Why do you use disper?
Do you unplug your 2nd monitor often?
(disper is made to handle different monitor setups.If
you want a static dual monitor setup,Twinview,Xinerama,
you should not use disper.)
Can you post your current xorg.conf file ?

...btw,welcome to UF!

Hi, thanks for your reply...

I only used disper because the link in my first post said to use it. Since then I have completely reinstalled ubuntu with a clean wipe. Also, I leave my secondary monitor in all the time as I use it for M$.

I ran up 'sudo nvidia-settings' and got the following message: Failed to parse existing X config file '/etc/X11/xorg.conf'!

After clicking ok and trying again it let me see my config file, here is what it says:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@allspice) Fri Feb 25 14:42:07 UTC 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer P223W"
HorizSync 31.0 - 84.0
VertRefresh 56.0 - 77.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 570"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

At the moment by default it's only using my primary monitor, the secondary is off (still plugged in). How would I go about changing it so it's like one big monitor, I'm scared of touching anything now in case it goes wrong again!

Thanks

realzippy
July 14th, 2011, 08:09 PM
Suggest to:
1.Make local backup of current xorg.conf:


sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.single

2.Power-on the 2nd monitor,then start


nvidia-settings

(no need for sudo,this used to be in earlier driver versions;you are asked for password when saving to X-configuration file)

3.Make your desired TwinView/Xinerama settings,then
hit "Save to X configuration file".
Exit nvidia-settings.

Now you should have a new xorg.conf with 2 monitor sections,
and Twinview/Xinerama enabled.You can copy this to Desktop
for later views:


sudo cp /etc/X11/xorg.conf ~/Desktop/xorg.conf.dual

4.Reboot or restart the X server;if it does not work
(very likely since you tried all night long), post your
xorg.conf.dual;the 2nd monitor (or it's EDID might
not be recognised correctly..)

Alex---1
July 14th, 2011, 08:56 PM
Well I followed what you put and it worked! Problem I have now is that it's using my secondary monitor as the primary so UNIX is running on the secondary and my bigger monitor is acting as the extra, I can't find anything in nvidia-settings that allows me to change this?

Here is the xorg.conf.dual



# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@allspice) Fri Feb 25 14:42:07 UTC 2011

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Mon Apr 18 15:14:00 PDT 2011

Section "ServerLayout"

# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Arnos Instruments F-417"
HorizSync 24.0 - 80.0
VertRefresh 49.0 - 75.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Arnos Instruments F-417"
HorizSync 24.0 - 80.0
VertRefresh 49.0 - 75.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 570"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 570"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: 1680x1050 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "CRT: 1280x1024 +1680+0, DFP: 1680x1050 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT: 1280x1024 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Thanks

EDIT: Found it, it was in the Nvidia-settings

*facepalm*

woohoo, now I can get back to enjoying Ubuntu, thanks a lot realzippy!

realzippy
July 14th, 2011, 09:20 PM
To be honest,I am a little confused about your
xorg.conf.dual
Anyway,it seems to work.
Run

gksudo gedit /etc/X11/xorg.conf

and add :
Option “TwinViewOrientation” “LeftOf”
or
Option “TwinViewOrientation” “RightOf”
(depending on your physical setup) to your
"screen" section,eg below
Option "TwinView" "1"
so it looks like:

.....
Option "TwinView" "1"
Option “TwinViewOrientation” “LeftOf”
Option "metamodes" "CRT: 1280x1024 +1680+0, DFP: 1680x1050 +0+0"
.....

Unfortunately I am not at my nvidia machine at the moment,so I
can only help theoretically.

Edit:
Just saw your edited post.Glad it worked.Please set thread as solved.Have fun.

realzippy
August 22nd, 2011, 01:13 PM
Just cleaning up my subscribed threads.
Please set thread as solved (ThreadTools)...thanks