PDA

View Full Version : [SOLVED] 11.04 new install old laptop wireless shows up won't connect



eatsleeplaxsoccer
July 14th, 2011, 01:09 AM
Hi
this is my first experience with Ubuntu as the main OS on a machine, everything prior has been on a VM.
I tried to salvage an old laptop, a Toshiba Portege M200 (http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=SB&os=&category=&moid=519121&rpn=PPM21U&modelFilter=M200&selCategory=2756709&selFamily=1073768662), that I installed 11.04 on via USB.
Things went pretty well, internet works fine with a wired ethernet connection, so I have all the updates.
My issue with wireless is this:
Wireless networks, including my router that I want to connect to, will show up fine, but when I click one to connect to it, it won't. My network is WPA2 with a PSK, and nothing comes up asking for a passphrase. If I manually create the wireless network profile, it says its connected but the icon is a monitor with the wireless icon in it, not the normal wireless icon. it grabs a weird IP address (10.42.43.1, not the normal 192.168.1.10x), and I can't connect to the internet. and it does the same thing if I give it the wrong passphrase.
if I change my router to no security and select the network in Ubuntu, the wireless icon looks like it's trying to acquire an IP address, but time's out and says "Disconnected, you are now offline"
:confused:
Is this a driver issue? or a software/ubuntu issue (I am about to clean downgrade to 10.04 LTS to see if that helps)
the wireless card is:
Intel Corporation 82551QM Ethernet Controller [8086:1059]
lshw -Network says that the driver eth1 (my wireless) is using is called "orinoco_cs"

Please help if you can,
thanks!

chili555
July 14th, 2011, 02:07 AM
It's an eatsleep issue and a downgrade won't help in the least. A 10.42.43.1 address is what you get when you click the Network Manager icon and click 'Create New Wireless Network...' That wording ought to say 'Create New Wireless Network computer-to-computer in internet connection sharing.' Is that what you intended? No? Then click on the NM icon and wipe out all those settings. Make sure the Mode is set to Infrastructure. Reboot and check:
iwconfigThe mode should now be Managed, approximately like:
IEEE 802.11abg ESSID:"GBR1"
Mode:Managed Frequency:2.462 GHz Access Point: 99:24:56:22:D7:99
Bit Rate:36 Mb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=82/100 Signal level=-48 dBm Noise level=-92 dBm
Rx invalid nwid:0 Rx invalid crypt:2 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Now simply click the NM icon and see your network and connect. Post back if it doesn't work as expected.
Intel Corporation 82551QM Ethernet Controller [8086:1059]That's the ethernet card, not wireless.

BrianGular
July 14th, 2011, 02:08 PM
I'm having a similar problem. I did a full,clean install of ubuntu 11.04 this morning. The machine is a Toshiba A15-S157. The installation and updates finished without a hitch while connected wired to my router. I unplugged the Ethernet cable, clicked on the network manager icon at the top of the screen, and was pleased to see my wireless network SSID listed--along with the networks of several of my neighbors. When I clicked on the SSID of my network, however, nothing happened. That is, the menu disappeared but no additional windows popped up to prompt me for authentication for the network. (I use WPA2 Personal with TKIP+AES algorithms. I have 7 or 8 other wireless devices that connect to this router without problems.)

I tried to out-smart the system by clicking on the network manager icon and selecting connect to a hidden wireless network. I gave it the proper SSID, selected WPA & WPA2 Personal for security, and provided my passphrase. After clicking Connect, a little window pops up to tell me that the network is disconnected. Network manager seems to think I'm connected, but ifconfig shows no IP address has been assigned. wconfig shows that the network connection is managed, and the name of my wireless network shows up as the ESSID.

After a minute or two, a Wireless Network Authentication Required window pops up. It says that passwords or encryption keys are required. The trouble is that the Wireless Security selector (drop down) is not populated. I can't choose any kind of wireless security. All I can do is click cancel or connect.

I've tried changing router channels, rebooting everything a few times, and switching the WPA algorithm to AES only. I'm not sure what else to do. Any ideas?

BrianGular
July 14th, 2011, 02:13 PM
One more thing. For grins I just tried connecting to my neighbors' wireless. I get prompted for authentication! Hmmm. This suggests something about my router settings that are giving my laptop's wireless fits. Maybe this isn't Ubuntu after all...

chili555
July 14th, 2011, 02:22 PM
One more thing. For grins I just tried connecting to my neighbors' wireless. I get prompted for authentication! Hmmm. This suggests something about my router settings that are giving my laptop's wireless fits. Maybe this isn't Ubuntu after all...Please start your own new thread as your issue is not eatsleep's issue (10.42.43.1, etc.)

eatsleeplaxsoccer
July 14th, 2011, 02:46 PM
I think BrianGular is having the same problem. I only did the "Create New Wireless Network" as a troubleshooting step when simply selecting my network from the NM dropdown didn't work.

Oddly enough I had the exact same issue as Brian when trying a neighbor's network. Selecting my network with WPA didn't do anything, but selecting a neighbor's network at least brought up a prompt for security passphrase, but there's nothing populated in the dropdown for security type so I can't enter anything.

And as I mentioned when I try to connect to my router after taking the WPA2 security off, the connection looks like it's trying but then times out and says disconnected.

I also have several other devices that connect to my router without problems: Windows, Android, iOS

Running Ubuntu from the Live disk had the same issue with the wireless not working

chili555
July 14th, 2011, 03:07 PM
Is your network set to mixed WPA and WPA2? That mode is troublesome and either WPA or WPA2 is preferred. Also, if your router is set to require N speeds or G speeds only, that can be troublesome; it's better to select mixed B, G and N. If all those steps don't result in a connection, let's look at the wireless driver, maybe there is a conflict we can eliminate or an alternate setting we can try. Please post:
lspci -nn | grep 0280

BrianGular
July 15th, 2011, 01:54 AM
My router--a Linksys WRT54G--Allows me to select "WPA Personal" or "WPA2 Personal". It does not appear to have a mixed mode. I have been using "WPA2 Personal" for months.

The output of lspci -nn | grep 0280 is nothing. No matches.

I switched the router from WPA2 Personal to WPA Personal and the laptop was able to connect. I wonder if there is an updated driver that would fix this problem? That's where I'm going to look next.

BrianGular
July 15th, 2011, 02:12 AM
I looked a little further. The Linksys docs say that if I choose WPA2 Personal and choose TKIP+AES for the algorithm it can connect to both WPA and WPA2. That sounds like mixed mode! I can choose AES only for WPA2, but that doesn't work. The summary:

WPA + TKIP works
WPA + AES does not work
WPA2 + AES does not work
WPA2 + TKIP+AES does not work

chili555
July 15th, 2011, 02:12 AM
The output of lspci -nn | grep 0280 is nothing. No matches.
I wonder if there is an updated driver that would fix this problem? That's where I'm going to look next. Where? What is the driver? Is your wireless device USB? Please post:
lsusb

BrianGular
July 15th, 2011, 02:19 PM
The driver I'm referring to would be the Ubuntu driver for the laptop's wireless card. The wireless is a built-in Atheros mini-PCI card.

While looking for such a driver, I came across a post that suggested switching from network-manager to wcip. I did so. Behavior is much more consistent--I am always prompted for the password now. When WPA2 is enabled on my router, wcip always comes back with "bad password." From the large number of posts, this appears to be a common problem. Unfortunately, the several fixes proposed in response to those posts haven't worked for me.

chili555
July 15th, 2011, 04:30 PM
The driver I'm referring to would be the Ubuntu driver for the laptop's wireless card. The wireless is a built-in Atheros mini-PCI card.

While looking for such a driver, I came across a post that suggested switching from network-manager to wcip. I did so. Behavior is much more consistent--I am always prompted for the password now. When WPA2 is enabled on my router, wcip always comes back with "bad password." From the large number of posts, this appears to be a common problem. Unfortunately, the several fixes proposed in response to those posts haven't worked for me.The reason I asked the pointed question is that, up until now, we haven't explored any issues related to the wireless driver. Which Atheros driver is it? Have any of the posts tried a different driver with success? What driver do you propose to try?

eatsleeplaxsoccer
July 15th, 2011, 10:24 PM
Changing the router to WPA with TKIP was the only thing that worked
not AES or WPA2 or even, for some reason, security disabled.
But when I connect to the WPA TKIP network, the prompt for the password says "WPA/WPA2" so it seems like it should be able to handle WPA2.
Even when I created the connection successfully then changed the router back to WPA2 and AES/TKIP, it wouldn't work.
My laptop is very old, could it be just that the wireless card can't handle WPA2 or AES?

chili555
July 15th, 2011, 10:28 PM
could it be just that the wireless card can't handle WPA2 or AES?Certainly. Please check:
sudo iwlist wlan0 authSubstitute your wireless interface, if it's not wlan0. Mine says:
wlan0 Authentication capabilities :
WPA
WPA2
CIPHER-TKIP
CIPHER-CCMP

eatsleeplaxsoccer
July 15th, 2011, 10:44 PM
ah that seems to be it

eth1 Authentication capabilities :
WPA
CIPHER-TKIP
Current Key management :
PSK
Current TKIP countermeasures : no
Current Authentication algorithm :
open


thats frustrating. I will mark the thread as solved

EDIT:
Still doesn't make sense why it didn't work when the wireless security is turned off.