PDA

View Full Version : [all variants] Problem setting up primary monitor



Naposk
June 23rd, 2011, 11:47 PM
Hello,

I have the following situation. I have a laptop, connected to two monitors, one of which is rotated. The setup is similar to this one: http://bitkickers.blogspot.com/2009/08/rotate-just-one-monitor-with.html .

The current situation is as follows:
-DFP-0, the laptop's display, is off (because 3 monitors are not supported unfortunately),
-DFP-1 is the monitor on the left,
-CRT-0 is the monitor on the right (rotate clockwise).

I've set up everything except for the primary monitory - currently it is CRT-0, but I would like it to be DFP-1. I've tried several things, including:
-switching the screen numbers in the layout specification (which causes X to fail),
-setting the TwinViewInfoOrder to DFP-1, CRT-0 (doesn't work).

There's probably some conflicting, overriding option in my xorg.conf that is causing CRT-0 to be primary. Here's my xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@allspice) Fri Feb 25 14:42:07 UTC 2011

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
# # generated from default
# Identifier "Mouse0"
# Driver "mouse"
# Option "Protocol" "auto"
# Option "Device" "/dev/psaux"
# Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
#EndSection
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
# # generated from default
# Identifier "Keyboard0"
# Driver "kbd"
#EndSection

Section "ServerLayout"

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
# InputDevice "Mouse0" "CorePointer"
Identifier "Layout0"
Screen 0 "Screen0" RightOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "1"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Ancor Communications Inc ASUS VW193D"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor2"
VendorName "Unknown"
ModelName "Samsung SMBX2235"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Samsung SMBX2235"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 330M"
BusID "PCI:2:0:0"
Screen 0
Option "RandRRotation" "on"
EndSection

Section "Device"
Identifier "Device2"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 330M"
BusID "PCI:2:0:0"
Screen 2
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 330M"
BusID "PCI:2:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
Option "TwinView" "0"
Option "metamodes" "CRT: 1440x900 +0+0"
Option "rotate" "cw"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"

Identifier "Screen2"
Device "Device2"
Monitor "Monitor2"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
Option "metamodes" "DFP-1: 1920x1080 +0+0; DFP-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
Option "metamodes" "DFP-1: 1920x1080 +0+0; DFP-1: 1024x768i +0+0; DFP-1: 960x540 +0+0; DFP-1: 840x525 +0+0; DFP-1: 832x624 +0+0; DFP-1: 800x600 +0+0; DFP-1: 800x600_75 +0+0; DFP-1: 800x600_72 +0+0; DFP-1: 800x600_60 +0+0; DFP-1: 800x600_56 +0+0; DFP-1: 800x512 +0+0; DFP-1: 720x450 +0+0; DFP-1: 720x400 +0+0; DFP-1: 700x525 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

What should I change for DFP-1 to be recognized as primary? Thanks in advance for any help.

chkneater
June 24th, 2011, 12:02 AM
Try changing the primary monitor settings in the bios. Turn off the laptop screen (I'm assuming is the CRT) and leave the others on. If a problem occurs on boot and it gives an error messgage about going into low graphics mode, sometimes you can reconfigure the graphics easier throgh those prompts.

But I feel confident its just because your bios is still recognizing the laptop monitor.

Naposk
June 24th, 2011, 02:19 AM
Unfortunately, I don't have such a setting in the BIOS. The laptop monitor is currently completely off, by the way, including the backlight.

BicyclerBoy
June 24th, 2011, 11:32 AM
I have battled this as well & gave it up .
Twinview seems the commonly used solution.

My primary happens to be on "Device0" & it is listed before "Device1" section.
I do not remember, when studying Xorg X11R6 docs, reading that the order mattered but this is nvidia X server.

I have found some suggestion that the order of the "Device" sections in xorg.conf changes the primary monitor for X server.
But that does not work for me.

So try moving your "Device2" section above "Device0"..
(you may also have to move Screen2 & Monitor2 sections before the others)
and fix the DFP-1 references in the "Screen1" section.. should be DFP-0.

A more likely solution could be to re-arrange your Devices Screens Monitors to make your preferred primary
Device0 Screen0 Monitor0 == DFP-1

Another possible xorg.conf option

Option "UseDisplayDevice" "DFP-1"
You could use this in your re-arranged xorg.conf "Screen0" section.

Option "Primary" "True"
You could use this in your re-arranged xorg.conf "Monitor0" section. (Rrandr 1.2 or later)

AFAIK
The CRT-n, DFP-n references are direct mapping to the wired ports.
So they do not change, the trick is somehow linking Device 0 ,1 or 2 to DFP-0,1 or VGA-0,1 etc..

chkneater
August 13th, 2011, 04:38 AM
I was interested if this was just a matter of just renaming the monitor and screen sections? Has that worked?