PDA

View Full Version : [ubuntu] I ... I made a mistake



Darris
June 15th, 2011, 09:55 AM
So I was attempting to encrypt my flashdrive and i was just copying and pasting the commands from a website
and the webside put /dev/sda1
that's the name of my hard drive
and my computer began shutting down, but I felt like I had responded in time by immediately powering off.
and now the grub says theres no operating system
and I booted from TAILS and the hard drive is encrypted... but the passphrase is not what I set it to be
I think I may have corrupted the passphrase

Is there anyway that I can get my data back from the valley of foolishness?

inameiname
June 15th, 2011, 11:36 AM
Yikes, I hate when that happens. Well, I don't really know where to start. It all depends on just what was erased from the time you started it to when you restarted. Sounds like it did some damage, software-wise. I'm afraid I'm not apt to give you a lot of help in that field.

Perhaps the first thing to do is to use a live cd (Ubuntu or whatever) and boot from it, get the important files/documents/etc off of it first and formost. Then figure out if its salvageable without having to redo the whole thing from scratch. Although, depending on just what was erased, you may have trouble easily getting stuff off of it booting from a Live CD.

It could be as simple as restoring grub and your boot options. I don't know off hand how to do that, but google it and you might get lucky. That'd be where I'd go next to fix this problem.