PDA

View Full Version : [ubuntu] Update error: invalid signatures



maqtanim
June 13th, 2011, 05:25 AM
For couple of days, I am getting the following message after updating Ubuntu 10.04.

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://archive.canonical.com lucid Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/lucid/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.


It seems that some repository is down. Currently I am using Main Server as the source. I've tried with some other servers also, but with no luck.

Does anyone have any suggestion?

Wild Man
June 13th, 2011, 06:09 AM
For couple of days, I am getting the following message after updating Ubuntu 10.04.

W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used.GPG error: http://archive.canonical.com lucid Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

W: Failed to fetch http://archive.canonical.com/ubuntu/dists/lucid/Release

W: Some index files failed to download, they have been ignored, or old ones used instead.


It seems that some repository is down. Currently I am using Main Server as the source. I've tried with some other servers also, but with no luck.

Does anyone have any suggestion?
Hi try this

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 048A1684108A879Cyou may have to get rid of the old key first.

maqtanim
June 13th, 2011, 08:42 AM
The command did not work. :(

BTW, how to get rid of old key?

maqtanim
June 13th, 2011, 03:11 PM
Well... I am getting a notice in my notification area like the attached screen-shot.

Stray Wolf
June 13th, 2011, 06:21 PM
I've been having the same problem in Lucid. I ran:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
Result:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
gpg: requesting key 437D05B5 from hkp server keyserver.ubuntu.com
gpg: key 437D05B5: "Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
Then ran:
sudo apt-get update
Result (error only):
W: GPG error: http://archive.canonical.com lucid Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

This has been happening for about a week. Still looking for an effective solution. Once I find one I'll post here unless someone beats me to it.

jynyl
September 20th, 2011, 11:44 AM
Similar problem here;
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://nz.archive.ubuntu.com natty-updates Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

philinux
September 20th, 2011, 11:55 AM
Similar problem here;
W: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://nz.archive.ubuntu.com natty-updates Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

Hi,

Read this first post. You'll then be able to fix yours.
http://ubuntuforums.org/showthread.php?t=1221323

sadaruwan12
September 20th, 2011, 01:08 PM
Read this how to delete the GPG key

Click Here (https://weblion.psu.edu/trac/weblion/wiki/DeleteGpgKey)

To rectify your problem read this

Click Here (http://systembash.com/content/apt-get-update-gpg-key-errors-and-fix/)