PDA

View Full Version : [ubuntu] OpenGL issues



DMzda
June 12th, 2011, 01:10 PM
After installing Natty, compiz started messing up. Other programs that use OpenGL also do the same thing (See atttachment). Compiz ran fine in Maverick.

My graphics card is an ATI Radeon x300.

Are there any alternative drivers that I can install?

VOT Productions
June 12th, 2011, 01:18 PM
Try the fglrx drivers. You can either do sudo apt-get install fglrx or look in Synaptic.

DMzda
June 12th, 2011, 01:33 PM
After installing those drivers, compiz still doesn't work properly (No window borders, and docky complains about lack of compositing). glxgears doesn't run, giving a Segmentation fault.

VOT Productions
June 12th, 2011, 01:38 PM
If you have CCSM installed, enable Compositioning.
Also, try sudo glxgears.

DMzda
June 12th, 2011, 01:45 PM
Same errors. Also, the ATI Catalyst Control Center says that the graphics card is not supported, or similar.

VOT Productions
June 12th, 2011, 01:53 PM
Odd... follow this link. https://help.ubuntu.com/community/RadeonDriver
sudo apt-get remove fglrx
sudo apt-get install xserver-xorg-video-ati

DMzda
June 12th, 2011, 03:50 PM
I have done that, and still the problem persists.

silex89
June 12th, 2011, 03:54 PM
What about the proprietary drivers for your card?, did you installed them from jockey?

VOT Productions
June 12th, 2011, 03:57 PM
[Removed due to double post]

VOT Productions
June 12th, 2011, 03:58 PM
Try ALT+F2 then compiz --replace

DMzda
June 12th, 2011, 05:03 PM
What about the proprietary drivers for your card?, did you installed them from jockey?
Jockey says that there are no proprietary drivers available for my system.


Try ALT+F2 then compiz --replace
Doing this still doesn't make a difference.

dFlyer
June 12th, 2011, 05:13 PM
I read some where on the forum that ati cards have a problem with unity. How true that is I don't know.

beew
June 12th, 2011, 06:46 PM
Since you have the open driver you can try adding the xorg-edgers ppa to your sources list and update.

https://launchpad.net/~xorg-edgers/+archive/ppa (https://launchpad.net/%7Exorg-edgers/+archive/ppa)

I have had problem with OpenGL in one ati machine I run Natty on. OpenGL version was 1.7 using the open source driver. Upgrading with this ppa boosted it up to OpenGl 2.1 and things that didn't work before suddenly started working.

Read carefully first. If anything goes wrong purge the ppa using ppa-purge, so install that first.

DMzda
June 12th, 2011, 09:25 PM
I read some where on the forum that ati cards have a problem with unity. How true that is I don't know.
I don't use unity, just the classic desktop.


Since you have the open driver you can try adding the xorg-edgers ppa to your sources list and update.

https://launchpad.net/~xorg-edgers/+archive/ppa (https://launchpad.net/%7Exorg-edgers/+archive/ppa)

I have had problem with OpenGL in one ati machine I run Natty on. OpenGL version was 1.7 using the open source driver. Upgrading with this ppa boosted it up to OpenGl 2.1 and things that didn't work before suddenly started working.

Read carefully first. If anything goes wrong purge the ppa using ppa-purge, so install that first.
That installs and works fine, but the issues still persist.