PDA

View Full Version : [ubuntu] Sound continues to emit from speakers after plugging in headphones



razzihaider
June 7th, 2011, 05:03 PM
I have a problem, when i plug in headphone jack in to my laptop, i stll heard from both laptop speakers and the headphones, i have tried to fix this through editin .conf file, but it didn't worked. help me solve this. plz

CeeCeez
June 9th, 2011, 10:43 AM
I have the same problem. What model do you have? Mine is K52J.

CeeCeez
June 9th, 2011, 10:57 AM
Try this, worked for me!:D

http://girliemangalo.wordpress.com/2011/04/15/fix-asus-k52j-speaker-sounds-with-ubuntu-10-10/

fi2
June 11th, 2011, 09:05 AM
Eee: I have it the other way round. Inserting the jack the speaker goes mute, but the headphone does not sound up. It does with Win7.

What you say means that it does not alternate the outputs with the jack-switch, but uses separate amplifiers instead. Is it so?

I have't tried the solution above yet - I certainly will.

Vinton90
June 13th, 2011, 09:46 PM
I have the same problem. But I'm new at all this. I have an Asus U50F. However, when I tried the above fix it came back looking like this.


wesley@wesley-laptop:~$ sudo apt-get install linux-alsa-driver-modules-$(wesley-r)
wesley-r: command not found
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package linux-alsa-driver-modules
wesley@wesley-laptop:~$ sudo apt-get install linux-alsa-driver-modules
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package linux-alsa-driver-modules
wesley@wesley-laptop:~$



I'm still searching around and I won't give up until I get it fixed but any help would be appreciated.
Thanks.

lidex
June 19th, 2011, 01:29 AM
Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Choose the upload option and provide a link for the output.

CloudShadow
June 19th, 2011, 09:48 PM
I have the exact same problem, i entered the above command in terminal and this is what the end result says

grep: /tmp/alsa-info.NAKGoGVueu/wget.tmp: No such file or directory
Your ALSA information is located at
Please inform the person helping you.

Any help would be very appreciated, i just switched from win 7 today and faced this problem. :(

batman408
August 20th, 2011, 05:34 AM
@Lidex

I have the same issue.

Here's the link to my ALSA report - http://www.alsa-project.org/db/?f=4a6d3dc61a35b4b5106a9c9e9de728f5321c51af

I'd really appreciate if you could help, Thank You

lidex
August 22nd, 2011, 06:05 AM
@Lidex

I have the same issue.

Here's the link to my ALSA report - http://www.alsa-project.org/db/?f=4a6d3dc61a35b4b5106a9c9e9de728f5321c51af

I'd really appreciate if you could help, Thank You


Try this using a Terminal="Applications->Accessories->Terminal"

echo "options snd-hda-intel model=auto" | sudo tee -a /etc/modprobe.d/alsa-base.conf Reboot

Linuxisfast
August 23rd, 2011, 02:02 AM
On my 1015B, all I have to do is plug in and reboot and it works.

batman408
August 23rd, 2011, 11:17 PM
Try this using a Terminal="Applications->Accessories->Terminal"

echo "options snd-hda-intel model=auto" | sudo tee -a /etc/modprobe.d/alsa-base.conf Reboot
Hi Lidex,

I tried running the line of code in terminal and rebooting yet the problem is still the same. Sound only comes from headphones when connector is set to analog output, and even then the sound comes from both the headphones and the internal speakers. When switching the connector to Analog Headphones, nothing happens.

lidex
August 24th, 2011, 09:06 AM
Hi Lidex,

I tried running the line of code in terminal and rebooting yet the problem is still the same. Sound only comes from headphones when connector is set to analog output, and even then the sound comes from both the headphones and the internal speakers. When switching the connector to Analog Headphones, nothing happens.

Have a look here:
http://ubuntuforums.org/showthread.php?t=1762969&highlight=headphones+asus+k60i

batman408
August 24th, 2011, 09:11 AM
Have a look here:
http://ubuntuforums.org/showthread.php?t=1762969&highlight=headphones+asus+k60i
Perfect man, Thank yoU!