PDA

View Full Version : [ubuntu] K42JC and Ubuntu 11.04 - No sound at all



bangrobe
June 7th, 2011, 04:47 PM
Hi everybody
I'm using Asus K42JC and Ubuntu 11.04 ( just installed Linux Mint 11 replace for Ubuntu). I updated to latest Kernel, and now I can't hear any sound in Ubuntu. No system sound, no music. I already checked all sound preference, Alsa Mixer and they aren't mute. I followed instruction on this link : http://ubuntuforums.org/showthread.php?t=1744966 but the problem still exist.
So anyone could give me a help? Thanks so much.:)

lidex
June 19th, 2011, 01:39 AM
Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Choose the upload option and provide a link for the output.
[Terminal="Applications->Accessories->Terminal"]

megamendung
July 13th, 2011, 04:04 AM
i have same problem (on same laptop series), please help. here is link alsa-info.

http://www.alsa-project.org/db/?f=d764877a9d4cf0502f95f5fe8118656eb9ed8cf9

thanks in advance...

lidex
July 15th, 2011, 06:36 AM
i have same problem (on same laptop series), please help. here is link alsa-info.


thanks in advance...

The edit you made to alsa-base.conf is not for your codec chip so remove it and run the alsa-info script again.

gksudo gedit /etc/modprobe.d/alsa-base.conf
Remove this line;

options snd-hda-intel model=laptop position_fix=1 enable=yes
Save. Close. Reboot.

plasticinedean
July 22nd, 2011, 07:32 AM
I had the same issue. I fixed it by updating the kernel to the latest rc. The kernel im using is v3.0-rc7, with full working sound, system, music, movies etc. To update the kernel download from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.0-rc7-oneiric/ the files:

linux-headers-3.0.0-0300rc7_3.0.0-0300rc7.201107120911_all.deb

linux-headers-3.0.0-0300rc7-generic_3.0.0-0300rc7.201107120911_i386.deb

linux-image-3.0.0-0300rc7-generic_3.0.0-0300rc7.201107120911_i386.deb

Install them in the above order and reboot for working sound (in grub just choose to boot from the new kernel). Note that i have only tried this for 32bit. You can try the amd64 generic header and image if your on 64bit, but i have no idea whether it will work.