PDA

View Full Version : No 5.1 Sound with Ubuntu 11.04



BlackScript
June 1st, 2011, 07:58 PM
Hi,

i got no surround-sound with my nb which running 11.04 x64

i only got sound on "front right" and "front left" i already tried
everything what i found in the Internet. setting a profile in sound settings will not change anything... in the alsamixer all channels are enabled and max volume.

about my hardware (what alsamixer shows)

Device: HDA Intel
Chip: Nvidia MCP77/78 HDMI

any ideas ?



Thank You


- BlackScript

lidex
June 4th, 2011, 05:38 AM
Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Choose the upload option and provide a link for the output.
[Terminal="Applications->Accessories->Terminal"]

satishkhandekar
June 17th, 2011, 04:00 PM
Hi,

I am having the similar problem...
I have uploaded the details requested on
http://www.alsa-project.org/db/?f=a47ae9a60d3cdbe5e366b5d48b5832df0899bc50

please help...

Thanks in advance
Satish

lidex
June 18th, 2011, 05:24 AM
Hi,

I am having the similar problem...
I have uploaded the details requested on
http://www.alsa-project.org/db/?f=a47ae9a60d3cdbe5e366b5d48b5832df0899bc50

please help...

Thanks in advance
Satish
What is the make/model of your computer/motherboard?

satishkhandekar
June 18th, 2011, 07:47 AM
Hi,
The details are as follows:
MotherBoard - Intel H55 Express
Processor - Intel Core i3

Please let me know if anything else is needed...

Thanks
Satish

BlackScript
June 18th, 2011, 03:27 PM
Use the alsa-info-script to provide detailed information.
Run this command in a terminal:

wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh
Choose the upload option and provide a link for the output.
[Terminal="Applications->Accessories->Terminal"]

Hi,

thank you for you answer ...

the Informations you wanted are located at :

http://www.alsa-project.org/db/?f=6ba01084922ec90fc4691199482794684f568655

lidex
June 18th, 2011, 09:11 PM
Hi,

thank you for you answer ...

the Informations you wanted are located at :

http://www.alsa-project.org/db/?f=6ba01084922ec90fc4691199482794684f568655

Try this using a Terminal="Applications->Accessories->Terminal"

echo "options snd-hda-intel model=auto probe_mask=1" | sudo tee -a /etc/modprobe.d/alsa-base.conf Reboot

satishkhandekar
June 20th, 2011, 07:46 AM
What is the make/model of your computer/motherboard?


Hi,
I have recently uprated from ubuntu 10 to 11.04. There is no option in sound preferences for selecting srround 5.1.
The details are as follows:
MotherBoard - Intel H55 Express
Processor - Intel Core i3

Please let me know if anything else is needed...

Thanks
Satish

jonnybignote
July 29th, 2011, 11:10 PM
hope its ok to piggyback on this thread but I'm stumped... Ubuntu 11.04 64bit ALSA on integrated Realtek ALC887. Running over iec958 and I constantly get squeeling or white noise sound. I have previously tried updating ALSA via update script to latest version with no change. Any surround sound files/discs work flawlessly. Using Mythtv tuned to digital tv signals works fine. Playing content on youtube through web browser also appears to work fine.. It appears to be files sending stereo signals over optical such as mp3 or the like. It is not particular to any one app. I'm wondering if I need to install PulseAudio for playing my music over xbmc etc as a way of getting round it.

ANy advice greatly appreciated

entaroadun
August 14th, 2011, 05:42 PM
http://www.alsa-project.org/db/?f=f33f0ef7054803a25f82c3f209c89bea17c427d5 here is my inf and my mother board is intel DQ67SW running a core i5 processor can u tell me if i can get soround i have 5.1 speakers

lidex
August 17th, 2011, 02:55 AM
http://www.alsa-project.org/db/?f=f33f0ef7054803a25f82c3f209c89bea17c427d5 here is my inf and my mother board is intel DQ67SW running a core i5 processor can u tell me if i can get soround i have 5.1 speakers

Your board supports it. You may need to add a model name to alsa-base.conf to get a channel element in alsamixer, which you then change to 6.

Try this using a Terminal="Applications->Accessories->Terminal"

echo "options snd-hda-intel model=3stack-6ch" | sudo tee -a /etc/modprobe.d/alsa-base.conf Reboot

Then alsamixer
Alsamixer
Using a Terminal="Applications->Accessories->Terminal"

alsamixer
Press <F6> to select the correct soundcard.
Press <F3> to show playback levels. <F4> selects capture levels [or use <Tab>]
Use the left/right arrow keys to select and up/down arrow keys to change levels. <M> to mute/unmute.

After that select a 5.1 surround profile in your sound preferences.

GreekFreak
August 17th, 2011, 11:50 PM
Hi all,

I am having the same problem.

I have 2 speakers now after adding the following line to my alsa-base.conf file:
"options snd-hda-intel model=generic"

I ran the "wget" code and got the following:
http://www.alsa-project.org/db/?f=a6bc4db549ef5fddc4f929c13af32f0aee780aa6

Motherboard: Gigabyte GA-X58A-UD7
Processor: i7 950
Sound: Intel HDA

5.1 works perfectly on Windows 7 (I'm dual booting)

Any help would be greatly appreciated.

Thanks
Theo

lidex
August 18th, 2011, 06:17 AM
Hi all,

I am having the same problem.

I have 2 speakers now after adding the following line to my alsa-base.conf file:
"options snd-hda-intel model=generic"

I ran the "wget" code and got the following:
http://www.alsa-project.org/db/?f=a6bc4db549ef5fddc4f929c13af32f0aee780aa6

Motherboard: Gigabyte GA-X58A-UD7
Processor: i7 950
Sound: Intel HDA

5.1 works perfectly on Windows 7 (I'm dual booting)

Any help would be greatly appreciated.

Thanks
Theo

You should follow the instructions in post #11 with a small change. Replace the model name in alsa-base.conf with 6stack-dig.
To edit:

gksudo gedit /etc/modprobe.d/alsa-base.conf
Find this line:

options snd-hda-intel model=generic
Change it to:

options snd-hda-intel model=6stack-dig
Save. Close. Reboot.

GreekFreak
August 18th, 2011, 08:07 PM
You should follow the instructions in post #11 with a small change. Replace the model name in alsa-base.conf with 6stack-dig.
To edit:

gksudo gedit /etc/modprobe.d/alsa-base.conf
Find this line:

options snd-hda-intel model=generic
Change it to:

options snd-hda-intel model=6stack-dig
Save. Close. Reboot.

Thanks lidex,

I edited the file, and followed the instructions on post #11.

After selecting "Analog surround 5.1 output" on my Sound Preferences, and putting all the volumes to full, I managed to hear my woofer and centre speaker (not sure why they have to be at full volume, but anyway). However I have no sound in the rear speakers. I ran the alsamixer, and "Front" is there but no "Rear". The Card I have selected is "HDA Intel".

Here is the sound inf upload again (after the changes) just in case: http://www.alsa-project.org/db/?f=c90fdc6874c52fccf4c94e2ee3507ec073624278

I thought about purging the alsa drivers and reinstalling them and trying again, but wasn't sure if my problem needs that.

Again, any help would be appreciated. Should I not be editing a file with the channel numbers (I think I did that in an older Ubuntu version I ran once, I think with Pulse)

Thanks again in advance

lidex
August 20th, 2011, 07:29 AM
Thanks lidex,

I edited the file, and followed the instructions on post #11.

After selecting "Analog surround 5.1 output" on my Sound Preferences, and putting all the volumes to full, I managed to hear my woofer and centre speaker (not sure why they have to be at full volume, but anyway). However I have no sound in the rear speakers. I ran the alsamixer, and "Front" is there but no "Rear". The Card I have selected is "HDA Intel".



You'll need to fix the typo in alsa-base.conf
Your model now reads as model=genericstack-dig, should be model=6stack-dig
Reboot after fixing that then in alsamixer set channels to 6 then select surround profile in sound preferences.

GreekFreak
August 20th, 2011, 03:19 PM
You'll need to fix the typo in alsa-base.conf
Your model now reads as model=genericstack-dig, should be model=6stack-dig
Reboot after fixing that then in alsamixer set channels to 6 then select surround profile in sound preferences.

Ok, I've made the corrections, got the info (http://www.alsa-project.org/db/?f=6cd886b0dbf87a4bc236ee7c2933b107db167e8d) which shows the correct model, and selected 6ch from alsamixer.

I still don't see Rear speakers in alsamixer, though, and VLC still does not give me the Audio option to select 5.1 (for an mkv file). In the Sound Preferences I have selected "Analog Surround 5.1 Output"

lidex
August 20th, 2011, 08:43 PM
Ok, I've made the corrections, got the info (http://www.alsa-project.org/db/?f=6cd886b0dbf87a4bc236ee7c2933b107db167e8d) which shows the correct model, and selected 6ch from alsamixer.

I still don't see Rear speakers in alsamixer, though, and VLC still does not give me the Audio option to select 5.1 (for an mkv file). In the Sound Preferences I have selected "Analog Surround 5.1 Output"

I don't know you will see "rear". You've got "front", "side" and "surround". What about your profile BTW?

GreekFreak
August 20th, 2011, 09:38 PM
I don't know you will see "rear". You've got "front", "side" and "surround". What about your profile BTW?

Yes I do see Side and Surround, and I have put them both on full. I think you're right, Rear might be only for 7.1. Still Nothing.

If by profile you mean what I have selected in Sound Preferences->Hardware, then I have selected "Analog Surround 5.1 Output".

I'm trying to sort this out lie this before I perform all these steps in this: https://help.ubuntu.com/community/SoundTroubleshootingProcedure

GreekFreak
August 22nd, 2011, 12:27 AM
OK this is odd. I just realised that when I play music from the internet (radio streaming) I hear music from my 2 side speakers as well (no woofer). I still can't hear it in the Test Speakers (of the sound preferences) and VLC (Audio Devices option disabled)

lidex
August 22nd, 2011, 06:33 AM
OK this is odd. I just realised that when I play music from the internet (radio streaming) I hear music from my 2 side speakers as well (no woofer). I still can't hear it in the Test Speakers (of the sound preferences) and VLC (Audio Devices option disabled)

You'll want your vlc audio out set to pulseaudio. If you don't have pulseaudio volume control, install it:

sudo apt-get install pavucontrol
Start up some music and check the output devices tab.
You also may want to try the daemon.conf edit.

gksudo gedit /etc/pulse/daemon.conf
and change this line:

; default-sample-channels = 2
to this:

default-sample-channels = 6

GreekFreak
August 22nd, 2011, 09:56 PM
You'll want your vlc audio out set to pulseaudio. If you don't have pulseaudio volume control, install it:

sudo apt-get install pavucontrol
Start up some music and check the output devices tab.
You also may want to try the daemon.conf edit.

gksudo gedit /etc/pulse/daemon.conf
and change this line:

; default-sample-channels = 2
to this:

default-sample-channels = 6

Thank you lidex, that worked (except for 2 things).

I installed pavucontrol and changed the channels to 6, as well as selected PulseAudio in VLC. Now when I have a movie with 5.1 it preselects it, even though the "Audio->Device" option is still disabled.

The problems are that when I play a .avi file with Stereo or an mp3 (2 channel) I have no woofer. Now I know most people will say "how can you want 5.1 when it doesn't have any". Thing is if Windows can do it, then I know Ubuntu can, and I had done when I used to use Ubuntu 8.04. I basically want the woofer to pick up the low res sounds. In windows it's called "Bass Management" or "Bass Enabled".

I tried switching to ALSA, which leaves the "Audio->Device" enabled (I was trying things out) and I would get this error:

Quote
--
Audio output failed:
The audio device "surround51" is already in use.
Audio output failed:
VLC could not open the ALSA device "surround51" (Device or resource busy).
--
Unquote

I put the PulseAudio settings back.

Thanks again for your help.

lidex
August 22nd, 2011, 11:03 PM
Sorry I don't have the time to analyze this right now, but here are some links that may put you on the right path:
http://forums.opensuse.org/english/get-technical-help-here/hardware/407603-snd-hda-intel-alsa-5-1-audio.html
http://ubuntuforums.org/showthread.php?t=1491347
http://ubuntuforums.org/showthread.php?t=795525
http://ubuntuforums.org/showthread.php?t=1305889
http://ubuntuforums.org/showthread.php?t=1640574
http://ubuntuforums.org/showthread.php?t=1507371
http://www.halfgaar.net/surround-sound-in-linux
http://www.sabi.co.uk/Notes/linuxSoundALSA.html

GreekFreak
August 23rd, 2011, 09:00 AM
Sorry I don't have the time to analyze this right now, but here are some links that may put you on the right path:
http://forums.opensuse.org/english/get-technical-help-here/hardware/407603-snd-hda-intel-alsa-5-1-audio.html
http://ubuntuforums.org/showthread.php?t=1491347
http://ubuntuforums.org/showthread.php?t=795525
http://ubuntuforums.org/showthread.php?t=1305889
http://ubuntuforums.org/showthread.php?t=1640574
http://ubuntuforums.org/showthread.php?t=1507371
http://www.halfgaar.net/surround-sound-in-linux
http://www.sabi.co.uk/Notes/linuxSoundALSA.html

Thank you very much lidex. You have been extremely helpful. When I solve this I'll add a post here (or make a new one if you recommend it) about what I did to fix everything, including your steps.

Again, Thanks a alot :D

KruayFu
September 1st, 2011, 09:57 PM
Hello,

I get only stereo sound with my surround sound in ubuntu:

-I ran the script from alsa-project.org

http://www.alsa-project.org/db/?f=d65ead655ac6b7466a9d60cc1f51c1cc57eaa235

I tried all your adivces, my computer is custom build, so I thought this line would do it:


snd-hda-intel: model=6stack-digbut it didn't.

-I istalled alsa, added the line then I restarted and changed to "Analog surround 5.1 Output" in the Mixer.

I did also check alsamixer and there is also another thing i do not understand, I got a 5.1 system with 6 channels, but the stereo sound is only working when I take 8 channels..

I also did this tutorial:
http://wiki.ubuntuusers.de/Soundkarten_konfigurieren/HDA?redirect=no

Thanks for help!

creador4
December 25th, 2012, 07:53 PM
Hi,

i got no surround-sound with my nb which running 11.04 x64

i only got sound on "front right" and "front left" i already tried
everything what i found in the Internet. setting a profile in sound settings will not change anything... in the alsamixer all channels are enabled and max volume.

about my hardware (what alsamixer shows)

Device: HDA Intel
Chip: Nvidia MCP77/78 HDMI

any ideas ?



Thank You


- BlackScript

The problem is gone if you do this:


gksudo gedit /etc/modprobe.d/alsa-base.conf

search this line:

options snd-hda-intel model=generic

if its there, change that for:

options snd-hda-intel model=6stack-dig

If not add it. And Restart.